summaryrefslogtreecommitdiffstats
path: root/python/pyOpenSSL
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-16 07:46:30 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-16 07:46:30 +0700
commit5fe4384f823cd9ef98d3ff3f2db23439294e7ad7 (patch)
tree922db79741ea265e9d8afef8a37eecd18e347727 /python/pyOpenSSL
parentbb4cf60a73d05597354572766eab6f0ee4604eea (diff)
downloadslackbuilds-5fe4384f823cd9ef98d3ff3f2db23439294e7ad7.tar.gz
slackbuilds-5fe4384f823cd9ef98d3ff3f2db23439294e7ad7.tar.xz
python/pyOpenSSL: Change to python3 modules only.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pyOpenSSL')
-rw-r--r--python/pyOpenSSL/README3
-rw-r--r--python/pyOpenSSL/pyOpenSSL.SlackBuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/python/pyOpenSSL/README b/python/pyOpenSSL/README
index 70e1a0d826..dbbca3b70e 100644
--- a/python/pyOpenSSL/README
+++ b/python/pyOpenSSL/README
@@ -2,3 +2,6 @@ Python wrapper around a small subset of the OpenSSL library. Includes:
X509 Certificates, SSL Context objects, SSL Connection objects using
Python sockets as transport layer. The Connection object wraps all the
socket methods and can therefore be used in.
+
+This package only build python3 modules.
+If you need python2 modules, please install python2-pyOpenSSL package.
diff --git a/python/pyOpenSSL/pyOpenSSL.SlackBuild b/python/pyOpenSSL/pyOpenSSL.SlackBuild
index 1b411b0962..6d83a9365a 100644
--- a/python/pyOpenSSL/pyOpenSSL.SlackBuild
+++ b/python/pyOpenSSL/pyOpenSSL.SlackBuild
@@ -31,7 +31,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pyOpenSSL
VERSION=${VERSION:-22.1.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,7 +82,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \