summaryrefslogtreecommitdiffstats
path: root/python/git-fame
diff options
context:
space:
mode:
author Andrew Clemons <andrew.clemons@gmail.com>2022-10-13 18:13:39 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-15 10:47:40 +0700
commit68c7f3f4def43856559451bde108178f08a0512e (patch)
treee84436fa2ad4c2a54b4f833d5dc11bd84c6eebde /python/git-fame
parent6f7088fe28d7f930731c5d6fc596899e1a763d18 (diff)
downloadslackbuilds-68c7f3f4def43856559451bde108178f08a0512e.tar.gz
slackbuilds-68c7f3f4def43856559451bde108178f08a0512e.tar.xz
python/git-fame: Updated for version 1.15.2.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/git-fame')
-rw-r--r--python/git-fame/git-fame.SlackBuild8
-rw-r--r--python/git-fame/git-fame.info8
2 files changed, 7 insertions, 9 deletions
diff --git a/python/git-fame/git-fame.SlackBuild b/python/git-fame/git-fame.SlackBuild
index 076708a375..1103bf4337 100644
--- a/python/git-fame/git-fame.SlackBuild
+++ b/python/git-fame/git-fame.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for git-fame
# Copyright 2017-2021 Andrew Clemons, Wellington New Zealand
+# Copyright 2022 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=git-fame
-VERSION=${VERSION:-1.15.1}
+VERSION=${VERSION:-1.15.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,7 +77,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/git-fame/git-fame.info b/python/git-fame/git-fame.info
index b4f9198285..5d3a7e0b7a 100644
--- a/python/git-fame/git-fame.info
+++ b/python/git-fame/git-fame.info
@@ -1,10 +1,10 @@
PRGNAM="git-fame"
-VERSION="1.15.1"
+VERSION="1.15.2"
HOMEPAGE="https://pypi.python.org/pypi/git-fame"
-DOWNLOAD="https://files.pythonhosted.org/packages/59/83/5820a5f114822a23e56cdd60e156ba52822d4430b37ba3f68b2a800d56ee/git-fame-1.15.1.tar.gz"
-MD5SUM="7155db82b6addc8d9c4f91d8533d3e24"
+DOWNLOAD="https://files.pythonhosted.org/packages/74/46/c12bfce3a2963ca9db64acc98e0bfbb3098044b8dbbef5a3eb87401496f9/git-fame-1.15.2.tar.gz"
+MD5SUM="55c1662df266bf0b254bd4e6f8207649"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-argopt docopt tqdm python2-tabulate"
+REQUIRES="python-argopt docopt tqdm python3-tabulate"
MAINTAINER="Andrew Clemons"
EMAIL="andrew.clemons@gmail.com"