summaryrefslogtreecommitdiffstats
path: root/python/click
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-08-31 05:13:43 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-02 18:02:36 +0700
commitd61392036219ad05cc13051115757778b405a2b9 (patch)
tree9fa368b07e47c671d299fa932da7a9535a88f082 /python/click
parenta62f37b229e9f93484f9bffd421d931b197e88cd (diff)
downloadslackbuilds-d61392036219ad05cc13051115757778b405a2b9.tar.gz
slackbuilds-d61392036219ad05cc13051115757778b405a2b9.tar.xz
python/click: Updated for version 8.1.7.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/click')
-rw-r--r--python/click/click.SlackBuild14
-rw-r--r--python/click/click.info6
2 files changed, 10 insertions, 10 deletions
diff --git a/python/click/click.SlackBuild b/python/click/click.SlackBuild
index 477f06355d..b72b7dc76b 100644
--- a/python/click/click.SlackBuild
+++ b/python/click/click.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for click
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -29,7 +29,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=click
-VERSION=${VERSION:-8.1.3}
+VERSION=${VERSION:-8.1.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -42,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -63,6 +60,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -79,9 +79,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/click/click.info b/python/click/click.info
index 06bfa6e411..8a6db6e40e 100644
--- a/python/click/click.info
+++ b/python/click/click.info
@@ -1,8 +1,8 @@
PRGNAM="click"
-VERSION="8.1.3"
+VERSION="8.1.7"
HOMEPAGE="https://github.com/mitsuhiko/click"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/c/click/click-8.1.3.tar.gz"
-MD5SUM="a804b085de7a3ff96968e38e0f6f2e05"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/c/click/click-8.1.7.tar.gz"
+MD5SUM="7c3b52c56fd30699f453a7dc7b42cecb"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""