summaryrefslogtreecommitdiffstats
path: root/python/Kallithea
diff options
context:
space:
mode:
author Arn0 <yth@ythogtha.org>2022-03-08 19:46:43 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 12:25:24 +0700
commit81e7607855cad1a95651f4217472ddded930bc2c (patch)
tree836b6e6d687d00df65b412ed68dc15b0bcb55dd6 /python/Kallithea
parent7f07fe0bf0b69ad99926f1b9ae44411e5556817a (diff)
downloadslackbuilds-81e7607855cad1a95651f4217472ddded930bc2c.tar.gz
slackbuilds-81e7607855cad1a95651f4217472ddded930bc2c.tar.xz
python/Kallithea: updated for version 0.7.0, and python3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/Kallithea')
-rw-r--r--python/Kallithea/Kallithea.SlackBuild4
-rw-r--r--python/Kallithea/Kallithea.info8
-rw-r--r--python/Kallithea/README3
-rw-r--r--python/Kallithea/versions.patch112
4 files changed, 71 insertions, 56 deletions
diff --git a/python/Kallithea/Kallithea.SlackBuild b/python/Kallithea/Kallithea.SlackBuild
index 36e015aa60..7d417abd89 100644
--- a/python/Kallithea/Kallithea.SlackBuild
+++ b/python/Kallithea/Kallithea.SlackBuild
@@ -23,7 +23,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=Kallithea
-VERSION=${VERSION:-0.4.1}
+VERSION=${VERSION:-0.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -65,7 +65,7 @@ find -L . \
cat $CWD/versions.patch | patch -p1 || exit 1
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING README.rst CONTRIBUTORS LICENSE* MANIFEST.in MIT* $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/Kallithea/Kallithea.info b/python/Kallithea/Kallithea.info
index 304a96df7a..2dba383adb 100644
--- a/python/Kallithea/Kallithea.info
+++ b/python/Kallithea/Kallithea.info
@@ -1,10 +1,10 @@
PRGNAM="Kallithea"
-VERSION="0.4.1"
+VERSION="0.7.0"
HOMEPAGE="https://kallithea-scm.org/"
-DOWNLOAD="https://pypi.python.org/packages/source/K/Kallithea/Kallithea-0.4.1.tar.gz"
-MD5SUM="73b9fd1aa456313d004e342398735580"
+DOWNLOAD="https://pypi.python.org/packages/source/K/Kallithea/Kallithea-0.7.0.tar.gz"
+MD5SUM="59109139636cd3323ce3cdb7bcb52ad3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="cffi alembic waitress WebOb FormEncode SQLAlchemy babel python2-dateutil Markdown dulwich decorator bleach click bcrypt Whoosh celery URLObject Routes Paste Beaker WebHelpers TurboGears2 tgext.routes backlash gearbox"
+REQUIRES="python3-celery python3-tgext.routes python3-gearbox python3-paginate_sqlalchemy python3-alembic python3-bcrypt python3-babel python3-backlash bleach python3-formencode python-importlib_metadata python3-beaker decorator python3-dulwich python3-ipaddr python3-paste python3-dateutil python3-urlobject python3-waitress python3-webhelpers2 python3-whoosh kallithea-frontend"
MAINTAINER="Yth - Arnaud"
EMAIL="yth@ythogtha.org"
diff --git a/python/Kallithea/README b/python/Kallithea/README
index e3455c789f..521682f0d1 100644
--- a/python/Kallithea/README
+++ b/python/Kallithea/README
@@ -5,3 +5,6 @@ interface that is easy to use for users and admins.
You can install Kallithea on your own server and host repositories for
the version control system of your choice.
+
+kallithea-frontend is required for offline installation.
+Else nodejs is required, to install frontend requirements, online. \ No newline at end of file
diff --git a/python/Kallithea/versions.patch b/python/Kallithea/versions.patch
index 9c9c1e6849..c71322a709 100644
--- a/python/Kallithea/versions.patch
+++ b/python/Kallithea/versions.patch
@@ -1,68 +1,80 @@
diff -c a/setup.py b/setup.py
-*** a/setup.py 2019-03-31 21:31:17.000000000 +0200
---- b/setup.py 2019-06-12 15:39:28.093303343 +0200
+*** a/setup.py 2022-03-04 15:53:59.833416704 +0100
+--- b/setup.py 2022-03-04 16:25:30.117462854 +0100
***************
-*** 37,67 ****
+*** 41,77 ****
+ is_windows = __platform__ in ['Windows']
+
requirements = [
-! "alembic >= 0.8.0, < 1.1",
- "gearbox < 1",
-! "waitress >= 0.8.8, < 1.2",
-! "WebOb >= 1.7, < 1.8", # turbogears2 2.3.12 requires WebOb<1.8.0
+! "alembic >= 1.0.10, < 1.5",
+ "gearbox >= 0.1.0, < 1",
+! "waitress >= 0.8.8, < 1.5",
+ "WebOb >= 1.8, < 1.9",
"backlash >= 0.1.2, < 1",
-! "TurboGears2 >= 2.3.10, < 2.4",
+ "TurboGears2 >= 2.4, < 2.5",
"tgext.routes >= 0.2.0, < 1",
- "Beaker >= 1.7.0, < 2",
- "WebHelpers >= 1.3, < 1.4",
- "FormEncode >= 1.2.4, < 1.4",
-! "SQLAlchemy >= 1.1, < 1.3",
-! "Mako >= 0.9.0, < 1.1",
-! "Pygments >= 2.0, < 2.3",
- "Whoosh >= 2.5.0, < 2.8",
-! "celery >= 3.1, < 4.0", # celery 4 doesn't work
-! "Babel >= 1.3, < 2.7",
-! "python-dateutil >= 1.5.0, < 2.8",
-! "Markdown >= 2.2.1, < 2.7",
- "docutils >= 0.11, < 0.15",
+ "Beaker >= 1.10.1, < 2",
+ "WebHelpers2 >= 2.0, < 2.1",
+! "FormEncode >= 1.3.1, < 1.4",
+! "SQLAlchemy >= 1.2.9, < 1.4",
+ "Mako >= 0.9.1, < 1.2",
+! "Pygments >= 2.2.0, < 2.7",
+ "Whoosh >= 2.7.1, < 2.8",
+! "celery >= 5, < 5.1",
+! "Babel >= 1.3, < 2.9",
+ "python-dateutil >= 2.1.0, < 2.9",
+! "Markdown >= 2.2.1, < 3.2",
+! "docutils >= 0.11, < 0.17",
"URLObject >= 2.3.4, < 2.5",
-! "Routes >= 1.13, < 2",
- "dulwich >= 0.14.1, < 0.20",
-! "mercurial >= 4.1.1, < 4.10",
-! "decorator >= 3.3.2, < 4.4",
-! "Paste >= 2.0.3, < 3.1",
-! "bleach >= 3.0, < 3.1",
-! "Click >= 7.0, < 8",
+! "Routes >= 2.0, < 2.5",
+! "dulwich >= 0.19.0, < 0.20",
+! "mercurial >= 5.2, < 5.9",
+! "decorator >= 4.2.1, < 4.5",
+! "Paste >= 2.0.3, < 3.5",
+! "bleach >= 3.0, < 3.1.4",
+ "Click >= 7.0, < 8",
+ "ipaddr >= 2.2.0, < 2.3",
+ "paginate >= 0.5, < 0.6",
+ "paginate_sqlalchemy >= 0.3.0, < 0.4",
+! "bcrypt >= 3.1.0, < 3.2",
+ "pip >= 20.0, < 999",
+ "chardet >= 3",
]
+--- 41,77 ----
+ is_windows = __platform__ in ['Windows']
- if sys.version_info < (2, 7):
---- 37,67 ----
requirements = [
-! "alembic >= 0.8.0",
- "gearbox < 1",
+! "alembic >= 1.0.10",
+ "gearbox >= 0.1.0, < 1",
! "waitress >= 0.8.8",
-! "WebOb >= 1.7",
+ "WebOb >= 1.8, < 1.9",
"backlash >= 0.1.2, < 1",
-! "TurboGears2 >= 2.3.10",
+ "TurboGears2 >= 2.4, < 2.5",
"tgext.routes >= 0.2.0, < 1",
- "Beaker >= 1.7.0, < 2",
- "WebHelpers >= 1.3, < 1.4",
- "FormEncode >= 1.2.4, < 1.4",
-! "SQLAlchemy >= 1.1",
-! "Mako >= 0.9.0",
-! "Pygments >= 2.0",
- "Whoosh >= 2.5.0, < 2.8",
-! "celery >= 3.1, < 4.0", # celery 4 doesn't work
+ "Beaker >= 1.10.1, < 2",
+ "WebHelpers2 >= 2.0, < 2.1",
+! "FormEncode >= 1.3.1",
+! "SQLAlchemy >= 1.2.9",
+ "Mako >= 0.9.1, < 1.2",
+! "Pygments >= 2.2.0",
+ "Whoosh >= 2.7.1, < 2.8",
+! "celery >= 5",
! "Babel >= 1.3",
-! "python-dateutil >= 1.5.0",
+ "python-dateutil >= 2.1.0, < 2.9",
! "Markdown >= 2.2.1",
- "docutils >= 0.11, < 0.15",
+! "docutils >= 0.11",
"URLObject >= 2.3.4, < 2.5",
-! "Routes >= 1.13",
- "dulwich >= 0.14.1, < 0.20",
-! "mercurial >= 4.1.1",
-! "decorator >= 3.3.2",
+! "Routes >= 2.0",
+! "dulwich >= 0.19.0",
+! "mercurial >= 5.2",
+! "decorator >= 4.2.1",
! "Paste >= 2.0.3",
! "bleach >= 3.0",
-! "Click >= 7.0",
+ "Click >= 7.0, < 8",
+ "ipaddr >= 2.2.0, < 2.3",
+ "paginate >= 0.5, < 0.6",
+ "paginate_sqlalchemy >= 0.3.0, < 0.4",
+! "bcrypt >= 3.1.0",
+ "pip >= 20.0, < 999",
+ "chardet >= 3",
]
-
- if sys.version_info < (2, 7):