summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author Alexander Verbovetsky <alik@ejik.org>2024-04-14 10:57:51 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-14 11:22:03 +0700
commit13775155ede1faa058f3ce739db1ede6124acf30 (patch)
tree46e4d4a72c3d7f5baadfcdf1715163c42b6ee5f3 /misc
parent822c1731f659f845ce9ad2597234abe472418486 (diff)
downloadslackbuilds-13775155ede1faa058f3ce739db1ede6124acf30.tar.gz
slackbuilds-13775155ede1faa058f3ce739db1ede6124acf30.tar.xz
misc/bee-host: Added (native messaging host application).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/bee-host/README10
-rw-r--r--misc/bee-host/bee-host.SlackBuild114
-rw-r--r--misc/bee-host/bee-host.info10
-rw-r--r--misc/bee-host/slack-desc19
4 files changed, 153 insertions, 0 deletions
diff --git a/misc/bee-host/README b/misc/bee-host/README
new file mode 100644
index 0000000000..ba0fb101cd
--- /dev/null
+++ b/misc/bee-host/README
@@ -0,0 +1,10 @@
+Bee-host is a native messaging host application for Browser's External
+Editor extension, which allows to edit text fields with an external
+editor.
+
+Bee-host is required for the extension to work. The extension supports
+Mozilla Firefox, Google Chrome, and Chromium based browsers (Vivaldi,
+Brave, Mircosoft Edge, etc.). It can be installed from the Firefox and
+Chrome web stores:
+https://addons.mozilla.org/en-US/firefox/addon/external-editor/
+https://chromewebstore.google.com/detail/browsers-external-editor/moakhilhbeednkjahjmomncgigcoemoi
diff --git a/misc/bee-host/bee-host.SlackBuild b/misc/bee-host/bee-host.SlackBuild
new file mode 100644
index 0000000000..6273c371cf
--- /dev/null
+++ b/misc/bee-host/bee-host.SlackBuild
@@ -0,0 +1,114 @@
+#!/bin/bash
+
+# Slackware build script for bee-host
+
+# Copyright 2024, Alexander Verbovetsky, Moscow, Russia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=bee-host
+VERSION=${VERSION:-1.3.7.2}
+SVERSION="1.3.7-2"
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SVERSION
+tar xvf $CWD/$PRGNAM-$SVERSION.tar.gz
+cd $PRGNAM-$SVERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e 's|@BEECTL_MANIFEST_TARGET_PATH@|/usr/libexec/beectl|' \
+ *bee.json*
+install -Dm644 firefox*bee.json* \
+$PKG/usr/lib${LIBDIRSUFFIX}/mozilla/native-messaging-hosts/com.ruslan_osmanov.bee.json
+install -Dm644 chrome*bee.json* \
+$PKG/etc/opt/chrome/native-messaging-hosts/com.ruslan_osmanov.bee.json
+
+sed -i \
+ -e '/^# cJSON and cJSONUtils/,/^set(CJSON_DOWNLOAD_DIR "\${download_dir}")/d' \
+ -e '/^add_custom_command(TARGET beectl PRE_BUILD/,/COMMAND touch "\${CJSON_SOURCE_DIR}\/cJSON.c")/d' \
+ -e '/"\${CJSON_SOURCE_DIR}\/cJSON.c"/d' \
+ -e '/^add_dependencies(beectl cjson)/d' CMakeLists.txt
+
+mkdir -p build
+cd build
+ LDFLAGS+="-lcjson" cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ install -Dsm755 beectl -t $PKG/usr/libexec
+cd ..
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.* changelog $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/misc/bee-host/bee-host.info b/misc/bee-host/bee-host.info
new file mode 100644
index 0000000000..482bdfde9c
--- /dev/null
+++ b/misc/bee-host/bee-host.info
@@ -0,0 +1,10 @@
+PRGNAM="bee-host"
+VERSION="1.3.7.2"
+HOMEPAGE="https://github.com/rosmanov/bee-host"
+DOWNLOAD="https://github.com/rosmanov/bee-host/archive/1.3.7-2/bee-host-1.3.7-2.tar.gz"
+MD5SUM="27ca5456416ee0443d3af3594661999b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="cJSON %README%"
+MAINTAINER="Alexander Verbovetsky"
+EMAIL="alik@ejik.org"
diff --git a/misc/bee-host/slack-desc b/misc/bee-host/slack-desc
new file mode 100644
index 0000000000..c008783dab
--- /dev/null
+++ b/misc/bee-host/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+bee-host: bee-host (native messaging app)
+bee-host:
+bee-host: Bee-host is a native messaging host application for Browser's
+bee-host: External Editor extension, which allows to edit text fields with
+bee-host: an external editor.
+bee-host:
+bee-host: Bee-host is required for the extension to work. The extension
+bee-host: supports Mozilla Firefox, Google Chrome, and Chromium based
+bee-host: browsers (Vivaldi, Brave, Mircosoft Edge, etc.).
+bee-host:
+bee-host: Homepage: https://github.com/rosmanov/bee-host