summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-06-10 23:12:08 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-06-15 07:37:43 +0700
commit263f68e0abc41cff553f21d28feb09eb7dd65274 (patch)
tree7359a99fb38b0d8a7881920d9911bb2a2fed23cc /libraries
parentec2ddef383a6bf7963d35a48f631df9915c49a24 (diff)
downloadslackbuilds-263f68e0abc41cff553f21d28feb09eb7dd65274.tar.gz
slackbuilds-263f68e0abc41cff553f21d28feb09eb7dd65274.tar.xz
libraries/belle-sip: Removed (see #6724).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/belle-sip/README1
-rw-r--r--libraries/belle-sip/belle-sip.SlackBuild142
-rw-r--r--libraries/belle-sip/belle-sip.info12
-rw-r--r--libraries/belle-sip/gcc9.patch19
-rw-r--r--libraries/belle-sip/slack-desc19
5 files changed, 0 insertions, 193 deletions
diff --git a/libraries/belle-sip/README b/libraries/belle-sip/README
deleted file mode 100644
index 1f4bada577..0000000000
--- a/libraries/belle-sip/README
+++ /dev/null
@@ -1 +0,0 @@
-belle-sip is a C object oriented SIP Stack used by linphone.
diff --git a/libraries/belle-sip/belle-sip.SlackBuild b/libraries/belle-sip/belle-sip.SlackBuild
deleted file mode 100644
index dd31abe6bf..0000000000
--- a/libraries/belle-sip/belle-sip.SlackBuild
+++ /dev/null
@@ -1,142 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for belle-sip
-# Was written by Euan Thoms <euan at potensol dot com>
-
-# Copyright 2014 Euan Thoms United Kingdom
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# 20220422 bkw: Modified by SlackBuilds.org, BUILD=3:
-# - remove empty ChangeLog from doc dir.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=belle-sip
-VERSION=${VERSION:-1.6.3}
-SRCDIRNAM=${PRGNAM}-${VERSION}-0
-BUILD=${BUILD:-3}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-DOCS="AUTHORS COPYING NEWS README.md $CWD/$PRGNAM.SlackBuild"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf ${PRGNAM}-${VERSION}
-tar xvf $CWD/${PRGNAM}-${VERSION}.tar.gz
-if [ "${SRCDIRNAM}" != "${PRGNAM}-${VERSION}" ]
-then
- mv ${SRCDIRNAM} ${PRGNAM}-${VERSION}
-fi
-cp $CWD/antlr-*-complete.jar ${PRGNAM}-${VERSION}/antlr.jar
-cd ${PRGNAM}-${VERSION}
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-
-# Ensure java is in $PATH
-export PATH=$PATH:/usr/lib${LIBDIRSUFFIX}/java/bin
-
-# Ammend configure.ac for 64bit support and direct it to build dep antlr.jar
-cp configure.ac configure.ac.orig
-sed -i \
- -e "s|/lib\"|/lib${LIBDIRSUFFIX}\"|g" \
- -e "/^antlr_java_prefixes=/s|=.*$|=\"$(pwd)\"|g" \
- configure.ac
-autoreconf -ivf
-
-# Kill the accursed -Werror (fix for -current)
-SLKCFLAGS="$SLKCFLAGS -Wno-error"
-
-patch -p1 < $CWD/gcc9.patch
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-CPPFLAGS="${CPPFLAGS} -I/usr/include/antlr3" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --disable-silent-rules \
- --disable-static \
- --disable-tests \
- --enable-tls \
- --with-antlr=/usr \
- --build=$ARCH-slackware-linux
-
-make
-make install-strip DESTDIR=$PKG
-
-#find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- #| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION
-chmod 0644 $PKG/usr/doc/$PRGNAM-$VERSION/*
-
-rm -f $PKG/usr/lib*/*.la
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/belle-sip/belle-sip.info b/libraries/belle-sip/belle-sip.info
deleted file mode 100644
index a479743faa..0000000000
--- a/libraries/belle-sip/belle-sip.info
+++ /dev/null
@@ -1,12 +0,0 @@
-PRGNAM="belle-sip"
-VERSION="1.6.3"
-HOMEPAGE="http://www.linphone.org/technical-corner/belle-sip.html"
-DOWNLOAD="https://download.linphone.org/releases/old/sources/belle-sip/belle-sip-1.6.3.tar.gz \
- https://github.com/antlr/website-antlr3/raw/gh-pages/download/antlr-3.4-complete.jar"
-MD5SUM="90c40812d98671ad2f40621542500bc6 \
- 1b91dea1c7d480b3223f7c8a9aa0e172"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="bctoolbox zulu-openjdk8 libantlr3c"
-MAINTAINER="Euan Thoms"
-EMAIL="euan at potensol dot com"
diff --git a/libraries/belle-sip/gcc9.patch b/libraries/belle-sip/gcc9.patch
deleted file mode 100644
index 35fa1ceae0..0000000000
--- a/libraries/belle-sip/gcc9.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/src/dns.h b/src/dns.h
-index ac390ae..33d99de 100644
---- a/src/dns.h
-+++ b/src/dns.h
-@@ -158,14 +158,6 @@ DNS_PUBLIC int *dns_debug_p(void);
-
- #define dns_quietinit(...) \
- DNS_PRAGMA_PUSH DNS_PRAGMA_QUIET __VA_ARGS__ DNS_PRAGMA_POP
--#elif (__GNUC__ == 4 && __GNUC_MINOR__ >= 6) || __GNUC__ > 4
--#define DNS_PRAGMA_PUSH _Pragma("GCC diagnostic push")
--#define DNS_PRAGMA_QUIET _Pragma("GCC diagnostic ignored \"-Woverride-init\"")
--#define DNS_PRAGMA_POP _Pragma("GCC diagnostic pop")
--
--/* GCC parses the _Pragma operator less elegantly than clang. */
--#define dns_quietinit(...) \
-- __extension__ ({ DNS_PRAGMA_PUSH DNS_PRAGMA_QUIET __VA_ARGS__; DNS_PRAGMA_POP })
- #else
- #define DNS_PRAGMA_PUSH
- #define DNS_PRAGMA_QUIET
diff --git a/libraries/belle-sip/slack-desc b/libraries/belle-sip/slack-desc
deleted file mode 100644
index 1ae0797e4d..0000000000
--- a/libraries/belle-sip/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-belle-sip: belle-sip (A Voice-over-IP phone)
-belle-sip:
-belle-sip: Belle-SIP is a C object oriented SIP Stack used by Linphone.
-belle-sip:
-belle-sip: http://www.linphone.org/technical-corner/belle-sip/overview
-belle-sip:
-belle-sip:
-belle-sip:
-belle-sip:
-belle-sip:
-belle-sip: