summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Diniz Bortolotto <diniz.bortolotto@gmail.com>2024-03-07 10:23:02 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-03-09 06:18:10 +0700
commit1c3dba94bd21f57bc88b17ca01cf7fed9ec3ad2a (patch)
treed97aa664e330fb0cd9f68975ac60086085fbdbc6 /libraries
parent5a7bf80f5d7eb0149411cfad984637e87d21d38a (diff)
downloadslackbuilds-1c3dba94bd21f57bc88b17ca01cf7fed9ec3ad2a.tar.gz
slackbuilds-1c3dba94bd21f57bc88b17ca01cf7fed9ec3ad2a.tar.xz
libraries/mygpoclient: Updated for version 1.9.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/mygpoclient/README12
-rw-r--r--libraries/mygpoclient/mygpoclient.SlackBuild60
-rw-r--r--libraries/mygpoclient/mygpoclient.info10
-rw-r--r--libraries/mygpoclient/slack-desc14
4 files changed, 50 insertions, 46 deletions
diff --git a/libraries/mygpoclient/README b/libraries/mygpoclient/README
index 981cb48f67..e6a92cfdb4 100644
--- a/libraries/mygpoclient/README
+++ b/libraries/mygpoclient/README
@@ -1,6 +1,8 @@
-The mygpoclient library allows developers to utilize a Pythonic
-interface to the gpodder.net web services.
+This library provides an easy and structured way to access the
+gpodder.net web services. In addition to subscription list
+synchronization and storage, the advanced API support allows
+to upload and download episode status changes.
-Included is an example utility, bpsync, that will will synchronize your
-bp.conf file from BashPodder to the gpodder.net web services, check out
-http://lincgeek.org/bashpodder for more information.
+Documentation can be read online at
+
+http://mygpoclient.readthedocs.io/
diff --git a/libraries/mygpoclient/mygpoclient.SlackBuild b/libraries/mygpoclient/mygpoclient.SlackBuild
index 982b287f34..8196857746 100644
--- a/libraries/mygpoclient/mygpoclient.SlackBuild
+++ b/libraries/mygpoclient/mygpoclient.SlackBuild
@@ -2,14 +2,30 @@
# Slackware build script for mygpoclient
-# Written by Luis Henrique <lmello.009@gmail.com>
-
-# Edited by Chris Farrell <timcowchip@gorge.net>
+# Copyright 2024 Diniz Bortolotto <diniz.bortolotto@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mygpoclient
-VERSION=${VERSION:-1.8}
+VERSION=${VERSION:-1.9}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -22,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -34,20 +47,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -58,21 +57,24 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-sed -i -e 's:share/man/man1:man/man1:' setup.py
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i "s|share/man/man1|man/man1|" setup.py
+python3 setup.py build
python3 setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS COPYING NEWS PKG-INFO \
+ AUTHORS CONTRIBUTING.md COPYING NEWS README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/libraries/mygpoclient/mygpoclient.info b/libraries/mygpoclient/mygpoclient.info
index e5c5e89a3d..87c3e34cbb 100644
--- a/libraries/mygpoclient/mygpoclient.info
+++ b/libraries/mygpoclient/mygpoclient.info
@@ -1,10 +1,10 @@
PRGNAM="mygpoclient"
-VERSION="1.8"
+VERSION="1.9"
HOMEPAGE="https://github.com/gpodder/mygpoclient"
-DOWNLOAD="https://github.com/timcowchip/DISTFILES/raw/master/mygpoclient-1.8.tar.gz"
-MD5SUM="b2623c5c068ed137a8ce0f18229aaf7a"
+DOWNLOAD="https://github.com/gpodder/mygpoclient/archive/refs/tags/1.9.tar.gz"
+MD5SUM="c6f453c6f9be6eca935efe54e0db6556"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Chris Farrell"
-EMAIL="timcowchip@gorge.net"
+MAINTAINER="Diniz Bortolotto"
+EMAIL="diniz.bortolotto@gmail.com"
diff --git a/libraries/mygpoclient/slack-desc b/libraries/mygpoclient/slack-desc
index 1a803d8c1b..709fb1efbf 100644
--- a/libraries/mygpoclient/slack-desc
+++ b/libraries/mygpoclient/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-mygpoclient: mygpoclient (gpodder.net Client Library)
-mygpoclient:
-mygpoclient: The mygpoclient library allows developers to utilize a Pythonic
-mygpoclient: interface to the gpodder.net web services.
-mygpoclient:
-mygpoclient: Homepage: https://github.com/gpodder/mygpoclient
-mygpoclient:
+mygpoclient: mygpoclient (The gpodder.net Client Library)
mygpoclient:
+mygpoclient: This library provides an easy and structured way to access
+mygpoclient: the gpodder.net web services. In addition to subscription list
+mygpoclient: synchronization and storage, the advanced API support allows to
+mygpoclient: upload and download episode status changes.
mygpoclient:
+mygpoclient: Documentation can be read online at
+mygpoclient: http://mygpoclient.readthedocs.io/
mygpoclient:
mygpoclient: