summaryrefslogtreecommitdiffstats
path: root/libraries/vst3sdk
diff options
context:
space:
mode:
author Martin BĂ„ngens <noisecode3@gmail.com>2023-12-31 11:41:59 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-31 21:01:39 +0700
commit046ffd037f002b28a9d3d77cbd7ef0b12bc450d8 (patch)
treeb5ca79cbd78751a7633eb425da44b18c423675cc /libraries/vst3sdk
parent4100450acfb2776f3f702efb9882adae1a070801 (diff)
downloadslackbuilds-046ffd037f002b28a9d3d77cbd7ef0b12bc450d8.tar.gz
slackbuilds-046ffd037f002b28a9d3d77cbd7ef0b12bc450d8.tar.xz
libraries/vst3sdk: Updated for version 3.7.9
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/vst3sdk')
-rw-r--r--libraries/vst3sdk/vst3sdk.SlackBuild40
-rw-r--r--libraries/vst3sdk/vst3sdk.info20
2 files changed, 42 insertions, 18 deletions
diff --git a/libraries/vst3sdk/vst3sdk.SlackBuild b/libraries/vst3sdk/vst3sdk.SlackBuild
index c7caf6f8db..dac030aab0 100644
--- a/libraries/vst3sdk/vst3sdk.SlackBuild
+++ b/libraries/vst3sdk/vst3sdk.SlackBuild
@@ -25,13 +25,22 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=vst3sdk
-VERSION=${VERSION:-3.7.7}
-SDK_BUILD=${SDK_BUILD:-_build_19}
+VERSION=${VERSION:-3.7.9}
+SDK_BUILD=${SDK_BUILD:-_build_61}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
ARCH=noarch
+# git submodules
+BASE=4737789f52b4e2610a99257e9d93dcbe7717e72e
+CMAKE=3ad5b558e8f94a5825c5c4930a7ffd0760d68c43
+DOC=1a90e37662834a54aa5406eeaa8634027f7801f8
+PLUGINTERFACES=f0eeef7ca771f3cac2dfe1922dc5733349766c7b
+PUBLIC_SDK=e61ee76eb0f8771a05e99018bc4705ac1b603e48
+TUTORIALS=dc425c8e588a78147bc4c3616857b8918b809dcd
+VSTGUI=65c353fcad783dd6baa34a2b9dbe23bb9f88d035
+
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
@@ -49,26 +58,27 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$VERSION$SDK_BUILD
+tar xf $CWD/$PRGNAM-$VERSION$SDK_BUILD.tar.gz
+cd $PRGNAM-$VERSION$SDK_BUILD
chown -R root:root .
+mkdir -p $PKG/usr/include/vst3sdk/{base,cmake,pluginterfaces,public.sdk,tutorials,vstgui4}
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/doc
mkdir -p $PKG/usr/share/pkgconfig
-cp $CWD/vst3sdk.pc $PKG/usr/share/pkgconfig/
+cp $CWD/vst3sdk.pc $PKG/usr/share/pkgconfig
sed -i "s/VERSION/$VERSION$SDK_BUILD/g" $PKG/usr/share/pkgconfig/vst3sdk.pc
-mkdir -p $PKG/usr/include/vst3sdk
-cp -a base $PKG/usr/include/vst3sdk/
-cp -a cmake $PKG/usr/include/vst3sdk/
-cp -a pluginterfaces $PKG/usr/include/vst3sdk/
-cp -a public.sdk $PKG/usr/include/vst3sdk/
-cp -a vstgui4 $PKG/usr/include/vst3sdk/
-cp CMakeLists.txt $PKG/usr/include/vst3sdk/
+tar xvzf $CWD/vst3_base-$BASE.tar.gz --strip-components=1 -C $PKG/usr/include/vst3sdk/base
+tar xvzf $CWD/vst3_cmake-$CMAKE.tar.gz --strip-components=1 -C $PKG/usr/include/vst3sdk/cmake
+tar xvzf $CWD/vst3_doc-$DOC.tar.gz --strip-components=1 -C $PKG/usr/doc/$PRGNAM-$VERSION/doc
+tar xvzf $CWD/vst3_pluginterfaces-$PLUGINTERFACES.tar.gz --strip-components=1 -C $PKG/usr/include/vst3sdk/pluginterfaces
+tar xvzf $CWD/vst3_public_sdk-$PUBLIC_SDK.tar.gz --strip-components=1 -C $PKG/usr/include/vst3sdk/public.sdk
+tar xvzf $CWD/vst3_tutorials-$TUTORIALS.tar.gz --strip-components=1 -C $PKG/usr/include/vst3sdk/tutorials
+tar xvzf $CWD/vstgui-$VSTGUI.tar.gz --strip-components=1 -C $PKG/usr/include/vst3sdk/vstgui4
+cp CMakeLists.txt $PKG/usr/include/vst3sdk
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- doc/ \
LICENSE.txt \
README.md \
VST3_License_Agreement.pdf \
diff --git a/libraries/vst3sdk/vst3sdk.info b/libraries/vst3sdk/vst3sdk.info
index 2dd4469d83..63cfe6bb0c 100644
--- a/libraries/vst3sdk/vst3sdk.info
+++ b/libraries/vst3sdk/vst3sdk.info
@@ -1,8 +1,22 @@
PRGNAM="vst3sdk"
-VERSION="3.7.7"
+VERSION="3.7.9"
HOMEPAGE="https://www.steinberg.net/developers/"
-DOWNLOAD="https://github.com/noisecode3/vst3sdk/archive/3.7.7/vst3sdk-3.7.7.tar.gz"
-MD5SUM="f9e2185ea8cdfbdc4d99c4a5f5e4d426"
+DOWNLOAD="https://github.com/steinbergmedia/vst3sdk/archive/v3.7.9_build_61/vst3sdk-3.7.9_build_61.tar.gz \
+ https://github.com/steinbergmedia/vst3_base/archive/4737789/vst3_base-4737789f52b4e2610a99257e9d93dcbe7717e72e.tar.gz \
+ https://github.com/steinbergmedia/vst3_cmake/archive/3ad5b55/vst3_cmake-3ad5b558e8f94a5825c5c4930a7ffd0760d68c43.tar.gz \
+ https://github.com/steinbergmedia/vst3_doc/archive/1a90e37/vst3_doc-1a90e37662834a54aa5406eeaa8634027f7801f8.tar.gz \
+ https://github.com/steinbergmedia/vst3_pluginterfaces/archive/f0eeef7/vst3_pluginterfaces-f0eeef7ca771f3cac2dfe1922dc5733349766c7b.tar.gz \
+ https://github.com/steinbergmedia/vst3_public_sdk/archive/e61ee76/vst3_public_sdk-e61ee76eb0f8771a05e99018bc4705ac1b603e48.tar.gz \
+ https://github.com/steinbergmedia/vst3_tutorials/archive/dc425c8/vst3_tutorials-dc425c8e588a78147bc4c3616857b8918b809dcd.tar.gz \
+ https://github.com/steinbergmedia/vstgui/archive/65c353f/vstgui-65c353fcad783dd6baa34a2b9dbe23bb9f88d035.tar.gz"
+MD5SUM="463991d7841d15c719a7e06f052b70af\
+ 42f09893f870635fea4f689aa6b9de98\
+ 9017e25a9ccb87d2de14a7936a37e581\
+ 53f1eece19363900ccb9f49261e97ffd\
+ 739bd26a2c2e786d9338e13042e20ee6\
+ cdc51a80c28577308b037caeeb274dd2\
+ f040faf28ba22514fcbe13667c1435ff\
+ b332b0cce26311a2a419b162be53ea54"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""