summaryrefslogtreecommitdiffstats
path: root/libraries/moddb
diff options
context:
space:
mode:
author Ozan Türkyılmaz <ozan.turkyilmaz@gmail.com>2023-05-18 22:50:32 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:11 +0700
commitc727010a174407b69edb922cca7ea585736d0ffd (patch)
tree115817555373f096e556c6538f54141938e1334d /libraries/moddb
parentb7338e416b03a6902d9600d28757ffb1671670ef (diff)
downloadslackbuilds-c727010a174407b69edb922cca7ea585736d0ffd.tar.gz
slackbuilds-c727010a174407b69edb922cca7ea585736d0ffd.tar.xz
libraries/moddb: Added (navigate ModDB purely programmatically)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/moddb')
-rw-r--r--libraries/moddb/README8
-rw-r--r--libraries/moddb/moddb.SlackBuild98
-rw-r--r--libraries/moddb/moddb.info10
-rw-r--r--libraries/moddb/slack-desc19
4 files changed, 135 insertions, 0 deletions
diff --git a/libraries/moddb/README b/libraries/moddb/README
new file mode 100644
index 0000000000..d78ad23d5e
--- /dev/null
+++ b/libraries/moddb/README
@@ -0,0 +1,8 @@
+The goal of the library is to be able to navigate ModDB purely
+programmatically through scraping and parsing of the various models
+present on the website. This is based off a command of my bot which can
+parse either a game or a mod, this command gave birth to the original
+library which was extremely limited in its abilities and only able to
+parse a few pages with inconsistencies. This library is a much more
+mature and professional attempt at the whole idea, adding on a much
+deeper understanding of OOP.
diff --git a/libraries/moddb/moddb.SlackBuild b/libraries/moddb/moddb.SlackBuild
new file mode 100644
index 0000000000..31e98b838c
--- /dev/null
+++ b/libraries/moddb/moddb.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/bash
+
+# Slackware build script for moddb
+
+# Copyright 2023 Ozan Türkyılmaz Türkiye
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=moddb
+VERSION=${VERSION:-0.8.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/moddb/moddb.info b/libraries/moddb/moddb.info
new file mode 100644
index 0000000000..5863ba59ab
--- /dev/null
+++ b/libraries/moddb/moddb.info
@@ -0,0 +1,10 @@
+PRGNAM="moddb"
+VERSION="0.8.1"
+HOMEPAGE="https://github.com/ClementJ18/moddb"
+DOWNLOAD="https://github.com/ClementJ18/moddb/archive/v0.8.1/moddb-0.8.1.tar.gz"
+MD5SUM="868f7ec37fd53f639068cdd5c1ec7692"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Ozan Türkyılmaz"
+EMAIL="ozan.turkyilmaz@gmail.com"
diff --git a/libraries/moddb/slack-desc b/libraries/moddb/slack-desc
new file mode 100644
index 0000000000..a86b5da5be
--- /dev/null
+++ b/libraries/moddb/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+moddb: moddb (navigate ModDB purely programmatically)
+moddb:
+moddb: The goal of the library is to be able to navigate ModDB purely
+moddb: programmatically through scraping and parsing of the various models
+moddb: present on the website.
+moddb:
+moddb:
+moddb: https://github.com/ClementJ18/moddb
+moddb:
+moddb:
+moddb: