summaryrefslogtreecommitdiffstats
path: root/libraries/gdal/gdal.SlackBuild
diff options
context:
space:
mode:
author David Spencer <baildon.research@googlemail.com>2013-06-05 19:45:06 -0400
committer dsomero <xgizzmo@slackbuilds.org>2013-06-05 19:45:06 -0400
commit06435eea38af2693c641bc11f8d526a686b2a815 (patch)
tree973044dfe987abf3b322045f0e6f623891900378 /libraries/gdal/gdal.SlackBuild
parent9c74d9d473dbf2f2e7586c94f6a29ac88d64998f (diff)
downloadslackbuilds-06435eea38af2693c641bc11f8d526a686b2a815.tar.gz
slackbuilds-06435eea38af2693c641bc11f8d526a686b2a815.tar.xz
libraries/gdal: Updated for version 1.9.2.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries/gdal/gdal.SlackBuild')
-rw-r--r--libraries/gdal/gdal.SlackBuild38
1 files changed, 28 insertions, 10 deletions
diff --git a/libraries/gdal/gdal.SlackBuild b/libraries/gdal/gdal.SlackBuild
index 70fbdd5e97..109396aef6 100644
--- a/libraries/gdal/gdal.SlackBuild
+++ b/libraries/gdal/gdal.SlackBuild
@@ -24,7 +24,7 @@
# Maintained by David Spencer <baildon.research@googlemail.com>
PRGNAM=gdal
-VERSION=${VERSION:-1.9.1}
+VERSION=${VERSION:-1.9.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,9 +70,32 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# OpenCL, webp, Grass and Spatialite support need special arrangements.
+# Everything else is handled automatically by configure.
WITHLIST=""
-# Grass support is buggy. If you really want it,
-# here is an undocumented option to enable it :-/
+
+# Request OpenCL support:
+if [ ${OPENCL:-no} = "yes" ]; then
+ WITHLIST+=" --with-opencl"
+fi
+
+# Request webp support if it's installed:
+if pkg-config --exists libwebp; then
+ WITHLIST+=" --with-webp"
+fi
+
+# Spatialite support in gdal optionally has a circular dependency
+# via the postgis 'liblwgeom' library (postgis depends on gdal).
+# Here is an undocumented option to request Spatialite support,
+# if you promise to be careful :-)
+if pkg-config --exists spatialite; then
+ if [ ${SPATIALITE:-no} = "yes" ]; then
+ WITHLIST+=" --with-spatialite"
+ fi
+fi
+
+# Also, enabling Grass support in gdal introduces a circular dependency,
+# so here is another undocumented option.
if pkg-config --exists grass; then
if [ ${GRASS:-no} = "yes" ]; then
WITHLIST+=" --with-grass=$(pkg-config --variable=prefix grass)"
@@ -81,14 +104,9 @@ fi
# Thanks to the people at Arch for this:
patch -p0 <$CWD/gdal-python-install.patch
-# and to the ones at Gentoo for this:
-patch -p4 <$CWD/gdal-1.9.1-poppler-0.20.1.patch
-
-echo "ACLOCAL_AMFLAGS = -I m4" > Makefile.am
-autoreconf -i
-CFLAGS="$SLKCFLAGS -Wno-error" \
-CXXFLAGS="$SLKCFLAGS -Wno-error" \
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \