summaryrefslogtreecommitdiffstats
path: root/libraries/OpenSceneGraph
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-02-15 01:06:28 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-16 08:20:06 +0700
commit05d451f23314f4671ff7c4266fa415e4d64cbec5 (patch)
treeb8c8da5073cc168e28bc43c7fe82a8429ef4e332 /libraries/OpenSceneGraph
parent763d78b2793e74f5c10f6696217b410e4d9ae1be (diff)
downloadslackbuilds-05d451f23314f4671ff7c4266fa415e4d64cbec5.tar.gz
slackbuilds-05d451f23314f4671ff7c4266fa415e4d64cbec5.tar.xz
libraries/OpenSceneGraph: Fix build when asio is installed.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/OpenSceneGraph')
-rw-r--r--libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild14
-rw-r--r--libraries/OpenSceneGraph/disable_asio.diff13
2 files changed, 25 insertions, 2 deletions
diff --git a/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild b/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
index 3a5fd0e54e..6edeaadf7f 100644
--- a/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
+++ b/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
@@ -65,9 +65,19 @@ cd $PRGNAM-$PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# 20220215 bkw: asio is an optional, auto-detected dependency. Our
+# version of asio is either too new or too old for this. Note
+# that this is Asio (the network library for C++), not
+# ASIO (the Windows low-latency audio API) nor wineasio, nor
+# /usr/include/boost/asio.hpp, whatever that even is. I don't see a
+# way to disable asio support via a cmake variable, so it has to be
+# surgery. Applying this patch disables the RestHttpDevice plugin,
+# hope that's OK.
+patch -p1 < $CWD/disable_asio.diff
mkdir -p build
cd build
diff --git a/libraries/OpenSceneGraph/disable_asio.diff b/libraries/OpenSceneGraph/disable_asio.diff
new file mode 100644
index 0000000000..95f74b7316
--- /dev/null
+++ b/libraries/OpenSceneGraph/disable_asio.diff
@@ -0,0 +1,13 @@
+diff -Naur OpenSceneGraph-OpenSceneGraph-3.6.5/CMakeLists.txt OpenSceneGraph-OpenSceneGraph-3.6.5.patched/CMakeLists.txt
+--- OpenSceneGraph-OpenSceneGraph-3.6.5/CMakeLists.txt 2020-01-31 06:03:07.000000000 -0500
++++ OpenSceneGraph-OpenSceneGraph-3.6.5.patched/CMakeLists.txt 2022-02-15 01:01:02.259927943 -0500
+@@ -763,9 +763,6 @@
+ FIND_PACKAGE(GtkGl)
+ FIND_PACKAGE(DirectInput)
+ FIND_PACKAGE(NVTT)
+- IF (NOT WIN32)
+- FIND_PACKAGE(Asio)
+- ENDIF()
+ FIND_PACKAGE(ZeroConf)
+
+ FIND_PACKAGE(LIBLAS)