summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-01-12 04:41:55 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-01-14 08:50:32 +0700
commitda0ef06416256662d23277feaaf799f5c14943e8 (patch)
tree048d1ae0bbe91c2121d62cea749d3ca4093371ca /graphics
parent91b10c2fc521b39118cbc574864f6a833545e155 (diff)
downloadslackbuilds-da0ef06416256662d23277feaaf799f5c14943e8.tar.gz
slackbuilds-da0ef06416256662d23277feaaf799f5c14943e8.tar.xz
graphics/mcomix3: Removed (abandoned upstream; use mcomix instead).
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mcomix3/README13
-rw-r--r--graphics/mcomix3/doinst.sh15
-rw-r--r--graphics/mcomix3/git2tarxz.sh44
-rw-r--r--graphics/mcomix3/mcomix3.SlackBuild107
-rw-r--r--graphics/mcomix3/mcomix3.info10
-rw-r--r--graphics/mcomix3/slack-desc19
6 files changed, 0 insertions, 208 deletions
diff --git a/graphics/mcomix3/README b/graphics/mcomix3/README
deleted file mode 100644
index 5a531628f2..0000000000
--- a/graphics/mcomix3/README
+++ /dev/null
@@ -1,13 +0,0 @@
-mcomix3 (comic book reader)
-
-MComix is a user-friendly, customizable image viewer. It is
-specifically designed to handle comic books (both Western comics and
-manga) and supports a variety of container formats (including CBR,
-CBZ, CB7, CBT, LHA and PDF). MComix is a fork of Comix, and MComix3 is
-a Python3 fork of MComix.
-
-Optional runtime dependencies:
-
-- unrar (for .cbr support)
-- p7zip (for .cb7 support)
-- mupdf (for .pdf support)
diff --git a/graphics/mcomix3/doinst.sh b/graphics/mcomix3/doinst.sh
deleted file mode 100644
index 0254ea06d8..0000000000
--- a/graphics/mcomix3/doinst.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
-
-if [ -e usr/share/glib-2.0/schemas ]; then
- if [ -x /usr/bin/glib-compile-schemas ]; then
- /usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
- fi
-fi
diff --git a/graphics/mcomix3/git2tarxz.sh b/graphics/mcomix3/git2tarxz.sh
deleted file mode 100644
index 9271c6cd0e..0000000000
--- a/graphics/mcomix3/git2tarxz.sh
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/bin/sh
-
-# Create source tarball from git repo, with generated version
-# number.
-
-# Note that this script doesn't need to be run as root. It does
-# need to be able to write to the current directory it's run from.
-
-# Takes one optional argument, which is the commit or tag to create
-# a tarball of. With no arg, HEAD is used.
-
-PRGNAM=mcomix3
-CLONE_URL=https://github.com/multiSnow/mcomix3
-
-set -e
-
-GITDIR=$( mktemp -dt $PRGNAM.git.XXXXXX )
-rm -rf $GITDIR
-git clone $CLONE_URL $GITDIR
-
-CWD="$( pwd )"
-cd $GITDIR
-
-if [ "$1" != "" ]; then
- git reset --hard "$1" || exit 1
-fi
-
-GIT_SHA=$( git rev-parse --short HEAD )
-
-DATE=$( git log --date=format:%Y%m%d --format=%cd | head -1 )
-
-VERSION=${DATE}_${GIT_SHA}
-
-rm -rf .git
-find . -name .gitignore -print0 | xargs -0 rm -f
-
-cd "$CWD"
-rm -rf $PRGNAM-$VERSION $PRGNAM-$VERSION.tar.xz
-mv $GITDIR $PRGNAM-$VERSION
-tar cvfJ $PRGNAM-$VERSION.tar.xz $PRGNAM-$VERSION
-
-echo
-echo "Created tarball: $PRGNAM-$VERSION.tar.xz"
-echo "VERSION=$VERSION"
diff --git a/graphics/mcomix3/mcomix3.SlackBuild b/graphics/mcomix3/mcomix3.SlackBuild
deleted file mode 100644
index b00452cedd..0000000000
--- a/graphics/mcomix3/mcomix3.SlackBuild
+++ /dev/null
@@ -1,107 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for mcomix3
-
-# Written by B. Watson (urchlay@slackware.uk)
-
-# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=mcomix3
-VERSION=${VERSION:-20211016_483f4b3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-
-# README.rst says not to use setup.py, use installer.py instead.
-# It looks like someone wrote 100 lines of python code that
-# does the same thing as "cp -a $src $target" would do, but
-# I guess when all you have is a hammer...
-python3 installer.py --srcdir=mcomix --target=$PKG/usr/share
-
-# executables get symlinks. the .desktop and .thumbnailer files
-# refer to these as "mcomix" and "comicthumb", with no absolute
-# path and without the .py extension, so these are absolutely
-# necessary (instead of just being convenient).
-mkdir -p $PKG/usr/bin
-ln -s ../share/mcomix/mcomixstarter.py $PKG/usr/bin/mcomix
-ln -s ../share/mcomix/comicthumb.py $PKG/usr/bin/comicthumb
-
-# .desktop and icons don't get installed by installer.py
-mkdir -p $PKG/usr/share/applications
-cp -a mime/mcomix.desktop $PKG/usr/share/applications
-
-# symlink app icons, not move. it's not 100% clear to me whether the
-# application uses them in their original location or not.
-PKGHIC=$PKG/usr/share/icons/hicolor
-for i in 16 22 24 32 48; do
- px="${i}x${i}"
- mkdir -p $PKGHIC/$px/{apps,mimetypes}
- #cp -a mcomix/mcomix/images/$px/* $PKGHIC/$px/apps
- ln -s ../../../../mcomix/mcomix/images/$px/mcomix.png $PKGHIC/$px/apps/mcomix.png
- cp -a mime/icons/$px/* $PKGHIC/$px/mimetypes
-done
-
-# mime stuff also needs manual install.
-mkdir -p $PKG/usr/share/metainfo \
- $PKG/usr/share/glib-2.0/schemas \
- $PKG/usr/share/thumbnailers
-cp -a mime/mcomix.appdata.xml $PKG/usr/share/metainfo
-cp -a mime/comicbook.schemas $PKG/usr/share/glib-2.0/schemas
-cp -a mime/comicthumb.thumbnailer $PKG/usr/share/thumbnailers
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/graphics/mcomix3/mcomix3.info b/graphics/mcomix3/mcomix3.info
deleted file mode 100644
index cb23626439..0000000000
--- a/graphics/mcomix3/mcomix3.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="mcomix3"
-VERSION="20211016_483f4b3"
-HOMEPAGE="https://github.com/multiSnow/mcomix3"
-DOWNLOAD="https://slackware.uk/~urchlay/src/mcomix3-20211016_483f4b3.tar.xz"
-MD5SUM="30be909380290909ccf7e8b154fe3f78"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="B. Watson"
-EMAIL="urchlay@slackware.uk"
diff --git a/graphics/mcomix3/slack-desc b/graphics/mcomix3/slack-desc
deleted file mode 100644
index 9aaf378214..0000000000
--- a/graphics/mcomix3/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-mcomix3: mcomix3 (comic book reader)
-mcomix3:
-mcomix3: MComix is a user-friendly, customizable image viewer. It is
-mcomix3: specifically designed to handle comic books (both Western comics and
-mcomix3: manga) and supports a variety of container formats (including CBR,
-mcomix3: CBZ, CB7, CBT, LHA and PDF). MComix is a fork of Comix, and MComix3 is
-mcomix3: a Python3 fork of MComix.
-mcomix3:
-mcomix3:
-mcomix3:
-mcomix3: