summaryrefslogtreecommitdiffstats
path: root/graphics/zgv/patches
diff options
context:
space:
mode:
author Luis Henrique <lmello.009@gmail.com>2010-06-17 06:44:14 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-06-17 14:43:58 -0500
commit02fb87d8e6378588ba463f4d2ae83ae7cfe68f80 (patch)
tree16644591280dd607b28b01b6d1228dfe2c1e2ef4 /graphics/zgv/patches
parent0b0004403cba1504a5c1c4e67837d2053d6d00eb (diff)
downloadslackbuilds-02fb87d8e6378588ba463f4d2ae83ae7cfe68f80.tar.gz
slackbuilds-02fb87d8e6378588ba463f4d2ae83ae7cfe68f80.tar.xz
graphics/zgv: Added (svgalib image viewer)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'graphics/zgv/patches')
-rw-r--r--graphics/zgv/patches/Makefile.doc.diff10
-rw-r--r--graphics/zgv/patches/Makefile.src.diff19
-rw-r--r--graphics/zgv/patches/config.mk.diff57
3 files changed, 86 insertions, 0 deletions
diff --git a/graphics/zgv/patches/Makefile.doc.diff b/graphics/zgv/patches/Makefile.doc.diff
new file mode 100644
index 0000000000..6188e6ebc1
--- /dev/null
+++ b/graphics/zgv/patches/Makefile.doc.diff
@@ -0,0 +1,10 @@
+--- doc/Makefile~ 2007-10-06 08:34:47.000000000 +0200
++++ doc/Makefile 2007-10-06 08:35:21.000000000 +0200
+@@ -43,7 +43,6 @@
+ else
+ install: ../src/install-info
+ endif
+- $(RM) /usr/share/man/man1/zgv.1* /usr/share/info/zgv*
+ install -m 644 zgv.1 $(MANDIR)
+ install -m 644 zgv zgv-? $(INFODIR)
+ # Update info `dir' file.
diff --git a/graphics/zgv/patches/Makefile.src.diff b/graphics/zgv/patches/Makefile.src.diff
new file mode 100644
index 0000000000..075c8c8510
--- /dev/null
+++ b/graphics/zgv/patches/Makefile.src.diff
@@ -0,0 +1,19 @@
+--- src/Makefile~ 2007-10-06 08:31:49.000000000 +0200
++++ src/Makefile 2007-10-06 08:33:45.000000000 +0200
+@@ -61,14 +61,10 @@
+ #
+ install: all
+ @if [ "$(BACKEND)" = SVGALIB ]; then \
+- echo $(RM) /usr/bin/zgv; \
+- $(RM) /usr/bin/zgv; \
+- echo install -m 4755 -o root -g root -s zgv $(BINDIR); \
+- install -m 4755 -o root -g root -s zgv $(BINDIR); \
++ echo install -m 0755 -o root -g root -s zgv $(BINDIR); \
++ install -m 0755 -o root -g root -s zgv $(BINDIR); \
+ fi
+ @if [ "$(BACKEND)" = SDL ]; then \
+- echo $(RM) /usr/bin/zgv-sdl; \
+- $(RM) /usr/bin/zgv-sdl; \
+ echo install -m 755 -s zgv $(BINDIR)/zgv-sdl; \
+ install -m 755 -s zgv $(BINDIR)/zgv-sdl; \
+ fi
diff --git a/graphics/zgv/patches/config.mk.diff b/graphics/zgv/patches/config.mk.diff
new file mode 100644
index 0000000000..575ccb5d51
--- /dev/null
+++ b/graphics/zgv/patches/config.mk.diff
@@ -0,0 +1,57 @@
+--- config.mk~ 2007-10-06 08:28:56.000000000 +0200
++++ config.mk 2007-10-06 08:31:02.000000000 +0200
+@@ -8,7 +8,7 @@
+ # This is likely to be what you'll want for most systems:
+ #
+ CC=gcc
+-CFLAGS=-O2 -Wall -fomit-frame-pointer -finline-functions
++CFLAGS=$(SLKCFLAGS) -Wall -fomit-frame-pointer -finline-functions
+ #
+ # If you're brave enough to try compiling zgv on a non-x86 system :-),
+ # this might be a better bet:
+@@ -37,7 +37,7 @@
+ # MANDIR to directory for man page.
+ # Usually it will be simpler to just set PREFIX.
+ #
+-PREFIX=/usr/local
++PREFIX=/usr
+
+ # In theory it would be nice to put the info file and man page under
+ # /usr/local/share. However, it's not clear if this is widely
+@@ -52,14 +52,14 @@
+ #
+ #SHARE_INFIX=/share
+
+-BINDIR=$(PREFIX)/bin
+-INFODIR=$(PREFIX)$(SHARE_INFIX)/info
+-MANDIR=$(PREFIX)$(SHARE_INFIX)/man/man1
++BINDIR=$(DESTDIR)/$(PREFIX)/bin
++INFODIR=$(DESTDIR)/$(PREFIX)$(SHARE_INFIX)/info
++MANDIR=$(DESTDIR)/$(PREFIX)$(SHARE_INFIX)/man/man1
+
+ # Set the location/filename of the system-wide configuration file. You
+ # may prefer to have this under /etc, for example.
+ #
+-RCFILE=$(PREFIX)/etc/zgv.conf
++RCFILE=$(DESTDIR)/etc/zgv.conf
+
+
+ # Normally `make install' will update your `dir' file (in INFODIR),
+@@ -73,7 +73,7 @@
+ #
+ # If you don't know what to do, leave it as-is.
+ #
+-#INFO_DIR_UPDATE=no
++INFO_DIR_UPDATE=no
+
+
+ # ------------------- Format-related options ----------------------
+@@ -91,7 +91,7 @@
+ # colours will be recognised, which will mean many XPMs won't be
+ # readable. This setting should be ok.
+ #
+-RGB_DB=/usr/X11R6/lib/X11/rgb.txt
++RGB_DB=/usr/share/X11/rgb.txt
+
+ # Finally, an option for `make dvi' in the `doc' directory. You only need
+ # worry about what this is set to if you plan to make a printed manual.