summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Dave Gauer <dave@ratfactor.com>2023-03-03 04:31:27 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-03-04 08:06:26 +0700
commit82ecdd4d8080a144ccca70f3652bd03d6548529f (patch)
tree52d194c47d3826d5fe92d158b13ef3b234838e96 /development
parent0f737866765505bb3422411ff4dc86f61eb321bc (diff)
downloadslackbuilds-82ecdd4d8080a144ccca70f3652bd03d6548529f.tar.gz
slackbuilds-82ecdd4d8080a144ccca70f3652bd03d6548529f.tar.xz
development/hare: Added (programming language)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/hare/README12
-rw-r--r--development/hare/hare.SlackBuild140
-rw-r--r--development/hare/hare.info10
-rw-r--r--development/hare/slack-desc19
4 files changed, 181 insertions, 0 deletions
diff --git a/development/hare/README b/development/hare/README
new file mode 100644
index 0000000000..c987afa1de
--- /dev/null
+++ b/development/hare/README
@@ -0,0 +1,12 @@
+Hare is a systems programming language designed to be simple,
+stable, and robust. Hare uses a static type system, manual memory
+management, and a minimal runtime. It is well-suited to writing
+operating systems, system tools, compilers, networking software,
+and other low-level, high performance tasks.
+
+Hare uses and depends on the QBE compiler backend.
+
+Building hare (this "build driver") depends on:
+
+ * scdoc - the man page generator
+ * harec - the hare boostrap compiler
diff --git a/development/hare/hare.SlackBuild b/development/hare/hare.SlackBuild
new file mode 100644
index 0000000000..ea694e5463
--- /dev/null
+++ b/development/hare/hare.SlackBuild
@@ -0,0 +1,140 @@
+#!/bin/bash
+
+# Slackware build script for hare
+
+# Copyright 2023 Dave Gauer, http://ratfactor.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+# Note that hare doesn't yet have a released version.
+# This script is set to the same commit currently (at the time of this
+# writing) used by the Alpine community package:
+#
+# https://git.alpinelinux.org/aports/tree/community/hare/APKBUILD
+#
+PRGNAM=hare
+VERSION=${VERSION:-20230225}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+COMMITVERSION=${COMMITVERSION:-1cbc3d0453055fa75b15797e937f4abafe53bcbc}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+
+if [ -e $CWD/$PRGNAM-$COMMITVERSION.tar.gz ]
+then
+ # browser download
+ tar xvf $CWD/$PRGNAM-$COMMITVERSION.tar.gz
+else
+ # wget download
+ tar xvf $CWD/$COMMITVERSION.tar.gz
+fi
+
+cd $PRGNAM-$COMMITVERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Copy example config and change prefix dir and mandirs.
+# Interestingly, this changes them to what is shown at
+# https://harelang.org/distributions/
+# /usr/local --> /usr
+# /usr/share/man --> /usr/man
+cp config.example.mk config.mk
+sed -i 's|/usr/local|/usr|' config.mk
+sed -i 's|/share/man|/man|' config.mk
+
+# Making this build script idempotent to make it easier to test
+make clean
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+PREFIX=/usr \
+make
+
+# Shouldn't need this (install also performs it), but I had some
+# trouble (zero length hare.1) and this *seemed* to do the trick.
+make docs
+
+make install DESTDIR=$PKG PREFIX=/usr
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING \
+ README \
+ README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# man pages need to be compressed
+gzip -9 $PKG/usr/man/man1/hare.1
+gzip -9 $PKG/usr/man/man1/haredoc.1
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/hare/hare.info b/development/hare/hare.info
new file mode 100644
index 0000000000..618e3b54c9
--- /dev/null
+++ b/development/hare/hare.info
@@ -0,0 +1,10 @@
+PRGNAM="hare"
+VERSION="20230225"
+HOMEPAGE="https://harelang.org/"
+DOWNLOAD="https://git.sr.ht/~sircmpwn/hare/archive/1cbc3d0453055fa75b15797e937f4abafe53bcbc.tar.gz"
+MD5SUM="e652fa188bec4a7e3db715e3b906fc40"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="qbe harec scdoc tzleap"
+MAINTAINER="Dave Gauer"
+EMAIL="dave@ratfactor.com"
diff --git a/development/hare/slack-desc b/development/hare/slack-desc
new file mode 100644
index 0000000000..8fd0f18849
--- /dev/null
+++ b/development/hare/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hare: hare (programming language)
+hare:
+hare: Hare is a systems programming language designed to be simple, stable,
+hare: and robust. Hare uses a static type system, manual memory management,
+hare: and a minimal runtime. It is well-suited to writing operating systems,
+hare: system tools, compilers, networking software, and other low-level,
+hare: high performance tasks.
+hare:
+hare: https://harelang.org/
+hare:
+hare: