summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2023-01-08 21:54:15 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-01-14 08:49:59 +0700
commit2f0abfe5e09c1788c2aab6443f15815ab89ef536 (patch)
treead0f18ba8f7220560d8bac69cafd1f367c120ddd /development
parent2dc520a0ffe6a458273870c8740f950ebda40fef (diff)
downloadslackbuilds-2f0abfe5e09c1788c2aab6443f15815ab89ef536.tar.gz
slackbuilds-2f0abfe5e09c1788c2aab6443f15815ab89ef536.tar.xz
development/jupyter_server: Updated for version 2.0.6.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/jupyter_server/jupyter_server.SlackBuild10
-rw-r--r--development/jupyter_server/jupyter_server.info8
2 files changed, 8 insertions, 10 deletions
diff --git a/development/jupyter_server/jupyter_server.SlackBuild b/development/jupyter_server/jupyter_server.SlackBuild
index 260bc9e933..dbbc6b7959 100644
--- a/development/jupyter_server/jupyter_server.SlackBuild
+++ b/development/jupyter_server/jupyter_server.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for jupyter_server
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2023 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter_server
-VERSION=${VERSION:-1.23.3}
+VERSION=${VERSION:-2.0.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,7 +76,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/development/jupyter_server/jupyter_server.info b/development/jupyter_server/jupyter_server.info
index 375fb1c675..b90f26fee5 100644
--- a/development/jupyter_server/jupyter_server.info
+++ b/development/jupyter_server/jupyter_server.info
@@ -1,10 +1,10 @@
PRGNAM="jupyter_server"
-VERSION="1.23.3"
+VERSION="2.0.6"
HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jupyter_server/jupyter_server-1.23.3.tar.gz"
-MD5SUM="386b319f610203100b20f7a7a4df250b"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jupyter_server/jupyter_server-2.0.6.tar.gz"
+MD5SUM="437ecaebd7f629c53a4c7352eafebc30"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="argon2-cffi jupyter-nbconvert jupyter_packaging python3-anyio python3-prometheus_client python3-requests-unixsocket send2trash terminado python3-websocket-client"
+REQUIRES="argon2-cffi jsonpointer jupyter_events jupyter-nbconvert jupyter_packaging jupyter_server_terminals python3-anyio python3-hatch_jupyter_builder python3-prometheus_client python3-requests-unixsocket send2trash python3-fqdn python3-isoduration python3-rfc3339_validator python3-rfc3986_validator python3-uri_template python3-webcolors python3-websocket-client"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu1@isaacyu1.com"