summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author isaackwy <isaacyu@protonmail.com>2024-04-19 00:03:22 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-20 07:54:57 +0700
commitb24c07de5957e3e2d80a2895aeffc6122817d8b6 (patch)
tree6217a16bdd0cf26387ac861036984a6ee2f4a825 /desktop
parent9d2f1cf541e697b2c531b9efe2b05e2f36e56640 (diff)
downloadslackbuilds-b24c07de5957e3e2d80a2895aeffc6122817d8b6.tar.gz
slackbuilds-b24c07de5957e3e2d80a2895aeffc6122817d8b6.tar.xz
desktop/qtile: Update for 0.25.0 (+disable Wayland support)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/qtile/README6
-rw-r--r--desktop/qtile/qtile.SlackBuild33
-rw-r--r--desktop/qtile/qtile.info8
3 files changed, 16 insertions, 31 deletions
diff --git a/desktop/qtile/README b/desktop/qtile/README
index 2b44f405b8..4e3abec5b7 100644
--- a/desktop/qtile/README
+++ b/desktop/qtile/README
@@ -10,6 +10,6 @@ python3-dbus-next is an optional dependency for qtile.
It sends notifications through dbus - please additionally install a
notification daemon such as dunst for displaying notifications on qtile.
-python3-pywlroots (another optional dependency) provides experimental
-Wayland support. If python3-pywlroots is installed, then this SlackBuild
-will also install a Wayland .desktop session file.
+This SlackBuild does not provide Wayland support. Slackware 15.0 is only
+able to build wlroots 0.15. qtile >= 0.23.0 requires wlroots 0.16 (which
+cannot be built with Slackware 15).
diff --git a/desktop/qtile/qtile.SlackBuild b/desktop/qtile/qtile.SlackBuild
index 51e7162010..dae625eb03 100644
--- a/desktop/qtile/qtile.SlackBuild
+++ b/desktop/qtile/qtile.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for qtile
# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
-# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=qtile
-VERSION=${VERSION:-0.22.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-0.25.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,7 +63,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+# qtile provides a setup.py - however, setuptools > 58.2.0 does not recommend running setup.py directly
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -90,12 +81,6 @@ install -m 0755 $CWD/xinitrc.$PRGNAM $PKG/etc/X11/xinit/xinitrc.$PRGNAM
mkdir -p $PKG/usr/share/xsessions
install -D -m644 resources/$PRGNAM.desktop $PKG/usr/share/xsessions/$PRGNAM.desktop
-# If pywlroots is installed, install Wayland session file
-if $(python3 -c 'import pkgutil; exit(not pkgutil.find_loader("wlroots"))'); then
- mkdir -p $PKG/usr/share/wayland-sessions
- install -D -m644 resources/$PRGNAM-wayland.desktop $PKG/usr/share/wayland-sessions/$PRGNAM-wayland.desktop
-fi
-
# example for default config file maybe installed ~/$USER/.config/qtile
CONFIG="libqtile/resources/default_config.py"
diff --git a/desktop/qtile/qtile.info b/desktop/qtile/qtile.info
index c80ff54930..6cd7ee2c1a 100644
--- a/desktop/qtile/qtile.info
+++ b/desktop/qtile/qtile.info
@@ -1,10 +1,10 @@
PRGNAM="qtile"
-VERSION="0.22.1"
+VERSION="0.25.0"
HOMEPAGE="http://qtile.org"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/q/qtile/qtile-0.22.1.tar.gz"
-MD5SUM="504e17bca60ef78bdbdb0b706809dd8b"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/q/qtile/qtile-0.25.0.tar.gz"
+MD5SUM="5dea4d6feb2b018dfb54433837178a2d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-xcffib python3-cairocffi"
+REQUIRES="python3-xcffib python3-cairocffi python3-setuptools-scm-opt"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu@protonmail.com"