summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2024-02-13 22:16:30 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-02-17 09:07:16 +0700
commit33e7dbcd13e5707b813eb41abe0e545b2dbcdf22 (patch)
treec6198bc085bea1b928990b8dc2c4b50d172f0c89 /desktop
parentac5ab3a6f99515aecd3f6372766545c5c91f5c29 (diff)
downloadslackbuilds-33e7dbcd13e5707b813eb41abe0e545b2dbcdf22.tar.gz
slackbuilds-33e7dbcd13e5707b813eb41abe0e545b2dbcdf22.tar.xz
desktop/sun: Updated for version 1.6.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/sun/doinst.sh4
-rw-r--r--desktop/sun/sun.SlackBuild23
-rw-r--r--desktop/sun/sun.info10
3 files changed, 21 insertions, 16 deletions
diff --git a/desktop/sun/doinst.sh b/desktop/sun/doinst.sh
index ddd427b246..f59a2090af 100644
--- a/desktop/sun/doinst.sh
+++ b/desktop/sun/doinst.sh
@@ -15,5 +15,5 @@ if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
-cmp etc/xdg/autostart/sun_daemon.desktop etc/xdg/autostart/sun_daemon.desktop.sample 2> /dev/null && \
- rm etc/xdg/autostart/sun_daemon.desktop.sample
+cmp etc/xdg/autostart/sun-daemon.desktop etc/xdg/autostart/sun-daemon.desktop.sample 2> /dev/null && \
+ rm etc/xdg/autostart/sun-daemon.desktop.sample
diff --git a/desktop/sun/sun.SlackBuild b/desktop/sun/sun.SlackBuild
index 86e70b5733..ed30f5c3d9 100644
--- a/desktop/sun/sun.SlackBuild
+++ b/desktop/sun/sun.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for sun
-# Copyright 2015-2023 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2015-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sun
-VERSION=${VERSION:-1.5.2}
+VERSION=${VERSION:-1.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,22 +79,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
-# Install autostart enable-disable daemon script
-mkdir -p $PKG/usr/sbin
-cp sbin/sun_daemon $PKG/usr/sbin
+# Install configuration and data files
+mkdir -p $PKG/usr/sbin $PKG/etc/$PRGNAM $PKG/usr/share/pixmaps/ $PKG/usr/share/applications/ \
+ $PKG/etc/xdg/autostart/
-# Install configuration file
-mkdir -p $PKG/etc/$PRGNAM
install -D -m0644 conf/sun.toml $PKG/etc/sun/sun.toml.new
install -D -m0644 conf/repositories.toml $PKG/etc/sun/repositories.toml.new
+mv $PKG/usr/bin/sun-autostart $PKG/usr/sbin/
+cp -a extra/icon/sun.png $PKG/usr/share/pixmaps/
+cp -a extra/desktop/sun.desktop $PKG/usr/share/applications/
+cp -a extra/xdg/sun-daemon.desktop.sample $PKG/etc/xdg/autostart/
+cp -a extra/xdg/sun.desktop $PKG/etc/xdg/autostart/
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst CHANGES.md LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md CHANGELOG.md LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/desktop/sun/sun.info b/desktop/sun/sun.info
index 7a8b2068fa..fe151f8c96 100644
--- a/desktop/sun/sun.info
+++ b/desktop/sun/sun.info
@@ -1,10 +1,10 @@
PRGNAM="sun"
-VERSION="1.5.2"
+VERSION="1.6.0"
HOMEPAGE="https://dslackw.gitlab.io/sun"
-DOWNLOAD="https://gitlab.com/dslackw/sun/-/archive/1.5.2/sun-1.5.2.tar.gz"
-MD5SUM="0587228af3c7984de0c5f1ac550826ae"
+DOWNLOAD="https://gitlab.com/dslackw/sun/-/archive/1.6.0/sun-1.6.0.tar.gz"
+MD5SUM="b0dc5f38d68e056c00052d2b494665a4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-build"
MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+EMAIL="dslackw@gmail.com"