summaryrefslogtreecommitdiffstats
path: root/desktop/polybar/polybar.SlackBuild
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2019-08-04 20:33:26 +0200
committer Robby Workman <rworkman@slackbuilds.org>2021-04-17 23:54:34 -0500
commitfd2b195e1ef3c4d8af5077911d72384e209125c3 (patch)
treed86d0e3773012d93384106ce4aecd3bfbfb1ba89 /desktop/polybar/polybar.SlackBuild
parent71824e5a9104d0bd32d756d8da89ccee0c9078c1 (diff)
downloadslackbuilds-fd2b195e1ef3c4d8af5077911d72384e209125c3.tar.gz
slackbuilds-fd2b195e1ef3c4d8af5077911d72384e209125c3.tar.xz
desktop/polybar: Fix for the newer xcb-proto.
Disable some warnings-as-errors Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'desktop/polybar/polybar.SlackBuild')
-rw-r--r--desktop/polybar/polybar.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/desktop/polybar/polybar.SlackBuild b/desktop/polybar/polybar.SlackBuild
index b86a3cabea..9856cb3da0 100644
--- a/desktop/polybar/polybar.SlackBuild
+++ b/desktop/polybar/polybar.SlackBuild
@@ -75,6 +75,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+( cd lib/xpp
+ patch -p1 < $CWD/00165e1a6d5dd61bc153e1352b21ec07fc81245d.patch )
+
# Fixes install location
sed -i -e '/share\/doc\/polybar/s/share\///' doc/CMakeLists.txt
sed -i -e "/DESTINATION doc\/polybar/s/polybar/$PRGNAM-$VERSION/" doc/CMakeLists.txt
@@ -87,7 +90,7 @@ mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -Wno-error=implicit-fallthrough -Wno-error=stringop-truncation -Wno-error=deprecated-copy" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ..
make -j1