summaryrefslogtreecommitdiffstats
path: root/business
diff options
context:
space:
mode:
author Arn0 <yth@ythogtha.org>2022-09-14 11:35:07 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-09-24 23:02:16 +0700
commitac3e07224f23a6bc8d4e46b11276e485185056c1 (patch)
treec66af7151e2a813d4feb660ad0467941f78635fd /business
parented6fe5e7bfdd8485058a3089f82e3ca19cb415b3 (diff)
downloadslackbuilds-ac3e07224f23a6bc8d4e46b11276e485185056c1.tar.gz
slackbuilds-ac3e07224f23a6bc8d4e46b11276e485185056c1.tar.xz
business/tryton: unmaintained and removed
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'business')
-rw-r--r--business/tryton/README17
-rw-r--r--business/tryton/doinst.sh3
-rw-r--r--business/tryton/slack-desc19
-rw-r--r--business/tryton/tryton.SlackBuild113
-rw-r--r--business/tryton/tryton.info10
5 files changed, 0 insertions, 162 deletions
diff --git a/business/tryton/README b/business/tryton/README
deleted file mode 100644
index fa013dadd9..0000000000
--- a/business/tryton/README
+++ /dev/null
@@ -1,17 +0,0 @@
-Tryton is a complete ERP. The main features are accounting (analytic
-and financial), stock management, sales and purchases management,
-POS, etc. Technical features include a distributed server, flexible
-workflows, an object database, a dynamic GUI, customizable reports, and
-SOAP and XML-RPC interfaces.
-
-This is the pygtk client for Tryton. Requires trytond available on
-either the same host or available via the network.
-
-If you want to integrate Google Calendar, then install GooCalendar
-(http://code.google.com/p/goocalendar/) - Not available on SBo.
-
-Optional is cdecimal (not available in SBo) to replace stock decimal
-module.
-
-If you want to install the documentation, optional dependency is Sphinx
-documentation program (development/Sphinx).
diff --git a/business/tryton/doinst.sh b/business/tryton/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/business/tryton/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/business/tryton/slack-desc b/business/tryton/slack-desc
deleted file mode 100644
index 66c4a91a66..0000000000
--- a/business/tryton/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-tryton: tryton (Tryton ERP -client part)
-tryton:
-tryton: Tryton is a complete ERP written in Python.
-tryton:
-tryton: This package is for the client only - trytond (server) package must
-tryton: be installed somewhere that the client can reach.
-tryton:
-tryton: Homepage: http://www.tryton.org
-tryton:
-tryton:
-tryton:
diff --git a/business/tryton/tryton.SlackBuild b/business/tryton/tryton.SlackBuild
deleted file mode 100644
index c178a8793e..0000000000
--- a/business/tryton/tryton.SlackBuild
+++ /dev/null
@@ -1,113 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for tryton
-
-# Copyright 2014 Ken Roberts
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=tryton
-VERSION=${VERSION:-3.0.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-if [ -x /usr/bin/sphinx ] ; then
- ( cd $TMP/$PRGNAM-$VERSION/doc
- make html
- make pickle
- make json
- make htmlhelp
- make qthelp
- make changes
- PAPER=${PAPER:-letter} make latex
- cp -a _build_/* $PKG/usr/doc/$PRGNAM-$VERSION
- )
-fi
-
-cp -a COPYRIGHT INSTALL CHANGELOG LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION/
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-# Add the desktop file
-mkdir $PKG/usr/share/applications
-cp -a tryton.desktop $PKG/usr/share/applications/tryton.desktop
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/business/tryton/tryton.info b/business/tryton/tryton.info
deleted file mode 100644
index 0bbf70a24c..0000000000
--- a/business/tryton/tryton.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="tryton"
-VERSION="3.0.3"
-HOMEPAGE="http://www.tryton.org"
-DOWNLOAD="http://downloads.tryton.org/3.0/tryton-3.0.3.tar.gz"
-MD5SUM="2b42241ed44de8c8936838c59ab850cd"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="simplejson pytz trytond"
-MAINTAINER="Ken Roberts"
-EMAIL="alisonken1@juno.com"