summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Martin BĂ„ngens <marbangens@gmail.com>2022-11-29 09:19:59 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-12-01 21:40:23 +0700
commitb1decc7a7e1a3b7f8fbedb6f598b48e649f82341 (patch)
treea75ae5a9f73e1bad8453a2ad8d1b6112dd3856fb /audio
parentef43f51724608b3f7c1a11473888cb43a71eba77 (diff)
downloadslackbuilds-b1decc7a7e1a3b7f8fbedb6f598b48e649f82341.tar.gz
slackbuilds-b1decc7a7e1a3b7f8fbedb6f598b48e649f82341.tar.xz
audio/yabridge: Updated for version 5.0.2
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/yabridge/yabridge.SlackBuild76
-rw-r--r--audio/yabridge/yabridge.info6
2 files changed, 54 insertions, 28 deletions
diff --git a/audio/yabridge/yabridge.SlackBuild b/audio/yabridge/yabridge.SlackBuild
index 1193329747..721c1ff54d 100644
--- a/audio/yabridge/yabridge.SlackBuild
+++ b/audio/yabridge/yabridge.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=yabridge
-VERSION=${VERSION:-5.0.1}
+VERSION=${VERSION:-5.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -56,6 +56,8 @@ WINE_IN_PATH=$?
which wine64 &>/dev/null
WINE64_IN_PATH=$?
+WINE_VERSION=$(wine --version | grep --only-matching -E '[0-9]+\.[0-9]+' | head -n1)
+
if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
if (($WINE_IN_PATH)); then
echo "This script look for wine in PATH and needs it for compiling and using yabridge on i586"
@@ -96,31 +98,55 @@ sed -i "s|bitsery_dep = dependency('bitsery', 'Bitsery', version : '>=5.2.0')|bi
mkdir subprojects/vst3
cp -a /usr/include/vst3sdk/* subprojects/vst3/
cp yabridge-html-docs-plus-build-files-$VERSION/meson.build subprojects/vst3
-
-if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
- meson setup \
- build \
- --cross-file=cross-wine.conf \
- --buildtype=release \
- --unity=on \
- --unity-size=1000 \
- --wrap-mode=nodownload \
- -Dbitbridge=true \
- -Dsystem-asio=true \
- -Dbuild.cpp_args='-m32' \
- -Dbuild.cpp_link_args='-m32'
-elif [ "$ARCH" = "x86_64" ]; then
- meson setup \
- build \
- --cross-file=cross-wine.conf \
- --buildtype=release \
- --unity=on \
- --unity-size=1000 \
- --wrap-mode=nodownload \
- -Dbitbridge=true \
- -Dsystem-asio=true
+if (( $(echo "$WINE_VERSION >= 7.21" |bc -l) )) && (( $(echo "$WINE_VERSION < 7.23" |bc -l) ));
+then
+ if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
+ meson setup \
+ build \
+ --cross-file=cross-wine.conf \
+ --buildtype=release \
+ --wrap-mode=nodownload \
+ -Dbitbridge=true \
+ -Dsystem-asio=true \
+ -Dbuild.cpp_args='-m32' \
+ -Dbuild.cpp_link_args='-m32'
+ elif [ "$ARCH" = "x86_64" ]; then
+ meson setup \
+ build \
+ --cross-file=cross-wine.conf \
+ --buildtype=release \
+ --wrap-mode=nodownload \
+ -Dbitbridge=true \
+ -Dsystem-asio=true
+ else
+ echo "Unsupported architecture"
+ fi
else
- echo "Unsupported architecture"
+ if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
+ meson setup \
+ build \
+ --cross-file=cross-wine.conf \
+ --buildtype=release \
+ --unity=on \
+ --unity-size=1000 \
+ --wrap-mode=nodownload \
+ -Dbitbridge=true \
+ -Dsystem-asio=true \
+ -Dbuild.cpp_args='-m32' \
+ -Dbuild.cpp_link_args='-m32'
+ elif [ "$ARCH" = "x86_64" ]; then
+ meson setup \
+ build \
+ --cross-file=cross-wine.conf \
+ --buildtype=release \
+ --unity=on \
+ --unity-size=1000 \
+ --wrap-mode=nodownload \
+ -Dbitbridge=true \
+ -Dsystem-asio=true
+ else
+ echo "Unsupported architecture"
+ fi
fi
# Build yabridge
diff --git a/audio/yabridge/yabridge.info b/audio/yabridge/yabridge.info
index e5868d55f7..df27b14176 100644
--- a/audio/yabridge/yabridge.info
+++ b/audio/yabridge/yabridge.info
@@ -1,8 +1,8 @@
PRGNAM="yabridge"
-VERSION="5.0.1"
+VERSION="5.0.2"
HOMEPAGE="https://github.com/robbert-vdh/yabridge"
-DOWNLOAD="https://github.com/robbert-vdh/yabridge/archive/5.0.1/yabridge-5.0.1.tar.gz https://github.com/noisecode3/yabridge-html-docs-plus-build-files/archive/v5.0.1/yabridge-html-docs-plus-build-files-5.0.1.tar.gz"
-MD5SUM="5805d4e4e4d0e15d0ae07e533104a3df ae2645f5bbffc52d8fedf15088765242"
+DOWNLOAD="https://github.com/robbert-vdh/yabridge/archive/5.0.2/yabridge-5.0.2.tar.gz https://github.com/noisecode3/yabridge-html-docs-plus-build-files/archive/v5.0.2/yabridge-html-docs-plus-build-files-5.0.2.tar.gz"
+MD5SUM="0aab2b2e7dbbd3e1afc314b47f1406de 5fa1a66a84dac91a4460006c28d10705"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="%README% wine-staging asio bitsery function2 ghc_filesystem tomlplusplus vst3sdk clap"