summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2021-12-09 15:08:07 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-12-10 08:37:40 +0700
commit27d48537d3fe88cbd695074059fe0b2ff4023d0d (patch)
tree3153f77d6629a26c16541da130c47179be58c882 /audio
parent0d14f4018d72e682df0a4815d2a26afe7f599117 (diff)
downloadslackbuilds-27d48537d3fe88cbd695074059fe0b2ff4023d0d.tar.gz
slackbuilds-27d48537d3fe88cbd695074059fe0b2ff4023d0d.tar.xz
audio/jokosher: Removed (literally a joke app; nobody uses it).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/jokosher/README10
-rw-r--r--audio/jokosher/doinst.sh13
-rw-r--r--audio/jokosher/jokosher.SlackBuild97
-rw-r--r--audio/jokosher/jokosher.info10
-rw-r--r--audio/jokosher/slack-desc19
5 files changed, 0 insertions, 149 deletions
diff --git a/audio/jokosher/README b/audio/jokosher/README
deleted file mode 100644
index d7687b8ad6..0000000000
--- a/audio/jokosher/README
+++ /dev/null
@@ -1,10 +0,0 @@
-jokosher (a multi-track non-linear audio editor)
-
-Jokosher is a simple and powerful multi-track studio. Jokosher
-provides a complete application for recording, editing, mixing and
-exporting audio, and has been specifically designed with usability in
-mind. The developers behind Jokosher have re-thought audio production
-at every level, and created something devilishly simple to use.
-
-Currently, jokosher can't be used with jack. This may change in the
-future: what's missing is the jack plugins from gst0-plugins-good.
diff --git a/audio/jokosher/doinst.sh b/audio/jokosher/doinst.sh
deleted file mode 100644
index 138e27de17..0000000000
--- a/audio/jokosher/doinst.sh
+++ /dev/null
@@ -1,13 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
diff --git a/audio/jokosher/jokosher.SlackBuild b/audio/jokosher/jokosher.SlackBuild
deleted file mode 100644
index d51c155d88..0000000000
--- a/audio/jokosher/jokosher.SlackBuild
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for jokosher
-
-# Formerly maintained by:
-# Ryan P.C. McQuen | Everett, WA | ryanpcmcquen@member.fsf.org
-
-# Now maintained by B. Watson (yalhcru@gmail.com)
-
-# Copyright 2010 Binh Nguyen <binhvng@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# 20170310 bkw:
-# - take over maintenanace
-# - i486 => i586
-# - stop spamming /usr
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=jokosher
-VERSION=${VERSION:-0.11.5}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# 20170310 bkw: Don't let setup.py spam /usr by running
-# update-mime-database and update-desktop-database. Be nice if
-# there were an option to setup.py to disable it, but there's not:
-sed -i 's,"update-[^"]*","true",' setup.py
-
-python setup.py build
-python setup.py install --skip-build --root=$PKG
-
-# nothing to strip, no native code, only python.
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/jokosher/jokosher.info b/audio/jokosher/jokosher.info
deleted file mode 100644
index 96f7190880..0000000000
--- a/audio/jokosher/jokosher.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="jokosher"
-VERSION="0.11.5"
-HOMEPAGE="https://launchpad.net/jokosher/"
-DOWNLOAD="http://launchpad.net/jokosher/trunk/0.11.5/+download/jokosher-0.11.5.tar.gz"
-MD5SUM="941b1fac0a93e2963afc192545caf320"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="gnonlin gst0-python"
-MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
diff --git a/audio/jokosher/slack-desc b/audio/jokosher/slack-desc
deleted file mode 100644
index c0c9b27364..0000000000
--- a/audio/jokosher/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-jokosher: jokosher (a multi-track non-linear audio editor)
-jokosher:
-jokosher: Jokosher is a simple and powerful multi-track studio. Jokosher
-jokosher: provides a complete application for recording, editing, mixing and
-jokosher: exporting audio, and has been specifically designed with usability in
-jokosher: mind. The developers behind Jokosher have re-thought audio production
-jokosher: at every level, and created something devilishly simple to use.
-jokosher:
-jokosher: Homepage: http://www.jokosher.org/
-jokosher:
-jokosher: