summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Vladimir Nikishkin <>2024-01-15 14:52:24 +0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-16 14:36:14 +0700
commit203047a52de8e54d656569884cf8c977cefe5e98 (patch)
treec0001cb83975bc2208c0fa9d134fd2960df2350b /academic
parent2968a96dc6955893133457e58e680ec85cf500d2 (diff)
downloadslackbuilds-203047a52de8e54d656569884cf8c977cefe5e98.tar.gz
slackbuilds-203047a52de8e54d656569884cf8c977cefe5e98.tar.xz
academic/qhull: Remove outdated octave symlinks.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/qhull/qhull.SlackBuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/academic/qhull/qhull.SlackBuild b/academic/qhull/qhull.SlackBuild
index a9e47aa829..feabf1cb97 100644
--- a/academic/qhull/qhull.SlackBuild
+++ b/academic/qhull/qhull.SlackBuild
@@ -5,6 +5,8 @@
# Copyright 2012 Chris Abela, Malta
# Copyright 2014 Ryan P.C. McQuen, ryanpcmcquen@member.fsf.org, WA
# Copyright 2023, Lockywolf
+# Contributed 2024, Kyle Guinn
+
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -30,7 +32,9 @@ PRGNAM=qhull
VERSION=${VERSION:-8.0.2}
BUILD_VERSION=${BUILD_VERSION:-2020}
BUILD_VERSION_PATCH=${BUILD_VERSION_PATCH:-2}
-BUILD=${BUILD:-1}
+
+BUILD=${BUILD:-2}
+
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -85,17 +89,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i \
+ -e '/ConfigPackageLocation/s/lib/${LIB_INSTALL_DIR}/' \
+ -e '/PkgConfigLocation/s/lib/${LIB_INSTALL_DIR}/' \
+ CMakeLists.txt
+
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DBIN_INSTALL_DIR=/usr/bin \
- -DLIB_INSTALL_DIR=/usr/lib${LIBDIRSUFFIX} \
- -DINCLUDE_INSTALL_DIR=/usr/include \
- -DMAN_INSTALL_DIR=/usr/man/man1 \
- -DDOC_INSTALL_DIR=/usr/doc/$PRGNAM-$VERSION \
+ -DLIB_INSTALL_DIR=lib${LIBDIRSUFFIX} \
+ -DMAN_INSTALL_DIR=man/man1 \
+ -DDOC_INSTALL_DIR=doc/$PRGNAM-$VERSION \
+ -DCMAKE_SKIP_RPATH=YES \
-DCMAKE_CXX_COMPILER_LAUNCHER=ccache \
-DCMAKE_C_COMPILER_LAUNCHER=ccache \
-DCMAKE_BUILD_TYPE=Release ..
@@ -103,10 +111,6 @@ cd build
make install DESTDIR=$PKG
cd ..
-# Let octave find us
-ln -s libqhull $PKG/usr/include/qhull
-ln -s libqhull.h $PKG/usr/include/libqhull/qhull.h
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true