summaryrefslogtreecommitdiffstats
path: root/academic/bpp1.9-utils
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2022-02-27 08:58:32 +0100
committer Robby Workman <rworkman@slackbuilds.org>2022-02-27 22:29:03 -0600
commit811dac1f48fcd22896fcf62b34ad8b967b33375d (patch)
tree655bae1a020779ef5b8d31beac9c5eeeed82ed6d /academic/bpp1.9-utils
parent2a8e2c8f35561c461d78305da9f7aea9e93320a2 (diff)
downloadslackbuilds-811dac1f48fcd22896fcf62b34ad8b967b33375d.tar.gz
slackbuilds-811dac1f48fcd22896fcf62b34ad8b967b33375d.tar.xz
academic/bpp1.9-utils: Removed (ftb + no active maintainer).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'academic/bpp1.9-utils')
-rw-r--r--academic/bpp1.9-utils/README10
-rw-r--r--academic/bpp1.9-utils/bpp1.9-utils.SlackBuild124
-rw-r--r--academic/bpp1.9-utils/bpp1.9-utils.info10
-rw-r--r--academic/bpp1.9-utils/slack-desc19
4 files changed, 0 insertions, 163 deletions
diff --git a/academic/bpp1.9-utils/README b/academic/bpp1.9-utils/README
deleted file mode 100644
index 5ee42d9632..0000000000
--- a/academic/bpp1.9-utils/README
+++ /dev/null
@@ -1,10 +0,0 @@
-Bio++ is a set of C++ libraries for Bioinformatics, including sequence
-analysis, phylogenetics, molecular evolution and population genetics.
-Bio++ is Object Oriented and is designed to be both easy to use and
-computer efficient. Bio++ intends to help programmers to write
-computer expensive programs, by providing them a set of re-usable
-tools.
-
-This contains the Bio++ 1.9 (April 2010) Utils Library. It can be
-installed along the current Bio++ suite libraries, however they better
-not be present at compile time.
diff --git a/academic/bpp1.9-utils/bpp1.9-utils.SlackBuild b/academic/bpp1.9-utils/bpp1.9-utils.SlackBuild
deleted file mode 100644
index f38058baff..0000000000
--- a/academic/bpp1.9-utils/bpp1.9-utils.SlackBuild
+++ /dev/null
@@ -1,124 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for bpp1.9-utils
-
-# Copyright 2020-2021 Petar Petrov slackalaxy@gmail.com
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=bpp1.9-utils
-SRCNAM=bpp-utils
-VERSION=${VERSION:-1.5.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-# This is needed for vCAPS to find its libraries at runtime. Thanks Urchlay!
-LIBDIRPATH="-Wl,-rpath,/usr/lib${LIBDIRSUFFIX}/Bpp1.9"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# This is needed on newer systems (-current)
-sed -i "s:file;:file.good();:g" Utils/FileTools.cpp
-
-# Use custom install place, so libs can coexist with latest Bio++
-sed -i "s:/lib/:/lib${LIBDIRSUFFIX}/Bpp1.9/:g" Utils.spec
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS $LIBDIRPATH" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release ..
-
-# More about word boundary and sed:
-# https://linuxize.com/post/how-to-use-sed-to-find-and-replace-string-in-files/
-sed -i "s:/lib/:/lib${LIBDIRSUFFIX}/Bpp1.9/:g" Utils/cmake_install.cmake
-sed -i "s:/lib\b:/lib${LIBDIRSUFFIX}/Bpp1.9:g" Utils/cmake_install.cmake
-
- make
- make DESTDIR=$PKG install
-cd ..
-
-# static library not needed
-rm -f $PKG/usr/lib$LIBDIRSUFFIX/Bpp1.9/libbpp-utils.a
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS ChangeLog COPYING INSTALL \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/bpp1.9-utils/bpp1.9-utils.info b/academic/bpp1.9-utils/bpp1.9-utils.info
deleted file mode 100644
index 8e7863e9f1..0000000000
--- a/academic/bpp1.9-utils/bpp1.9-utils.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="bpp1.9-utils"
-VERSION="1.5.0"
-HOMEPAGE="http://biopp.univ-montp2.fr/"
-DOWNLOAD="http://biopp.univ-montp2.fr/repos/sources/bpp-utils-1.5.0.tar.gz"
-MD5SUM="4625b7f2146caa1815ed7dc433d5eb78"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Petar Petrov"
-EMAIL="slackalaxy@gmail.copm"
diff --git a/academic/bpp1.9-utils/slack-desc b/academic/bpp1.9-utils/slack-desc
deleted file mode 100644
index be9d333c61..0000000000
--- a/academic/bpp1.9-utils/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-bpp1.9-utils: bpp1.9-utils (Bio++ 1.9 Utils Library)
-bpp1.9-utils:
-bpp1.9-utils: Contains the Bio++ 1.9 Utils Library.
-bpp1.9-utils:
-bpp1.9-utils:
-bpp1.9-utils:
-bpp1.9-utils:
-bpp1.9-utils:
-bpp1.9-utils:
-bpp1.9-utils:
-bpp1.9-utils: