summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-10-17 07:54:12 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-10-17 07:54:12 +0700
commitec87cddf127055de1342e9c60e1ab17d7da8540e (patch)
treea1b053596c451970173ffb72d2bc294974c40d00
parentba7401a6fb31a311698579369e87f70025123fd0 (diff)
downloadslackbuilds-ec87cddf127055de1342e9c60e1ab17d7da8540e.tar.gz
slackbuilds-ec87cddf127055de1342e9c60e1ab17d7da8540e.tar.xz
libraries/LuaBitOp: Removed (project no longer updated)
And it will not built against newer lua. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/LuaBitOp/LuaBitOp.SlackBuild99
-rw-r--r--libraries/LuaBitOp/LuaBitOp.info10
-rw-r--r--libraries/LuaBitOp/Makefile.patch15
-rw-r--r--libraries/LuaBitOp/README19
-rw-r--r--libraries/LuaBitOp/slack-desc19
5 files changed, 0 insertions, 162 deletions
diff --git a/libraries/LuaBitOp/LuaBitOp.SlackBuild b/libraries/LuaBitOp/LuaBitOp.SlackBuild
deleted file mode 100644
index b6f32bd6fa..0000000000
--- a/libraries/LuaBitOp/LuaBitOp.SlackBuild
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for LuaBitOp
-
-# Copyright 2017 Gerardo Zamudio <gerardo.zamudio@linux.com> Mexico City
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=LuaBitOp
-VERSION=${VERSION:-1.0.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS=" -O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS=" -O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS=" -O2"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS=" -O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-patch < $CWD/Makefile.patch
-
-CFLAGS="$SLKCFLAGS" \
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -aR doc/* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/LuaBitOp/LuaBitOp.info b/libraries/LuaBitOp/LuaBitOp.info
deleted file mode 100644
index d8e3d2a3d9..0000000000
--- a/libraries/LuaBitOp/LuaBitOp.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="LuaBitOp"
-VERSION="1.0.2"
-HOMEPAGE="http://bitop.luajit.org/"
-DOWNLOAD="http://bitop.luajit.org/download/LuaBitOp-1.0.2.tar.gz"
-MD5SUM="d0c1080fe0c844e8477279668e2d0d06"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="lua"
-MAINTAINER="Gerardo Zamudio"
-EMAIL="gerardo.zamudio@linux.com"
diff --git a/libraries/LuaBitOp/Makefile.patch b/libraries/LuaBitOp/Makefile.patch
deleted file mode 100644
index b6841e5c85..0000000000
--- a/libraries/LuaBitOp/Makefile.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-# Obtained from Springdale Linux (SDL) RPM
-diff -up LuaBitOp-1.0.2/Makefile.destdir LuaBitOp-1.0.2/Makefile
---- Makefile.destdir 2012-05-08 13:15:00.000000000 -0600
-+++ Makefile 2014-06-26 11:20:14.380263499 -0600
-@@ -39,7 +39,9 @@
- $(SOCC) $(SOLDFLAGS) -o $@ $<
-
- install: $(MODSO)
-- $(INSTALL) $< `$(INSTALLPATH) $(MODNAME)`
-+ file=$(DESTDIR)`$(INSTALLPATH) $(MODNAME)`; \
-+ mkdir -p `dirname $$file`; \
-+ $(INSTALL) $< $$file
-
- test: $(MODSO)
- @$(LUA) bittest.lua && echo "basic test OK"
diff --git a/libraries/LuaBitOp/README b/libraries/LuaBitOp/README
deleted file mode 100644
index 4a972a1cfc..0000000000
--- a/libraries/LuaBitOp/README
+++ /dev/null
@@ -1,19 +0,0 @@
-Lua BitOp is a C extension module for Lua 5.1/5.2 which adds bitwise
-operations on numbers.
-
-Features
-
-* Supported functions: bit.tobit, bit.tohex, bit.bnot, bit.band,
- bit.bor, bit.bxor, bit.lshift, bit.rshift, bit.arshift, bit.rol,
- bit.ror, bit.bswap
-* Consistent semantics across 16, 32 and 64 bit platforms.
-* Supports different lua_Number types: either IEEE 754 doubles, int32_t
- or int64_t.
-* Runs on Linux, *BSD, Mac OS X, Windows and probably anything else you
- can find.
-* Simple installation on all systems. No bulky configure scripts.
- Embedded-systems-friendly.
-* Internal self-test on startup to detect miscompiles. Includes a
- comprehensive test and benchmark suite.
-* Compatible with the built-in bitwise operations in LuaJIT 2.0.
-* It's as fast as you can get with the standard Lua/C API.
diff --git a/libraries/LuaBitOp/slack-desc b/libraries/LuaBitOp/slack-desc
deleted file mode 100644
index 508fc96e99..0000000000
--- a/libraries/LuaBitOp/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-LuaBitOp: LuaBitOp (bitwise operations on numbers for Lua)
-LuaBitOp:
-LuaBitOp: Lua BitOp is a C extension module for Lua 5.1 which adds bitwise
-LuaBitOp: operations on numbers.
-LuaBitOp:
-LuaBitOp:
-LuaBitOp:
-LuaBitOp:
-LuaBitOp:
-LuaBitOp: Homepage: http://bitop.luajit.org/
-LuaBitOp: