summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Alexander Verbovetsky <alik@ejik.org>2023-05-05 21:27:31 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-06 08:28:30 +0700
commite5cc5bbbb774aa405bc07589c8d5fcd68f94b2dc (patch)
tree41e318e253729ea75cb70b1ebb18ccee37f86194
parente8331d6f8f275bd0570f4e21e6c163c2883c7747 (diff)
downloadslackbuilds-e5cc5bbbb774aa405bc07589c8d5fcd68f94b2dc.tar.gz
slackbuilds-e5cc5bbbb774aa405bc07589c8d5fcd68f94b2dc.tar.xz
python/python-gmpy2: Removed.
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-gmpy2/README6
-rw-r--r--python/python-gmpy2/python-gmpy2.SlackBuild82
-rw-r--r--python/python-gmpy2/python-gmpy2.info10
-rw-r--r--python/python-gmpy2/slack-desc19
4 files changed, 0 insertions, 117 deletions
diff --git a/python/python-gmpy2/README b/python/python-gmpy2/README
deleted file mode 100644
index 44538874cc..0000000000
--- a/python/python-gmpy2/README
+++ /dev/null
@@ -1,6 +0,0 @@
-gmpy2 is an optimized, c-coded python extension module that supports
-fast multiple-precision arithmetic. gmpy2 is based on the original gmpy
-module. In addition to supporting gmp or mpir for multiple-precision
-integer and rational arithmetic, gmpy2 adds support for the mpfr
-(correctly rounded real floating-point arithmetic) and mpc (correctly
-rounded complex floating-point arithmetic) libraries.
diff --git a/python/python-gmpy2/python-gmpy2.SlackBuild b/python/python-gmpy2/python-gmpy2.SlackBuild
deleted file mode 100644
index 2d20018690..0000000000
--- a/python/python-gmpy2/python-gmpy2.SlackBuild
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python-gmpy2
-
-# Copyright 2019-2022, Alexander Verbovetsky, Moscow, Russia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python-gmpy2
-SRCNAM=gmpy2
-VERSION=${VERSION:-2.1.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xf $CWD/$SRCNAM-$VERSION.tar.?z
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-chmod 644 docs/*
-cp -a README docs $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-gmpy2/python-gmpy2.info b/python/python-gmpy2/python-gmpy2.info
deleted file mode 100644
index 2fbb8a5a8c..0000000000
--- a/python/python-gmpy2/python-gmpy2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-gmpy2"
-VERSION="2.1.2"
-HOMEPAGE="https://github.com/aleaxit/gmpy"
-DOWNLOAD="https://files.pythonhosted.org/packages/80/02/a9f4de927fc1677a68b40d966f9ea757b58997cfe06cf305ffa2159979ce/gmpy2-2.1.2.tar.gz"
-MD5SUM="bb21846e99800e04d5b330b76c23ba10"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Alexander Verbovetsky"
-EMAIL="alik@ejik.org"
diff --git a/python/python-gmpy2/slack-desc b/python/python-gmpy2/slack-desc
deleted file mode 100644
index 020eb16afd..0000000000
--- a/python/python-gmpy2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-gmpy2: python-gmpy2 (multi-precision arithmetic for python)
-python-gmpy2:
-python-gmpy2: gmpy2 is an optimized, c-coded python extension module that supports
-python-gmpy2: fast multiple-precision arithmetic. gmpy2 is based on the original
-python-gmpy2: gmpy module. In addition to supporting gmp or mpir for
-python-gmpy2: multiple-precision integer and rational arithmetic, gmpy2 adds support
-python-gmpy2: for the mpfr (correctly rounded real floating-point arithmetic) and
-python-gmpy2: mpc (correctly rounded complex floating-point arithmetic) libraries.
-python-gmpy2:
-python-gmpy2: Homepage: https://github.com/aleaxit/gmpy
-python-gmpy2: