summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-04-22 23:44:42 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-04-23 10:47:08 +0700
commitdb2339a6a9475cf07f4dd2afad006f5065aa7c44 (patch)
treebded8fb6ec1c4a8d675f7eee1abec25929d80198
parent3f1fcd3703510a4e0417b01cda51d9d2faff4c18 (diff)
downloadslackbuilds-db2339a6a9475cf07f4dd2afad006f5065aa7c44.tar.gz
slackbuilds-db2339a6a9475cf07f4dd2afad006f5065aa7c44.tar.xz
system/colord: Updated for version 1.4.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/colord/colord.SlackBuild73
-rw-r--r--system/colord/colord.info6
2 files changed, 34 insertions, 45 deletions
diff --git a/system/colord/colord.SlackBuild b/system/colord/colord.SlackBuild
index 5112df3e32..9447a4c8d1 100644
--- a/system/colord/colord.SlackBuild
+++ b/system/colord/colord.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for colord
-# Copyright 2015-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2015-2021 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=colord
-VERSION=${VERSION:-1.3.5}
+VERSION=${VERSION:-1.4.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -68,16 +68,9 @@ else
fi
if [ "${BASH_COMPLETION:-no}" = "yes" ]; then
- USE_BASH="--enable-bash-completion"
+ USE_BASH="true"
else
- USE_BASH="--disable-bash-completion"
-fi
-
-# Check if ARGYLL is set to yes
-if [ "${ARGYLL:-no}" = "yes" ]; then
- argyll="--enable-argyllcms-sensor"
-else
- argyll="--disable-argyllcms-sensor"
+ USE_BASH="false"
fi
set -e
@@ -98,41 +91,37 @@ find -L . \
# Since polkit in current apply upstream git
# we have to reduce the polkit version used to test
# https://github.com/hughsie/colord/issues/36
-sed -i "s|114|113|g" configure
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --disable-static \
- --enable-gusb \
- --enable-udev \
- --enable-polkit \
- --enable-sane \
- --enable-libcolordcompat \
- $argyll \
- --enable-vala \
- --disable-systemd-login \
- --with-daemon-user=colord \
- --build=$ARCH-slackware-linux \
- $USE_BASH
-
-make
-make install DESTDIR=$PKG
+sed -i "s|0.114|0.113|" meson.build
+
+mkdir -p build
+cd build
+meson --prefix=/usr \
+ --buildtype=release \
+ --localstatedir=/var \
+ --libdir=lib${LIBDIRSUFFIX} \
+ --libexecdir=/usr/lib${LIBDIRSUFFIX}/colord \
+ --mandir=/usr/man \
+ -Dlibcolordcompat=true \
+ -Dsane=true \
+ -Dvapi=true \
+ -Dsystemd=false \
+ -Dargyllcms_sensor=false \
+ -Dprint_profiles=false \
+ -Dtests=false \
+ -Dbash_completion=${USE_BASH} \
+ -Ddaemon_user=colord \
+ -Dman=false \
+ ../
+ninja
+DESTDIR=$PKG ninja install
+cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mv $PKG/etc/dbus-1/system.d/org.freedesktop.ColorManager.conf \
- $PKG/etc/dbus-1/system.d/org.freedesktop.ColorManager.conf.new
+# Fix paths
+sed -i "s|/lib|/lib${LIBDIRSUFFIX}|g" $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig/colord.pc
+sed -i "s|/lib|/lib${LIBDIRSUFFIX}|g" $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig/colorhug.pc
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING* MAINTAINERS $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/system/colord/colord.info b/system/colord/colord.info
index b792b9d795..e1222d3a26 100644
--- a/system/colord/colord.info
+++ b/system/colord/colord.info
@@ -1,8 +1,8 @@
PRGNAM="colord"
-VERSION="1.3.5"
+VERSION="1.4.5"
HOMEPAGE="http://www.freedesktop.org/software/colord"
-DOWNLOAD="http://www.freedesktop.org/software/colord/releases/colord-1.3.5.tar.xz"
-MD5SUM="a8e7fcf0a45383ca7a65cef91ca5e019"
+DOWNLOAD="http://www.freedesktop.org/software/colord/releases/colord-1.4.5.tar.xz"
+MD5SUM="adc4501b54fb8667ee99f64cff87e12d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libgusb"