summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-05-27 08:05:49 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-06-10 09:23:02 +0700
commita7e8b949f35ab3f903768685c00de1ab85cbb747 (patch)
tree475e3410ad04bc154a61f829d18697c9d05aa3ae
parent9c59c42d164732bc3cf4845d63eadec2036a5ba7 (diff)
downloadslackbuilds-a7e8b949f35ab3f903768685c00de1ab85cbb747.tar.gz
slackbuilds-a7e8b949f35ab3f903768685c00de1ab85cbb747.tar.xz
system/docker-compose: Removed: (replaced by python3-docker-compose)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/docker-compose/README7
-rw-r--r--system/docker-compose/docker-compose.SlackBuild89
-rw-r--r--system/docker-compose/docker-compose.info10
-rw-r--r--system/docker-compose/slack-desc19
4 files changed, 0 insertions, 125 deletions
diff --git a/system/docker-compose/README b/system/docker-compose/README
deleted file mode 100644
index c2fe93df16..0000000000
--- a/system/docker-compose/README
+++ /dev/null
@@ -1,7 +0,0 @@
-Compose is a tool for defining and running multi-container Docker
-applications. With Compose, you use a Compose file to configure your
-application's services. Then, using a single command, you create and
-start all the services from your configuration.
-
-Compose is great for development, testing, and staging environments, as
-well as CI workflows.
diff --git a/system/docker-compose/docker-compose.SlackBuild b/system/docker-compose/docker-compose.SlackBuild
deleted file mode 100644
index 1d58c12e12..0000000000
--- a/system/docker-compose/docker-compose.SlackBuild
+++ /dev/null
@@ -1,89 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for docker-compose
-
-# Copyright 2017-2018 Audrius Kažukauskas <audrius@neutrino.lt>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=docker-compose
-VERSION=${VERSION:-1.21.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Remove upper bound on requires.
-sed -i "s/, < .*',$/',/" setup.py
-
-python2 setup.py install --root=$PKG
-
-# Completion.
-install -D -m 0644 contrib/completion/bash/docker-compose \
- $PKG/usr/share/bash-completion/completions/docker-compose
-install -D -m 0644 contrib/completion/zsh/_docker-compose \
- $PKG/usr/share/zsh/site-functions/_docker-compose
-install -D -m 0644 contrib/completion/fish/docker-compose.fish \
- $PKG/usr/share/fish/vendor_completions.d/docker-compose.fish
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG.md LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/docker-compose/docker-compose.info b/system/docker-compose/docker-compose.info
deleted file mode 100644
index ca9641debb..0000000000
--- a/system/docker-compose/docker-compose.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="docker-compose"
-VERSION="1.21.1"
-HOMEPAGE="https://docs.docker.com/compose/"
-DOWNLOAD="https://files.pythonhosted.org/packages/04/93/8547a7701e44b0ea24735d1950fe7e6fe90951f0ebb6757dabf76ee64473/docker-compose-1.21.1.tar.gz"
-MD5SUM="9dbc93a798fcda7b871ed6d580dc1a18"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-PyYAML python2-docopt jsonschema python2-cached-property python2-docker python2-dockerpty python2-texttable"
-MAINTAINER="Audrius Kažukauskas"
-EMAIL="audrius@neutrino.lt"
diff --git a/system/docker-compose/slack-desc b/system/docker-compose/slack-desc
deleted file mode 100644
index 4ce7ddc508..0000000000
--- a/system/docker-compose/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-docker-compose: docker-compose (multi-container orchestration for docker)
-docker-compose:
-docker-compose: Compose is a tool for defining and running multi-container Docker
-docker-compose: applications. With Compose, you use a Compose file to configure your
-docker-compose: application's services. Then, using a single command, you create and
-docker-compose: start all the services from your configuration.
-docker-compose:
-docker-compose: Homepage: https://docs.docker.com/compose/
-docker-compose:
-docker-compose:
-docker-compose: