summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-09-04 05:18:13 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-09 10:14:16 +0700
commit91d2ca69b65be8e00a2c6893c70c45937f629738 (patch)
treea60ef2df8e3357f924dd36c72dcdcb75f2a40ece
parent99ac9d3700c66176ca530765af134d143f0023db (diff)
downloadslackbuilds-91d2ca69b65be8e00a2c6893c70c45937f629738.tar.gz
slackbuilds-91d2ca69b65be8e00a2c6893c70c45937f629738.tar.xz
python/python3-rich: Updated for version 13.5.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-rich/python3-rich.SlackBuild8
-rw-r--r--python/python3-rich/python3-rich.info6
2 files changed, 10 insertions, 4 deletions
diff --git a/python/python3-rich/python3-rich.SlackBuild b/python/python3-rich/python3-rich.SlackBuild
index 4a52f6bb43..2a75552379 100644
--- a/python/python3-rich/python3-rich.SlackBuild
+++ b/python/python3-rich/python3-rich.SlackBuild
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-rich
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-13.3.5}
+VERSION=${VERSION:-13.5.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -59,6 +59,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -79,6 +82,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+# lower version requirements for pygments
+sed -i '/^pygments/ s/2\.13/2.10/' pyproject.toml
+
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl
diff --git a/python/python3-rich/python3-rich.info b/python/python3-rich/python3-rich.info
index b3404e9cd5..47c53135b8 100644
--- a/python/python3-rich/python3-rich.info
+++ b/python/python3-rich/python3-rich.info
@@ -1,8 +1,8 @@
PRGNAM="python3-rich"
-VERSION="13.3.5"
+VERSION="13.5.2"
HOMEPAGE="https://github.com/Textualize/rich"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/r/rich/rich-13.3.5.tar.gz"
-MD5SUM="8943de826cb552dd5e84a46c6c416c89"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/r/rich/rich-13.5.2.tar.gz"
+MD5SUM="08ac7c52966450e9b67cb5313244ccb3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-poetry-core python3-markdown-it-py"