summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2023-07-30 17:01:37 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-08-05 10:08:55 +0700
commit8bd25ed3cd8cfc1bbef4115907d8243c321079b9 (patch)
tree1425511a3a90fa521f0ee363380b945df6e7ef1a
parentee0d8b6b83f4352ec09a78fbe43833f491164b26 (diff)
downloadslackbuilds-8bd25ed3cd8cfc1bbef4115907d8243c321079b9.tar.gz
slackbuilds-8bd25ed3cd8cfc1bbef4115907d8243c321079b9.tar.xz
python/pathlib2: Removed (split to python2 and python3).
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pathlib2/README4
-rw-r--r--python/pathlib2/pathlib2.SlackBuild96
-rw-r--r--python/pathlib2/pathlib2.info10
-rw-r--r--python/pathlib2/slack-desc19
4 files changed, 0 insertions, 129 deletions
diff --git a/python/pathlib2/README b/python/pathlib2/README
deleted file mode 100644
index 4ae19c8621..0000000000
--- a/python/pathlib2/README
+++ /dev/null
@@ -1,4 +0,0 @@
-The old pathlib module on bitbucket is in bugfix-only mode. The goal of
-pathlib2 is to provide a backport of standard pathlib module which
-tracks the standard library module, so all the newest features of the
-standard pathlib can be used also on older Python versions.
diff --git a/python/pathlib2/pathlib2.SlackBuild b/python/pathlib2/pathlib2.SlackBuild
deleted file mode 100644
index e6a1ac71f2..0000000000
--- a/python/pathlib2/pathlib2.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pathlib2
-
-# Copyright 2018 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pathlib2
-VERSION=${VERSION:-2.3.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG.rst LICENSE.rst README.rst VERSION $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pathlib2/pathlib2.info b/python/pathlib2/pathlib2.info
deleted file mode 100644
index db60f73d69..0000000000
--- a/python/pathlib2/pathlib2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pathlib2"
-VERSION="2.3.2"
-HOMEPAGE="https://pypi.org/project/pathlib2/"
-DOWNLOAD="https://files.pythonhosted.org/packages/db/a8/7d6439c1aec525ed70810abee5b7d7f3aa35347f59bc28343e8f62019aa2/pathlib2-2.3.2.tar.gz"
-MD5SUM="fd76fb5d0baa798bfe12fb7965da97f8"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-scandir"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/pathlib2/slack-desc b/python/pathlib2/slack-desc
deleted file mode 100644
index d205388d5e..0000000000
--- a/python/pathlib2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pathlib2: pathlib2 (Object-oriented filesystem paths)
-pathlib2:
-pathlib2: The old pathlib module on bitbucket is in bugfix-only mode. The goal
-pathlib2: of pathlib2 is to provide a backport of standard pathlib module which
-pathlib2: tracks the standard library module, so all the newest features of the
-pathlib2: standard pathlib can be used also on older Python versions.
-pathlib2:
-pathlib2: Homepage: https://pypi.org/project/pathlib2/
-pathlib2:
-pathlib2:
-pathlib2: