summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2021-04-21 00:26:58 -0500
committer Robby Workman <rworkman@slackbuilds.org>2021-04-21 00:26:58 -0500
commit5b6c14359e8dff40e3a597ba0cae1d46ee2abe3e (patch)
tree2b36abae5796c19577d2fd7e7da3760503735782
parent7bfbb23a3de23b640e016c536666fde2c1190f03 (diff)
downloadslackbuilds-5b6c14359e8dff40e3a597ba0cae1d46ee2abe3e.tar.gz
slackbuilds-5b6c14359e8dff40e3a597ba0cae1d46ee2abe3e.tar.xz
python/python-distutils-extra: Build with python3 by default
-rw-r--r--python/python-distutils-extra/README4
-rw-r--r--python/python-distutils-extra/python-distutils-extra.SlackBuild6
2 files changed, 1 insertions, 9 deletions
diff --git a/python/python-distutils-extra/README b/python/python-distutils-extra/README
index 90754780d3..5e652e923f 100644
--- a/python/python-distutils-extra/README
+++ b/python/python-distutils-extra/README
@@ -2,7 +2,3 @@ Python-distutils-extra allows to easily integrate themable icons,
scrollkeeper based documentation, and gettext based translations in
your python install and build tools. It can be used with python's
distutils or the enhanced setuptools.
-
-To install python3 bindings run the slackbuild with PYTHON3=yes.
-
- # PYTHON3=yes ./python-distutils-extra.SlackBuild
diff --git a/python/python-distutils-extra/python-distutils-extra.SlackBuild b/python/python-distutils-extra/python-distutils-extra.SlackBuild
index 9e25ef75a7..5ff5ef359f 100644
--- a/python/python-distutils-extra/python-distutils-extra.SlackBuild
+++ b/python/python-distutils-extra/python-distutils-extra.SlackBuild
@@ -56,11 +56,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-
-# Install python3 bindings for distutils-extra. Default is no.
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true