summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2022-04-24 21:14:31 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-30 13:51:48 +0700
commit4b6c4b9509a3a2f01a039fb9010603609e58198f (patch)
tree680683c67d4e4df957946589afeb663b22610c5d
parent9fdb3f4dd763580a9d261871a1eb1bf3bc670f11 (diff)
downloadslackbuilds-4b6c4b9509a3a2f01a039fb9010603609e58198f.tar.gz
slackbuilds-4b6c4b9509a3a2f01a039fb9010603609e58198f.tar.xz
network/elinks: Add Patches: disable suspend, -no-connect
2 contributed patches. VERSION renumbering with commit hash. Not likely to change unless felinks fixes are back-ported though. Change download URL. Extra notes in README. Tidy up slackbuild a bit. Move stuff. Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/elinks/README47
-rw-r--r--network/elinks/elinks.SlackBuild65
-rw-r--r--network/elinks/elinks.info10
-rw-r--r--network/elinks/option-patches/0010-disable-suspend-pause.patch19
-rw-r--r--network/elinks/option-patches/0020-no-connect-by-default.patch62
-rw-r--r--network/elinks/patches/0004-ssl_cert_verify.patch147
-rw-r--r--network/elinks/patches/0010-force-text-wrap.patch (renamed from network/elinks/patches/0000-force-text-wrap.patch)0
-rw-r--r--network/elinks/patches/0020-gopher-html-links.patch (renamed from network/elinks/patches/0001-gopher_html_links.patch)0
-rw-r--r--network/elinks/patches/0030-gopher-index-queries.patch (renamed from network/elinks/patches/0002-gopher_index_queries.patch)0
-rw-r--r--network/elinks/patches/0040-gopher-directory-links.patch (renamed from network/elinks/patches/0003-gopher_directory_links.patch)0
-rw-r--r--network/elinks/patches/0050-gopher-newlines-tabs-entity.patch (renamed from network/elinks/patches/0005-gopher_newlines_tabs_entity.patch)0
-rw-r--r--network/elinks/patches/0060-gopher-indexes-nocr.patch (renamed from network/elinks/patches/0006-gopher-indexes_nocr.patch)0
-rw-r--r--network/elinks/patches/0070-gopher-move-null.patch (renamed from network/elinks/patches/0007-gopher-move_null.patch)0
-rw-r--r--network/elinks/patches/0080-gopher-html-entities.patch (renamed from network/elinks/patches/0008-gopher-html-entities.patch)0
-rw-r--r--network/elinks/patches/0090-fix-lib-path.patch (renamed from network/elinks/patches/0010-fix-lib-path.patch)0
-rw-r--r--network/elinks/slack-desc2
16 files changed, 157 insertions, 195 deletions
diff --git a/network/elinks/README b/network/elinks/README
index 83365bb46a..e40cc46f9e 100644
--- a/network/elinks/README
+++ b/network/elinks/README
@@ -1,10 +1,8 @@
-elinks (ELinks - Full-Featured Text WWW Browser)
-
-ELinks is an advanced and well-established feature-rich text mode web
-(HTTP/FTP/..) browser. ELinks can render both frames and tables, is
+Elinks is an advanced and well-established feature-rich text mode web
+(HTTP/FTP/..) browser. Elinks can render both frames and tables, is
highly customizable, and can be extended via Lua or Guile scripts. It
-is very portable and runs on a variety of platforms. It also uses
-SpiderMonkey javascript support.
+is very portable and runs on a variety of platforms. It also has
+(very limited) JavaScript support via SpiderMonkey (js185).
There are a number of options that can be used to add support for
other protocols etc. To enable or disable an option use the following
@@ -14,8 +12,6 @@ MOUSE=no ./elinks.SlackBuild
Several options can be combined together.
-OPTIONS
-
Category Description Default Value
System:
@@ -55,15 +51,40 @@ DATA yes
FSP no
FTP yes
FINGER no
-GOPHER no
+GOPHER (use internal gopher code, see note below) no
NNTP no
SMB no
Note that Unicode combining characters is marked as experimental.
-Optional dependencies apart from scripting languages stated above:
+Contributed Patches:
+
+Thanks goes to B. Watson for the following two patches:
+
+No Suspend Patch
+
+Elinks sometimes has problems resuming if it has been suspended with ^Z.
+To apply a patch that disables ^Z, ^S and ^Q suspend/pause/resume keys
+so that they are available to bind in elinks:
+
+ NO_SUSPEND=yes
+
+No Connect Patch.
+
+Sometimes when quitting and another client is running on the same
+session-ring, the process will freeze and require killing manually.
+This patch solves that by making elinks use '-no-connect 1' by default.
+It won't be possible to open links in new windows with this, but using
+URI passing is a workaround.
+
+ NO_CONNECT=yes
+
+Auto-detected Dependencies:
-tre: for regex search support
+js185: SpiderMonkey (can be turned off in options).
+tre: regexp support in searches.
-Note: this version uses the last commit in elinks' git repo, before it
-was forked into felinks (f86be659718c0cd0a67f88b42f07044c23d0d028).
+Other included patches help make the internal gopher support usable. By
+default elinks will hand gopher URLs to lynx if the GOPHER option isn't
+set. Using the internal gopher client has the advantage of having
+combined http and gopher bookmarks, and a more uniform interface.
diff --git a/network/elinks/elinks.SlackBuild b/network/elinks/elinks.SlackBuild
index 71a4402a75..86232118d4 100644
--- a/network/elinks/elinks.SlackBuild
+++ b/network/elinks/elinks.SlackBuild
@@ -24,8 +24,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=elinks
-VERSION=${VERSION:-git20170723}
-COMMIT=f86be659
+VERSION=${VERSION:-20170723_f86be65}
+COMMIT=${VERSION#*_}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,45 +47,53 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-# Added -fno-strict-aliasing -Wno-pointer-sign for a much more peaceful build
if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686 -fno-strict-aliasing -Wno-pointer-sign"
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686 -fno-strict-aliasing -Wno-pointer-sign"
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC -fno-strict-aliasing -Wno-pointer-sign"
- SLKLDFLAGS="-m64"
+ SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
+# A much more peaceful build
+SLKCFLAGS="$SLKCFLAGS -fno-strict-aliasing -Wno-pointer-sign"
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$COMMIT
-tar xvf $CWD/$PRGNAM-$COMMIT.tar.?z
+tar xvf $CWD/$COMMIT.tar.?z
cd $PRGNAM-$COMMIT
-# fix documentation generation on 15.0.
-# xmlto needs --skip-validation or it fails.
-sed -i 's/$(XMLTO) -o/$(XMLTO) --skip-validation -o/' doc/Makefile
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# fix documentation generation on 15.0.
+# xmlto needs --skip-validation or it fails.
+sed -i 's/$(XMLTO) -o/$(XMLTO) --skip-validation -o/' doc/Makefile
-for patch in $CWD/patches/*
-do
+for patch in $CWD/patches/*; do
patch --verbose -p1 < $patch
done
+# patches for no suspend (^Z) and -no-connect by default
+# courtesy of B. Watson.
+[ "${NO_SUSPEND:-no}" = "yes" ] &&
+ patch --verbose -p1 -i $CWD/option-patches/0010-*
+[ "${NO_CONNECT:-no}" = "yes" ] &&
+ patch --verbose -p1 -i $CWD/option-patches/0020-*
+
# System
[ "${FASTMEM:-no}" = "yes" ] && fastmem="--enable-fastmem"
[ "${CGI:-no}" = "yes" ] && cgi="--enable-cgi"
@@ -125,8 +130,11 @@ done
[ "${NNTP:-no}" = "yes" ] && nntp="--enable-nntp"
[ "${SMB:-no}" = "yes" ] && smb="--enable-smb"
+# quiet some more warnings
+sed "s,^aclocal,& -Wnone," -i autogen.sh
+
./autogen.sh
-CFLAGS="$SLKCFLAGS -L/usr/lib64" \
+CFLAGS="$SLKCFLAGS -L/usr/lib$LIBDIRSUFFIX" \
./configure \
--prefix=/usr \
--libdir=/usr/lib$LIBDIRSUFFIX \
@@ -135,6 +143,7 @@ CFLAGS="$SLKCFLAGS -L/usr/lib64" \
--mandir=/usr/man \
--infodir=/usr/info \
--docdir=/usr/doc/$PRGNAM-$VERSION \
+ --htmldir=/usr/doc/$PRGNAM-$VERSION/html \
$fastmem \
$cgi \
$combining \
@@ -164,16 +173,12 @@ CFLAGS="$SLKCFLAGS -L/usr/lib64" \
--build=$ARCH-slackware-linux
make
+# html doesn't install so we copy it later
+make -C doc html
make install DESTDIR=$PKG
-cd doc
-make html
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+strip --strip-unneeded $PKG/usr/bin/$PRGNAM
+gzip -9 $PKG/usr/man/man?/*.?
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
@@ -182,7 +187,9 @@ cp -a \
doc/*txt doc/manual.html-chunked \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-rm -f $PKG/usr/doc/$PRGNAM-$VERSION/manual.html-chunked/manual.proc
+
+# don't need these
+find $PKG \( -name ".gitignore" -o -name "manual.proc" \) -delete
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/network/elinks/elinks.info b/network/elinks/elinks.info
index 267545e39a..9e62b47739 100644
--- a/network/elinks/elinks.info
+++ b/network/elinks/elinks.info
@@ -1,10 +1,10 @@
PRGNAM="elinks"
-VERSION="git20170723"
-HOMEPAGE="http://elinks.or.cz"
-DOWNLOAD="http://www.unrealize.co.uk/source/elinks-f86be659.tar.gz"
-MD5SUM="86c2270d083d25573609adb827eb1a04"
+VERSION="20170723_f86be65"
+HOMEPAGE="http://elinks.cz"
+DOWNLOAD="https://repo.or.cz/elinks.git/snapshot/f86be65.tar.gz"
+MD5SUM="660ae64c253f1e2014064dc1a3fbed80"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="David Woodfall"
+MAINTAINER="Dave Woodfall"
EMAIL="dave@slackbuilds.org"
diff --git a/network/elinks/option-patches/0010-disable-suspend-pause.patch b/network/elinks/option-patches/0010-disable-suspend-pause.patch
new file mode 100644
index 0000000000..9a85ad5669
--- /dev/null
+++ b/network/elinks/option-patches/0010-disable-suspend-pause.patch
@@ -0,0 +1,19 @@
+diff -Naur elinks-git20131231/src/terminal/kbd.c elinks-git20131231.patched/src/terminal/kbd.c
+--- elinks-git20131231/src/terminal/kbd.c 2013-12-18 10:38:57.000000000 -0500
++++ elinks-git20131231.patched/src/terminal/kbd.c 2020-06-25 01:32:29.333043353 -0400
+@@ -263,6 +263,15 @@
+ t.c_lflag |= TOSTOP;
+ #endif
+ t.c_oflag |= OPOST;
++
++ /* 20200625 bkw: patched code disables suspend (normally ^Z),
++ pause (normally ^S) and resume (normally ^Q). This allows
++ us to use those keys for normal keybinds. If we're running
++ elinks in tmux or screen, or in X with multiple terminals,
++ or the Linux console (multiple consoles), we don't really
++ need ^Z anyway. */
++ t.c_cc[VSUSP] = t.c_cc[VSTOP] = t.c_cc[VSTART] = vdisable;
++
+ if (tcsetattr(itrm->in.ctl, TCSANOW, &t)) return -1;
+
+ return 0;
diff --git a/network/elinks/option-patches/0020-no-connect-by-default.patch b/network/elinks/option-patches/0020-no-connect-by-default.patch
new file mode 100644
index 0000000000..e36c9aa006
--- /dev/null
+++ b/network/elinks/option-patches/0020-no-connect-by-default.patch
@@ -0,0 +1,62 @@
+diff -Naur elinks-git20131231/doc/man/man1/elinks.1.in elinks-git20131231.patched/doc/man/man1/elinks.1.in
+--- elinks-git20131231/doc/man/man1/elinks.1.in 2013-12-18 10:38:57.000000000 -0500
++++ elinks-git20131231.patched/doc/man/man1/elinks.1.in 2020-06-25 03:02:54.523412259 -0400
+@@ -141,12 +141,13 @@
+ Look up specified host and print all DNS resolved IP addresses\&.
+ .RE
+ .PP
+-\fB\-no\-connect\fR \fI[0|1]\fR (default: 0)
++\fB\-no\-connect\fR \fI[0|1]\fR (default: 1)
+ .RS 4
+ Run
+ ELinks
+-as a separate instance instead of connecting to an existing instance\&. Note that normally no runtime state files (bookmarks, history, etc\&.) are written to the disk when this option is used\&. See also
+-\-touch\-files\&.
++as a separate instance instead of connecting to an existing instance\&. Enabled
++by default in this build; use \fB\-no\-connect 0\fR to connect to an existing
++instance\&.
+ .RE
+ .PP
+ \fB\-no\-home\fR \fI[0|1]\fR (default: 0)
+@@ -238,13 +239,13 @@
+ Print given URLs in source form to stdout\&.
+ .RE
+ .PP
+-\fB\-touch\-files\fR \fI[0|1]\fR (default: 0)
++\fB\-touch\-files\fR \fI[0|1]\fR (default: 1)
+ .RS 4
+ When enabled, runtime state files (bookmarks, history, etc\&.) are written to disk, even when
+ \-no\-connect
+ or
+ \-session\-ring
+-is used\&. The option has no effect if not used in conjunction with any of these options\&.
++is used\&. The option has no effect if not used in conjunction with any of these options\&. This option is enabled by default; use \fB\-touch\-files 0\fR to disable\&.
+ .RE
+ .PP
+ \fB\-verbose\fR \fI<num>\fR (default: 1)
+diff -Naur elinks-git20131231/src/config/cmdline.c elinks-git20131231.patched/src/config/cmdline.c
+--- elinks-git20131231/src/config/cmdline.c 2013-12-18 10:38:57.000000000 -0500
++++ elinks-git20131231.patched/src/config/cmdline.c 2020-06-25 02:58:31.595442844 -0400
+@@ -848,11 +848,9 @@
+ "addresses.")),
+
+ INIT_OPT_BOOL("", N_("Run as separate instance"),
+- "no-connect", 0, 0,
++ "no-connect", 0, 1,
+ N_("Run ELinks as a separate instance instead of connecting "
+- "to an existing instance. Note that normally no runtime state "
+- "files (bookmarks, history, etc.) are written to the disk "
+- "when this option is used. See also -touch-files.")),
++ "to an existing instance. Enabled by default in this build.")),
+
+ INIT_OPT_BOOL("", N_("Disable use of files in ~/.elinks"),
+ "no-home", 0, 0,
+@@ -921,7 +919,7 @@
+ INIT_OPT_COMMAND("", NULL, "stdin", OPT_HIDDEN, redir_cmd, NULL),
+
+ INIT_OPT_BOOL("", N_("Touch files in ~/.elinks when running with -no-connect/-session-ring"),
+- "touch-files", 0, 0,
++ "touch-files", 0, 1,
+ N_("When enabled, runtime state files (bookmarks, history, "
+ "etc.) are written to disk, even when -no-connect or "
+ "-session-ring is used. The option has no effect if not used "
diff --git a/network/elinks/patches/0004-ssl_cert_verify.patch b/network/elinks/patches/0004-ssl_cert_verify.patch
deleted file mode 100644
index 6bb1748856..0000000000
--- a/network/elinks/patches/0004-ssl_cert_verify.patch
+++ /dev/null
@@ -1,147 +0,0 @@
-##############################################################################
-# Verify SSL host names with OpenSSL.
-# Turn on verification by default.
-# http://lists.linuxfromscratch.org/pipermail/elinks-dev/2015-June/002099.html
-# dave@slackbuilds.org
-##############################################################################
---- a/configure.in 2017-12-21 15:58:12.470247050 +0000
-+++ b/configure.in 2017-12-21 16:10:27.406938487 +0000
-@@ -1132,6 +1132,9 @@
- fi
-
- AC_MSG_RESULT($cf_result)
-+if test "$cf_result" = yes; then
-+ AC_CHECK_FUNCS(X509_VERIFY_PARAM_set1_host)
-+fi
-
- # ---- GNU TLS
-
-diff -Naur a/src/network/ssl/socket.c b/src/network/ssl/socket.c
---- a/src/network/ssl/socket.c 2017-12-21 15:58:12.553249389 +0000
-+++ b/src/network/ssl/socket.c 2017-12-21 16:11:47.532190591 +0000
-@@ -7,6 +7,9 @@
- #ifdef CONFIG_OPENSSL
- #include <openssl/ssl.h>
- #include <openssl/x509v3.h>
-+#ifdef HAVE_X509_VERIFY_PARAM_SET1_HOST
-+#include <openssl/x509_vfy.h>
-+#endif
- #define USE_OPENSSL
- #elif defined(CONFIG_NSS_COMPAT_OSSL)
- #include <nss_compat_ossl/nss_compat_ossl.h>
-@@ -168,6 +171,30 @@
-
- #ifdef USE_OPENSSL
-
-+#ifdef HAVE_X509_VERIFY_PARAM_SET1_HOST
-+/* activate the OpenSSL-provided host name check */
-+static int
-+ossl_set_hostname(void *ssl, unsigned char *server_name)
-+{
-+ int ret = -1;
-+
-+ X509_VERIFY_PARAM *vpm = X509_VERIFY_PARAM_new();
-+ if (vpm) {
-+ if (X509_VERIFY_PARAM_set1_host(vpm, (char *) server_name, 0)
-+ && SSL_set1_param(ssl, vpm))
-+ {
-+ /* successfully activated the OpenSSL host name check */
-+ ret = 0;
-+ }
-+
-+ X509_VERIFY_PARAM_free(vpm);
-+ }
-+
-+ return ret;
-+}
-+
-+#else /* HAVE_X509_VERIFY_PARAM_SET1_HOST */
-+
- /** Checks whether the host component of a URI matches a host name in
- * the server certificate.
- *
-@@ -360,6 +387,7 @@
- mem_free(host_in_uri);
- return matched;
- }
-+#endif /* HAVE_X509_VERIFY_PARAM_SET1_HOST */
-
- #endif /* USE_OPENSSL */
-
-@@ -389,7 +417,10 @@
-
- default:
- socket->no_tls = !socket->no_tls;
-- socket->ops->retry(socket, connection_state(S_SSL_ERROR));
-+ if (SSL_VERIFY_FAIL_IF_NO_PEER_CERT)
-+ socket->ops->retry(socket, connection_state(S_SSL_CERTFAIL));
-+ else
-+ socket->ops->retry(socket, connection_state(S_SSL_ERROR));
- }
- }
-
-@@ -400,6 +431,9 @@
- int ret;
- unsigned char *server_name;
- struct connection *conn = socket->conn;
-+#ifdef USE_OPENSSL
-+ int (*verify_callback_ptr)(int, X509_STORE_CTX *);
-+#endif /* USE_OPENSSL */
-
- /* TODO: Recode server_name to UTF-8. */
- server_name = get_uri_string(conn->proxied_uri, URI_HOST);
-@@ -418,6 +452,23 @@
- return -1;
- }
-
-+#ifdef USE_OPENSSL
-+#ifdef HAVE_X509_VERIFY_PARAM_SET1_HOST
-+ /* activate the OpenSSL-provided host name check */
-+ if (ossl_set_hostname(socket->ssl, server_name)) {
-+ mem_free_if(server_name);
-+ socket->ops->done(socket, connection_state(S_SSL_ERROR));
-+ return -1;
-+ }
-+
-+ /* verify_callback() is not needed with X509_VERIFY_PARAM_set1_host() */
-+ verify_callback_ptr = NULL;
-+#else
-+ /* use our own callback implementing the host name check */
-+ verify_callback_ptr = verify_callback;
-+#endif
-+#endif /* USE_OPENSSL */
-+
- mem_free_if(server_name);
-
- if (socket->no_tls)
-@@ -429,7 +480,7 @@
- if (get_opt_bool("connection.ssl.cert_verify", NULL))
- SSL_set_verify(socket->ssl, SSL_VERIFY_PEER
- | SSL_VERIFY_FAIL_IF_NO_PEER_CERT,
-- verify_callback);
-+ verify_callback_ptr);
-
- if (get_opt_bool("connection.ssl.client_cert.enable", NULL)) {
- unsigned char *client_cert;
-diff -Naur a/src/network/state.c b/src/network/state.c
---- a/src/network/state.c 2017-12-21 15:58:12.553249389 +0000
-+++ b/src/network/state.c 2017-12-21 16:10:20.579746621 +0000
-@@ -88,6 +88,7 @@
-
- #ifdef CONFIG_SSL
- {S_SSL_ERROR, N_("SSL error")},
-+ {S_SSL_CERTFAIL, N_("SSL Host Verification Failed.")},
- #else
- {S_SSL_ERROR, N_("This version of ELinks does not contain SSL/TLS support")},
- #endif
-diff -Naur a/src/network/state.h b/src/network/state.h
---- a/src/network/state.h 2017-12-21 15:58:12.553249389 +0000
-+++ b/src/network/state.h 2017-12-21 16:10:03.057254202 +0000
-@@ -67,6 +67,7 @@
- S_ENCODE_ERROR = -100017,
- S_SSL_ERROR = -100018,
- S_NO_FORCED_DNS = -100019,
-+ S_SSL_CERTFAIL = -100020,
-
- S_HTTP_ERROR = -100100,
- S_HTTP_204 = -100101,
diff --git a/network/elinks/patches/0000-force-text-wrap.patch b/network/elinks/patches/0010-force-text-wrap.patch
index 4705cb0893..4705cb0893 100644
--- a/network/elinks/patches/0000-force-text-wrap.patch
+++ b/network/elinks/patches/0010-force-text-wrap.patch
diff --git a/network/elinks/patches/0001-gopher_html_links.patch b/network/elinks/patches/0020-gopher-html-links.patch
index 38a2dd0b10..38a2dd0b10 100644
--- a/network/elinks/patches/0001-gopher_html_links.patch
+++ b/network/elinks/patches/0020-gopher-html-links.patch
diff --git a/network/elinks/patches/0002-gopher_index_queries.patch b/network/elinks/patches/0030-gopher-index-queries.patch
index 662fd13a7f..662fd13a7f 100644
--- a/network/elinks/patches/0002-gopher_index_queries.patch
+++ b/network/elinks/patches/0030-gopher-index-queries.patch
diff --git a/network/elinks/patches/0003-gopher_directory_links.patch b/network/elinks/patches/0040-gopher-directory-links.patch
index 15a89fac2f..15a89fac2f 100644
--- a/network/elinks/patches/0003-gopher_directory_links.patch
+++ b/network/elinks/patches/0040-gopher-directory-links.patch
diff --git a/network/elinks/patches/0005-gopher_newlines_tabs_entity.patch b/network/elinks/patches/0050-gopher-newlines-tabs-entity.patch
index b255fb4f98..b255fb4f98 100644
--- a/network/elinks/patches/0005-gopher_newlines_tabs_entity.patch
+++ b/network/elinks/patches/0050-gopher-newlines-tabs-entity.patch
diff --git a/network/elinks/patches/0006-gopher-indexes_nocr.patch b/network/elinks/patches/0060-gopher-indexes-nocr.patch
index 9e4a441db6..9e4a441db6 100644
--- a/network/elinks/patches/0006-gopher-indexes_nocr.patch
+++ b/network/elinks/patches/0060-gopher-indexes-nocr.patch
diff --git a/network/elinks/patches/0007-gopher-move_null.patch b/network/elinks/patches/0070-gopher-move-null.patch
index 8f259e55cf..8f259e55cf 100644
--- a/network/elinks/patches/0007-gopher-move_null.patch
+++ b/network/elinks/patches/0070-gopher-move-null.patch
diff --git a/network/elinks/patches/0008-gopher-html-entities.patch b/network/elinks/patches/0080-gopher-html-entities.patch
index 750d1a49de..750d1a49de 100644
--- a/network/elinks/patches/0008-gopher-html-entities.patch
+++ b/network/elinks/patches/0080-gopher-html-entities.patch
diff --git a/network/elinks/patches/0010-fix-lib-path.patch b/network/elinks/patches/0090-fix-lib-path.patch
index 2cdee67fbd..2cdee67fbd 100644
--- a/network/elinks/patches/0010-fix-lib-path.patch
+++ b/network/elinks/patches/0090-fix-lib-path.patch
diff --git a/network/elinks/slack-desc b/network/elinks/slack-desc
index 13590c62fd..7ae5ceddeb 100644
--- a/network/elinks/slack-desc
+++ b/network/elinks/slack-desc
@@ -13,7 +13,7 @@ elinks: web (HTTP/FTP/..) browser. ELinks can render both frames and tables,
elinks: is highly customizable, and can be extended via Lua or Guile scripts.
elinks: It is very portable and runs on a variety of platforms.
elinks:
-elinks: For more information, see: http://elinks.or.cz
+elinks: Homepage: http://elinks.cz
elinks:
elinks:
elinks: