summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-03 10:30:29 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-04 21:45:16 +0700
commit487894c144b4d2d4db2122f2cf005236bd0871d9 (patch)
tree76833f1211e3f0e7c6da74c811de2b8e8052c85a
parent0c57da494c5a55062962c8498c051d7473c1e2b7 (diff)
downloadslackbuilds-487894c144b4d2d4db2122f2cf005236bd0871d9.tar.gz
slackbuilds-487894c144b4d2d4db2122f2cf005236bd0871d9.tar.xz
python/pyPdf: Removed (use python3-pypdf).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pyPdf/README16
-rw-r--r--python/pyPdf/pyPdf.SlackBuild99
-rw-r--r--python/pyPdf/pyPdf.info10
-rw-r--r--python/pyPdf/slack-desc19
4 files changed, 0 insertions, 144 deletions
diff --git a/python/pyPdf/README b/python/pyPdf/README
deleted file mode 100644
index de81982790..0000000000
--- a/python/pyPdf/README
+++ /dev/null
@@ -1,16 +0,0 @@
-A Pure-Python library built as a PDF toolkit. It is capable of:
-
- extracting document information (title, author, ...),
- splitting documents page by page,
- merging documents page by page,
- cropping pages,
- merging multiple pages into a single page,
- encrypting and decrypting PDF files.
-
-It should run on any Python platform without any dependencies on
-external libraries. It can also work entirely on StringIO objects
-rather than file streams, allowing for PDF manipulation in memory. It
-is therefore a useful tool for websites that manage or manipulate PDFs.
-
-NOTE: the upstream project is NOT MAINTAINED. PyPDF2 is a fork based on
-this project that provides enhanced features.
diff --git a/python/pyPdf/pyPdf.SlackBuild b/python/pyPdf/pyPdf.SlackBuild
deleted file mode 100644
index c8e815cc5c..0000000000
--- a/python/pyPdf/pyPdf.SlackBuild
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pyPdf
-
-# Copyright (c) 2017 Alan Alberghini <414N@slacky.it>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# -----------------------------------------------------------------------------
-#
-# Build history:
-#
-# 1 - Initial release.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pyPdf
-VERSION=${VERSION:-1.13}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-DOCS="README CHANGELOG"
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pyPdf/pyPdf.info b/python/pyPdf/pyPdf.info
deleted file mode 100644
index 817b2a041d..0000000000
--- a/python/pyPdf/pyPdf.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyPdf"
-VERSION="1.13"
-HOMEPAGE="http://pybrary.net/pyPdf/"
-DOWNLOAD="http://pybrary.net/pyPdf/pyPdf-1.13.tar.gz"
-MD5SUM="7a75ef56f227b78ae62d6e38d4b6b1da"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Alan Alberghini"
-EMAIL="414N@slacky.it"
diff --git a/python/pyPdf/slack-desc b/python/pyPdf/slack-desc
deleted file mode 100644
index 7bd23be9aa..0000000000
--- a/python/pyPdf/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pyPdf: pyPdf (pure Python library built as a PDF toolkit)
-pyPdf:
-pyPdf: It is capable of:
-pyPdf: - extracting document information (title, author, ...),
-pyPdf: - splitting documents page by page,
-pyPdf: - merging documents page by page,
-pyPdf: - cropping pages,
-pyPdf: - merging multiple pages into a single page,
-pyPdf: - encrypting and decrypting PDF files.
-pyPdf:
-pyPdf: Homepage: http://pybrary.net/pyPdf/