summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-02-08 02:52:12 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-02-11 09:30:41 +0700
commit3b90538ed0d5bc7ef342494cb3bba46582c1ec08 (patch)
tree299a189de96c5d733a10d26c1e5e654f98a7a678
parenta4fbad76f96d53c2cd49d45529a7923c64f7445d (diff)
downloadslackbuilds-3b90538ed0d5bc7ef342494cb3bba46582c1ec08.tar.gz
slackbuilds-3b90538ed0d5bc7ef342494cb3bba46582c1ec08.tar.xz
network/transmission: Updated for version 4.0.0.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/transmission/README15
-rw-r--r--network/transmission/slack-desc2
-rw-r--r--network/transmission/transmission.SlackBuild97
-rw-r--r--network/transmission/transmission.info8
4 files changed, 50 insertions, 72 deletions
diff --git a/network/transmission/README b/network/transmission/README
index cbfcb736cc..fb7be33365 100644
--- a/network/transmission/README
+++ b/network/transmission/README
@@ -4,12 +4,21 @@ Transmission is a lightweight open source BitTorrent client, providing
useful functionality without feature bloat. It consists of a daemon
and GTK+, Qt, and CLI clients.
-By default, all 4 components are built. Specific parts can be disabled
-by setting one or more environment variables:
+By default, everything but the Qt client is built. It can be enabled
+by exporting QT=yes in the environment. The other parts can be
+disabled by exporting one or more environment variables:
GTK=no
-QT=no
CLI=no
DAEMON=no
+Hint: if you use QT=yes, you probably also want GTK=no.
+
At least one component must be enabled (all 4 set to "no" won't work).
+
+Note: transmission-gtk *must* be run from within a D-Bus session. If
+you use the standard /etc/X11/xinit/xinitrc.* to start X, or if you
+log in with a graphical login manager, you're already using D-Bus.
+Unfortunately, if it can't connect to D-Bus, transmission-gtk will
+freeze (not even closing the window will work). If you dislike D-Bus
+and prefer to avoid it, use transmission-qt instead.
diff --git a/network/transmission/slack-desc b/network/transmission/slack-desc
index 5ab683a1b9..30f5ac84ba 100644
--- a/network/transmission/slack-desc
+++ b/network/transmission/slack-desc
@@ -15,5 +15,5 @@ transmission:
transmission: This package built with options:
transmission: @opts@
transmission:
-transmission: Homepage: http://transmissionbt.com/
+transmission: Homepage: https://transmissionbt.com/
transmission:
diff --git a/network/transmission/transmission.SlackBuild b/network/transmission/transmission.SlackBuild
index 60ff05296a..a29579d736 100644
--- a/network/transmission/transmission.SlackBuild
+++ b/network/transmission/transmission.SlackBuild
@@ -24,6 +24,9 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230208 bkw: update for v4.0.0, which has only been out for about 5 hours.
+# - Disable the qt5 UI by default. There's no reason to build both GUIs
+# by default. User can still say GTK=no QT=yes to get only the qt UI.
# 20210926 bkw: BUILD=2, restore Qt5 build. 15.0 not yet released, but "soon".
# 20200525 bkw: update for v3.00.
# Drop Qt GUI and QT=yes, due to 14.2's old gcc/libstdc++.
@@ -42,8 +45,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=transmission
-VERSION=${VERSION:-3.00}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-4.0.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -64,8 +67,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="AUTHORS COPYING NEWS.md README.md"
-
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
@@ -83,7 +84,7 @@ fi
set -e
GTK="${GTK:-yes}"
-QT="${QT:-yes}"
+QT="${QT:-no}"
CLI="${CLI:-yes}"
DAEMON="${DAEMON:-yes}"
@@ -99,10 +100,13 @@ EOF
exit 1
fi
-# anything but lowercase "yes" is considered a no!
-[ "$GTK" != "yes" ] && GTKOPT="no" || GTKOPT="yes"
-[ "$CLI" != "yes" ] && CLIOPT="dis" || CLIOPT="en"
-[ "$DAEMON" != "yes" ] && DAEMOPT="dis" || DAEMOPT="en"
+# Anything but lowercase "yes" is considered a no!
+# cmake didn't used to be case-sensitive about on and off.
+# It feels like BDSM, and not in a good way.
+[ "$QT" != "yes" ] && QTOPT="OFF" || QTOPT="ON"
+[ "$GTK" != "yes" ] && GTKOPT="OFF" || GTKOPT="ON"
+[ "$CLI" != "yes" ] && CLIOPT="OFF" || CLIOPT="ON"
+[ "$DAEMON" != "yes" ] && DAEMOPT="OFF" || DAEMOPT="ON"
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -115,67 +119,32 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-sed -i -e 's%-g -O3 -funroll-loops %%g' configure.ac
-sed -i -e 's%-ggdb3 %%g' configure.ac
-
-# fix for -current (does no harm on stable). ref:
-# https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c13b5e88c6e9c7bd2698d844cb5ed127ed809f7e
-rm -f m4/glib-gettext.m4
-
-CC=gcc CXX=g++ \
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --disable-static \
- --verbose \
- --with-gtk=$GTKOPT \
- --${CLIOPT}able-cli \
- --${DAEMOPT}able-daemon \
- --build=$ARCH-slackware-linux \
- --host=$ARCH-slackware-linux
-
-# Build daemon, GTK and cli client (unless disabled). This also builds
-# the tools (transmission-create and friends).
-make
-make install-strip DESTDIR=$PKG
-
-if [ "$QT" = "yes" ]; then
- # build the Qt client (transmission-qt) unless disabled
- # Fix hard-coded path of man file of Qt client
- sed -i "s|share/man/|man/|" qt/qtr.pro
-
- # Needed when using Qt4
- # https://trac.transmissionbt.com/ticket/5700#comment:2
- echo "QMAKE_CXXFLAGS += -std=c++11" >> qt/qtr.pro
-
- cd $TMP/$PRGNAM-$VERSION/qt
- qmake-qt5 \
- QMAKE_CXXFLAGS+="$SLKCFLAGS" \
- QMAKE_CFLAGS+="$SLKCFLAGS" \
- qtr.pro
- sed -i -e 's% -g % %g' Makefile
- make
- INSTALL_ROOT=$PKG/usr make install
-
- mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps
- install -m644 transmission-qt.desktop $PKG/usr/share/applications/transmission-qt.desktop
- install -m644 icons/transmission.png $PKG/usr/share/pixmaps/transmission-qt.png
- cd -
-fi
+mkdir -p build
+cd build
+ cmake \
+ -DENABLE_DAEMON=$DAEMOPT \
+ -DENABLE_QT=$QTOPT \
+ -DENABLE_GTK=$GTKOPT \
+ -DENABLE_CLI=$CLIOPT \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_INSTALL_MANDIR=/usr/man \
+ -DCMAKE_INSTALL_DOCDIR=/usr/doc/$PRGNAM-$VERSION \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make VERBOSE=1
+ make install/strip DESTDIR=$PKG
+cd ..
gzip -9 $PKG/usr/man/man?/*
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
-sed "s,@opts@,GTK=$GTK QT=$QT CLI=$CLI QT=$QT DAEMON=$DAEMON," $CWD/slack-desc > $PKG/install/slack-desc
+sed "s,@opts@,GTK=$GTK QT=$QT CLI=$CLI DAEMON=$DAEMON," \
+ $CWD/slack-desc \
+ > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
diff --git a/network/transmission/transmission.info b/network/transmission/transmission.info
index 5274134ef8..a7796a934a 100644
--- a/network/transmission/transmission.info
+++ b/network/transmission/transmission.info
@@ -1,8 +1,8 @@
PRGNAM="transmission"
-VERSION="3.00"
-HOMEPAGE="http://www.transmissionbt.com/"
-DOWNLOAD="https://github.com/transmission/transmission-releases/raw/master/transmission-3.00.tar.xz"
-MD5SUM="a23a32672b83c89b9b61e90408f53d98"
+VERSION="4.0.0"
+HOMEPAGE="https://www.transmissionbt.com/"
+DOWNLOAD="https://github.com/transmission/transmission/releases/download/4.0.0/transmission-4.0.0.tar.xz"
+MD5SUM="d73915000cf2871404b45a64969cea83"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""