summaryrefslogtreecommitdiffstats
path: root/source/d/python-setuptools/python-setuptools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/python-setuptools/python-setuptools.SlackBuild')
-rwxr-xr-xsource/d/python-setuptools/python-setuptools.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/source/d/python-setuptools/python-setuptools.SlackBuild b/source/d/python-setuptools/python-setuptools.SlackBuild
index 762c83f5e..2e926666e 100755
--- a/source/d/python-setuptools/python-setuptools.SlackBuild
+++ b/source/d/python-setuptools/python-setuptools.SlackBuild
@@ -102,9 +102,13 @@ if python3 --version | grep -q "Python 3.9." ; then
fi
fi
-unshare -n python3 -m build --wheel --no-isolation || exit 1
+# Sticking with setup.py while it exists to make it easier to bootstrap a
+# new Python version:
+python3 setup.py build install --root=$PKG || exit 1
-python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
+# Don't use this. ;-)
+#unshare -n python3 -m build --wheel --no-isolation || exit 1
+#python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a CHANGES.rst PKG-INFO README.rst docs/*.txt \