summaryrefslogtreecommitdiffstats
path: root/source/d/python-pip/python-pip.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/python-pip/python-pip.SlackBuild')
-rwxr-xr-xsource/d/python-pip/python-pip.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/source/d/python-pip/python-pip.SlackBuild b/source/d/python-pip/python-pip.SlackBuild
index d41293569..596f13f21 100755
--- a/source/d/python-pip/python-pip.SlackBuild
+++ b/source/d/python-pip/python-pip.SlackBuild
@@ -61,9 +61,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-unshare -n python3 -m build --wheel --no-isolation || exit 1
+# Sticking with setup.py while it exists to make it easier to bootstrap a
+# new Python version:
+python3 setup.py build install --root=$PKG || exit 1
-python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
+# Don't use this. ;-)
+#unshare -n python3 -m build --wheel --no-isolation || exit 1
+#python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a *.txt PKG-INFO README.rst \