summaryrefslogtreecommitdiffstats
path: root/source/a/gpm/gpm.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2024-03-28 21:40:08 +0000
committer Eric Hameleers <alien@slackware.com>2024-03-28 23:48:35 +0100
commit6b5ab0b4ab4195a9d3c2107de2167c0735695899 (patch)
treecd54f718144e48b66654823579d8864f94052bb9 /source/a/gpm/gpm.SlackBuild
parent0566738f32381ee1eb6c24ecd47f690423c49009 (diff)
downloadcurrent-6b5ab0b4ab4195a9d3c2107de2167c0735695899.tar.gz
current-6b5ab0b4ab4195a9d3c2107de2167c0735695899.tar.xz
Thu Mar 28 21:40:08 UTC 202420240328214008
a/btrfs-progs-6.8-x86_64-1.txz: Upgraded. a/gpm-1.20.7-x86_64-10.txz: Rebuilt. Clean up the compile fix patch omitting the Emacs Lisp file. Clean up and apply the weak-wgetch patch. Build using the option --without-curses. Thanks to qunying. a/util-linux-2.40-x86_64-1.txz: Upgraded. This release fixes a vulnerability where the wall command did not filter escape sequences from command line arguments, allowing unprivileged users to put arbitrary text on other users terminals. For more information, see: https://www.cve.org/CVERecord?id=CVE-2024-28085 (* Security fix *) d/rust-1.77.1-x86_64-1.txz: Upgraded. l/fluidsynth-2.3.5-x86_64-1.txz: Upgraded. l/protobuf-26.1-x86_64-1.txz: Upgraded. l/python-build-1.2.1-x86_64-1.txz: Upgraded. n/samba-4.20.0-x86_64-1.txz: Upgraded. x/mesa-24.0.4-x86_64-1.txz: Upgraded. xap/seamonkey-2.53.18.2-x86_64-1.txz: Upgraded. This update contains security fixes and improvements. For more information, see: https://www.seamonkey-project.org/releases/seamonkey2.53.18.2 (* Security fix *)
Diffstat (limited to 'source/a/gpm/gpm.SlackBuild')
-rwxr-xr-xsource/a/gpm/gpm.SlackBuild30
1 files changed, 7 insertions, 23 deletions
diff --git a/source/a/gpm/gpm.SlackBuild b/source/a/gpm/gpm.SlackBuild
index 767d7f352..d2f27c7f5 100755
--- a/source/a/gpm/gpm.SlackBuild
+++ b/source/a/gpm/gpm.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=gpm
VERSION=1.20.7
-BUILD=${BUILD:-9}
+BUILD=${BUILD:-10}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -80,36 +80,20 @@ zcat $CWD/gpm-1.20.5-close-fds.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/gpm-1.20.1-select-1.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/gpm.types.diff.gz | patch -p1 --verbose || exit 1
zcat $CWD/gpm.gcc7.diff.gz | patch -p1 --verbose || exit 1
-
-sh autogen.sh
-
-# This is *supposed* to prevent linking libgpm.so with -lncurses,
-# but for some reason it doesn't have the desired effect here.
-# Any ideas? The patch is supposed to resolve a circular dependency
-# between libgpm.so and libncurses.so. I don't notice any ill effects
-# here, but perhaps the problem would occur if prelinking was used.
-# Also, ncurses has not shown an ldd link to libgpm for several releases,
-# so perhaps any problem that existed was fixed on their end.
-# NOTE: Since this isn't preventing gpm from linking to ncurses, I'm
-# commenting this patch out until we understand better if it's even
-# useful for anything. Half a patch seems worse than no patch.
-#zcat $CWD/gpm-1.20.1-weak-wgetch.patch.gz | patch -p1 --verbose || exit 1
-
-# Since we aren't installing any Emacs Lisp files anyway, just brutally
-# hack around this failing part of ./configure. This may be a brittle
-# solution, so if it doesn't apply just go ahead and try without this
-# patch and see if it's working or not.
zcat $CWD/gpm.configure.diff.gz | patch -p1 --verbose || exit 1
-# Since we just patched configure.ac, run this again to carry the change
-# into configure:
-autoconf
+# This patch is supposed to resolve a circular dependency between libgpm.so
+# and libncurses.so:
+zcat $CWD/gpm-1.20.1-weak-wgetch.patch.gz | patch -p1 --verbose || exit 1
+
+sh autogen.sh
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--libdir=/usr/lib${LIBDIRSUFFIX} \
+ --without-curses \
--build=$ARCH-slackware-linux || exit 1
make || exit 1