summaryrefslogtreecommitdiffstats
path: root/python/Pygments/Pygments.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/Pygments/Pygments.SlackBuild')
-rw-r--r--python/Pygments/Pygments.SlackBuild24
1 files changed, 15 insertions, 9 deletions
diff --git a/python/Pygments/Pygments.SlackBuild b/python/Pygments/Pygments.SlackBuild
index 2f558875dd..45a4d1b4d7 100644
--- a/python/Pygments/Pygments.SlackBuild
+++ b/python/Pygments/Pygments.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for Pygments
# Copyright 2009 Grissiom <chaos.proton@gmail.com>
-# Copyright 2009-2013 LukenShiro, Italy
+# Copyright 2009-2015 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,8 +24,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=Pygments
-VERSION=${VERSION:-1.6}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.0.2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -41,7 +41,9 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCFILES="LICENSE TODO AUTHORS CHANGES docs/build/*.html"
+DOCFILES="LICENSE TODO AUTHORS CHANGES README.rst"
+# html documentation is not built by default
+HTML=${HTML:-0}
set -e
@@ -53,15 +55,15 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --prefix=/usr --root=$PKG
mkdir -p $PKG/usr/man/man1
-cp -a docs/pygmentize.1 $PKG/usr/man/man1
+cp -a doc/pygmentize.1 $PKG/usr/man/man1
# Adapting to Slackware's directory layout
sed -i "s|share/doc/python-pygments|doc/${PRGNAM}-${VERSION}|" \
$PKG/usr/man/man1/pygmentize.1
@@ -69,6 +71,11 @@ sed -i "s|share/doc/python-pygments|doc/${PRGNAM}-${VERSION}|" \
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+# building html documentation
+case "$HTML" in
+ 0) ;;
+ *) cd doc ; make html && cp -R _build/html $PKG/usr/doc/$PRGNAM-$VERSION ; cd - ;;
+esac
cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -77,4 +84,3 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-