summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
Diffstat (limited to 'gis')
-rw-r--r--gis/python3-cartopy/python3-cartopy.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/gis/python3-cartopy/python3-cartopy.SlackBuild b/gis/python3-cartopy/python3-cartopy.SlackBuild
index 54e9139051..42993d5796 100644
--- a/gis/python3-cartopy/python3-cartopy.SlackBuild
+++ b/gis/python3-cartopy/python3-cartopy.SlackBuild
@@ -86,7 +86,8 @@ find -L . \
# build line but this is not deemed optimal.
sed -i 's/oldest-supported-numpy/numpy>=1.19.3/' pyproject.toml
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl