summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/pyicu/README5
-rw-r--r--python/pyicu/pyicu.SlackBuild8
2 files changed, 2 insertions, 11 deletions
diff --git a/python/pyicu/README b/python/pyicu/README
index 7473d2b4a8..86100eea25 100644
--- a/python/pyicu/README
+++ b/python/pyicu/README
@@ -1,7 +1,2 @@
PyICU is a Python extension wrapping IBM's International
Components for Unicode C++ library (ICU).
-
-python3 is an optional dependency. You need to set PYTHON3=yes,
-for example:
-
- PYTHON3=yes ./pyicu.SlackBuild
diff --git a/python/pyicu/pyicu.SlackBuild b/python/pyicu/pyicu.SlackBuild
index bf2bb1d31a..e1d22e84ef 100644
--- a/python/pyicu/pyicu.SlackBuild
+++ b/python/pyicu/pyicu.SlackBuild
@@ -57,12 +57,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-if [ "${PYTHON3:-no}" = "yes" ]; then
- rm -rf build
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true