summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/python3-pyproject-api/python3-pyproject-api.SlackBuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/python/python3-pyproject-api/python3-pyproject-api.SlackBuild b/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
index b644ab0940..715c2314fc 100644
--- a/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
+++ b/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
@@ -62,12 +62,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
# Revert unnecessary dependency version requirements
-sed -i 's|1\.24\.2|1\.18|' pyproject.toml # hatchling
sed -i 's|2\.0\.1|1\.2\.2|' pyproject.toml # tomli
-sed -i 's|24\.1|21\.0|' pyproject.toml # packaging
python3 -m build --wheel --no-isolation
python3 -m installer --destdir=$PKG dist/*.whl