summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2023-01-31 12:42:13 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-02-04 06:50:29 +0700
commit4b099eaab8b8873bfdb2a8265638ce15f8f0111b (patch)
treece20f9bfdc2b1d63f9f94b103d63f906a819e1a9 /python
parentba737f38bb49cbbd9fc51ef9ab3b2b2ff48a5eba (diff)
downloadslackbuilds-4b099eaab8b8873bfdb2a8265638ce15f8f0111b.tar.gz
slackbuilds-4b099eaab8b8873bfdb2a8265638ce15f8f0111b.tar.xz
python/python3-openpyxl: Update for 3.1.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-openpyxl/python3-openpyxl.SlackBuild10
-rw-r--r--python/python3-openpyxl/python3-openpyxl.info6
2 files changed, 6 insertions, 10 deletions
diff --git a/python/python3-openpyxl/python3-openpyxl.SlackBuild b/python/python3-openpyxl/python3-openpyxl.SlackBuild
index 2981e56fac..1fa694be7e 100644
--- a/python/python3-openpyxl/python3-openpyxl.SlackBuild
+++ b/python/python3-openpyxl/python3-openpyxl.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-openpyxl
-# Copyright 2020-2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020-2023 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-openpyxl
-VERSION=${VERSION:-3.0.10}
+VERSION=${VERSION:-3.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -77,8 +74,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py build
-python3 setup.py install --skip-build --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-openpyxl/python3-openpyxl.info b/python/python3-openpyxl/python3-openpyxl.info
index d6219f5189..52a45bf22f 100644
--- a/python/python3-openpyxl/python3-openpyxl.info
+++ b/python/python3-openpyxl/python3-openpyxl.info
@@ -1,8 +1,8 @@
PRGNAM="python3-openpyxl"
-VERSION="3.0.10"
+VERSION="3.1.0"
HOMEPAGE="https://openpyxl.readthedocs.org/"
-DOWNLOAD="https://foss.heptapod.net/openpyxl/openpyxl/-/archive/3.0.10/openpyxl-3.0.10.tar.bz2"
-MD5SUM="f825fc5e687d082970ca526449a90084"
+DOWNLOAD="https://foss.heptapod.net/openpyxl/openpyxl/-/archive/3.1.0/openpyxl-3.1.0.tar.bz2"
+MD5SUM="0669f8bdf706d269848027b8a211c627"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="et_xmlfile"