summaryrefslogtreecommitdiffstats
path: root/games/fceux
diff options
context:
space:
mode:
author M.Dinslage <daedra1980@gmail.com>2022-03-31 20:33:50 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-02 18:19:19 +0700
commit48bc58222411bde2b64c7420cfde85db2c9bbef6 (patch)
tree7cace269c4adca208ac75b15680569d4ad995733 /games/fceux
parentb67b1b683f30b140bdee8240e69fe42aec06cadc (diff)
downloadslackbuilds-48bc58222411bde2b64c7420cfde85db2c9bbef6.tar.gz
slackbuilds-48bc58222411bde2b64c7420cfde85db2c9bbef6.tar.xz
games/fceux: Updated for version 2.6.3.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/fceux')
-rw-r--r--games/fceux/README6
-rw-r--r--games/fceux/fceux.SlackBuild15
-rw-r--r--games/fceux/fceux.info6
3 files changed, 18 insertions, 9 deletions
diff --git a/games/fceux/README b/games/fceux/README
index 0250aa6a2f..73ded9e648 100644
--- a/games/fceux/README
+++ b/games/fceux/README
@@ -2,3 +2,9 @@ fceux is a Nintendo Entertainment System (NES), Famicom, and
Famicom Disk System (FDS) emulator. It supports both PAL
(European) and NTSC (USA/JPN) modes. It supports both Windows
and SDL versions for cross compatibility.
+
+Optional dependencies are x264 and x265
+
+Lua 5.1.x is required for fceux, however it will use an internal
+version if not found during build. So it is optional but not
+nescessary to install Lua 5.1 for fceux to work.
diff --git a/games/fceux/fceux.SlackBuild b/games/fceux/fceux.SlackBuild
index d8ab3875be..9c1b7cfc70 100644
--- a/games/fceux/fceux.SlackBuild
+++ b/games/fceux/fceux.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=fceux
-VERSION=${VERSION:-2.4.0}
+VERSION=${VERSION:-2.6.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -70,7 +70,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -79,12 +79,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix man pages
-sed -i 's,share/man/man6,man/man6,g' src/CMakeLists.txt
-
# Fix incorrect version name
sed -i 's/-interim git//g' src/version.h
+# Fix Lua 5.1.x detection
+sed -i 's/LUA lua5.1 lua-5.1/LUA lua5.1 lua-5.1 lua/g' src/CMakeLists.txt
+
mkdir -p build
cd build
cmake \
@@ -92,12 +92,15 @@ cd build
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
- -DMAN_INSTALL_DIR=/usr/man \
+ -DCMAKE_INSTALL_MANDIR=/usr/man \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
cd ..
+# remove unused files
+rm -rf $PKG/usr/share/$PRGNAM/*.dll
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/games/fceux/fceux.info b/games/fceux/fceux.info
index 305157ce7c..6426222b74 100644
--- a/games/fceux/fceux.info
+++ b/games/fceux/fceux.info
@@ -1,8 +1,8 @@
PRGNAM="fceux"
-VERSION="2.4.0"
+VERSION="2.6.3"
HOMEPAGE="http://fceux.com/web/home.html"
-DOWNLOAD="http://downloads.sourceforge.net/fceultra/fceux-2.4.0.tar.gz"
-MD5SUM="373ddc61b8e9557f1e8ba27a8ff10697"
+DOWNLOAD="http://downloads.sourceforge.net/fceultra/fceux-2.6.3.tar.gz"
+MD5SUM="d45dbfca4a2c398889111b93e8f7f16f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libminizip"