summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Samuel Young <samyoung12788@gmail.com>2023-03-16 23:38:00 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-03-18 09:50:24 +0700
commit52393d24155782dd2bff1d0e6fa8410d8a80ec8f (patch)
treed07ebaa31b6809c5daf73c973e5a4f2ba18c24fc
parente3d1b6d7ae93e0cbb9e7f8d50c816a9152bc53bf (diff)
downloadslackbuilds-52393d24155782dd2bff1d0e6fa8410d8a80ec8f.tar.gz
slackbuilds-52393d24155782dd2bff1d0e6fa8410d8a80ec8f.tar.xz
desktop/mugshot: Added (User Management Utility for Linux)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--desktop/mugshot/README13
-rw-r--r--desktop/mugshot/doinst.sh17
-rw-r--r--desktop/mugshot/mugshot.SlackBuild98
-rw-r--r--desktop/mugshot/mugshot.info10
-rw-r--r--desktop/mugshot/slack-desc19
5 files changed, 157 insertions, 0 deletions
diff --git a/desktop/mugshot/README b/desktop/mugshot/README
new file mode 100644
index 0000000000..cf065d9531
--- /dev/null
+++ b/desktop/mugshot/README
@@ -0,0 +1,13 @@
+mugshot (User Management Utility for Linux)
+
+Mugshot is a lightweight user configuration utility for Linux
+designed for simplicity and ease of use. Quickly update your personal
+profile and sync your updates across applications.
+
+Features:
+*Update your user profile image (~/.face and AccountService)
+*Update user details stored in /etc/passwd (used by finger and other
+desktop applications)
+*(Optionally) sync your profile image to your Pidgin buddy icon
+*(Optionally) sync your user details to LibreOffice
+
diff --git a/desktop/mugshot/doinst.sh b/desktop/mugshot/doinst.sh
new file mode 100644
index 0000000000..7d4bb0a5da
--- /dev/null
+++ b/desktop/mugshot/doinst.sh
@@ -0,0 +1,17 @@
+doinst ()
+{
+ if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications > /dev/null 2>&1;
+ fi;
+ if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor > /dev/null 2>&1;
+ fi;
+ fi;
+ if [ -e usr/share/glib-2.0/schemas ]; then
+ if [ -x /usr/bin/glib-compile-schemas ]; then
+ /usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas > /dev/null 2>&1;
+ fi;
+ fi
+}
+doinst
diff --git a/desktop/mugshot/mugshot.SlackBuild b/desktop/mugshot/mugshot.SlackBuild
new file mode 100644
index 0000000000..4dcbb1880a
--- /dev/null
+++ b/desktop/mugshot/mugshot.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/bash
+
+# Slackware build script for mugshot
+
+# Copyright 2023 Samuel Young, MO, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=mugshot
+VERSION=${VERSION:-0.4.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mv $PKG/usr/share/doc/mugshot/* $PKG/usr/doc/$PRGNAM-$VERSION/
+rm -R $PKG/usr/share/doc
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/mugshot/mugshot.info b/desktop/mugshot/mugshot.info
new file mode 100644
index 0000000000..83185e8e5a
--- /dev/null
+++ b/desktop/mugshot/mugshot.info
@@ -0,0 +1,10 @@
+PRGNAM="mugshot"
+VERSION="0.4.3"
+HOMEPAGE="https://github.com/bluesabre/mugshot"
+DOWNLOAD="https://github.com/bluesabre/mugshot/releases/download/mugshot-0.4.3/mugshot-0.4.3.tar.gz"
+MD5SUM="1c504dcec181159ff5aa896bed9605ab"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-pexpect python-distutils-extra"
+MAINTAINER="Samuel Young"
+EMAIL="samyoung12788@gmail.com"
diff --git a/desktop/mugshot/slack-desc b/desktop/mugshot/slack-desc
new file mode 100644
index 0000000000..ba7e6242a3
--- /dev/null
+++ b/desktop/mugshot/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+mugshot: mugshot (User Management Utility for Linux)
+mugshot:
+mugshot: Mugshot is a lightweight user configuration utility for Linux
+mugshot: designed for simplicity and ease of use. Quickly update your personal
+mugshot: profile and sync your updates across applications.
+mugshot:
+mugshot: https://github.com/bluesabre/mugshot:
+mugshot:
+mugshot:
+mugshot:
+mugshot: