summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons <andrew.clemons@gmail.com>2023-12-28 21:37:15 +0900
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-30 07:33:31 +0700
commitf8e825b36bc5e99c44318fd6b4f2117019f198be (patch)
tree0e57c92c0794d3d7c2930264c892b3ed835ba99e
parenteb8aaa2a862d23c191e679e1b383a864ba646e8a (diff)
downloadslackbuilds-f8e825b36bc5e99c44318fd6b4f2117019f198be.tar.gz
slackbuilds-f8e825b36bc5e99c44318fd6b4f2117019f198be.tar.xz
python/python-nbxmpp: Updated for version 3.2.5, new maint.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
-rw-r--r--python/python-nbxmpp/README4
-rw-r--r--python/python-nbxmpp/python-nbxmpp.SlackBuild31
-rw-r--r--python/python-nbxmpp/python-nbxmpp.info12
3 files changed, 14 insertions, 33 deletions
diff --git a/python/python-nbxmpp/README b/python/python-nbxmpp/README
index ca1cc30153..0b019dc8c8 100644
--- a/python/python-nbxmpp/README
+++ b/python/python-nbxmpp/README
@@ -3,7 +3,3 @@ applications to use Jabber/XMPP networks in a non-blocking way.
This library is initialy a fork of xmpppy one, but using
non-blocking sockets.
-
-If you download with wget you should use the --content-disposition
-option for that, or you'll end up with a file named 8 (although the
-slackbuild checks for this file, too).
diff --git a/python/python-nbxmpp/python-nbxmpp.SlackBuild b/python/python-nbxmpp/python-nbxmpp.SlackBuild
index 917524014b..5563f6b22d 100644
--- a/python/python-nbxmpp/python-nbxmpp.SlackBuild
+++ b/python/python-nbxmpp/python-nbxmpp.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for python-nbxmpp
# Copyright 2014-2022 Ruben Schuller
+# Copyright 2022-2023 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,10 +26,9 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-nbxmpp
-VERSION=${VERSION:-2.0.6}
+VERSION=${VERSION:-3.2.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-TARNAM=${PRGNAM}-nbxmpp
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,28 +48,14 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $TARNAM-$VERSION
-tar xvf $CWD/$TARNAM-$VERSION.tar.gz
-cd $TARNAM-$VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -80,7 +63,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-nbxmpp/python-nbxmpp.info b/python/python-nbxmpp/python-nbxmpp.info
index fa4360ade1..856827037d 100644
--- a/python/python-nbxmpp/python-nbxmpp.info
+++ b/python/python-nbxmpp/python-nbxmpp.info
@@ -1,10 +1,10 @@
PRGNAM="python-nbxmpp"
-VERSION="2.0.6"
+VERSION="3.2.5"
HOMEPAGE="https://dev.gajim.org/gajim/python-nbxmpp/"
-DOWNLOAD="https://dev.gajim.org/gajim/python-nbxmpp/-/archive/nbxmpp-2.0.6/python-nbxmpp-nbxmpp-2.0.6.tar.gz"
-MD5SUM="afada41084f1ed6253e404e60e5c5dc4"
+DOWNLOAD="https://dev.gajim.org/gajim/python-nbxmpp/-/archive/3.2.5/python-nbxmpp-3.2.5.tar.gz"
+MD5SUM="c22c9f935b9e093bdb3602145cc49c48"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-precis-i18n"
-MAINTAINER="Ruben Schuller"
-EMAIL="sb@rbn.im"
+REQUIRES="python3-build python3-wheel python-precis-i18n"
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"