summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons <andrew.clemons@gmail.com>2023-12-28 21:37:23 +0900
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-30 07:33:32 +0700
commitf0790012af430c61b3311a333ea4f4bf1d9f078b (patch)
tree6bfc80b52875870d73f0593a81cc5fd9e94cf99b
parentf8e825b36bc5e99c44318fd6b4f2117019f198be (diff)
downloadslackbuilds-f0790012af430c61b3311a333ea4f4bf1d9f078b.tar.gz
slackbuilds-f0790012af430c61b3311a333ea4f4bf1d9f078b.tar.xz
network/gajim: Updated for version 1.5.4, new maint.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
-rw-r--r--network/gajim/README12
-rw-r--r--network/gajim/gajim.SlackBuild31
-rw-r--r--network/gajim/gajim.info12
3 files changed, 24 insertions, 31 deletions
diff --git a/network/gajim/README b/network/gajim/README
index 43a93a0285..6e6856a15e 100644
--- a/network/gajim/README
+++ b/network/gajim/README
@@ -2,9 +2,11 @@ gajim is a GTK3-based Jabber client featuring tabbed interface,
tray icon and notifications, encryption support, local link
(Zeroconf/Bonjour) and other interesting things.
-As of the 0.16 version, gajim uses its own non-blocking xmpp
-implementation called nbxmpp (python-nbxmpp on slackbuilds.org). This
-is required to build.
+Optional dependencies:
+ gspell
+ gst-plugins-ugly
+ gst-plugins-bad-nonfree
-For encryption PyOpenSSL is used, which is not required for building,
-but produces a warning message on connection if not installed.
+Note that 1.5.4 is the last version to support Python 3.9, so there
+will be no more updates of this slackbuild until the next Slackware
+release.
diff --git a/network/gajim/gajim.SlackBuild b/network/gajim/gajim.SlackBuild
index 0b2479e6ae..1e38de8bd4 100644
--- a/network/gajim/gajim.SlackBuild
+++ b/network/gajim/gajim.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for Gajim
#
# Copyright 2014-2018 Ruben Schuller
+# Copyright 2022-2023 Andrew Clemons, Tokyo Japan
#
# All rights reserved.
#
@@ -26,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gajim
-VERSION=${VERSION:-1.3.3}
+VERSION=${VERSION:-1.5.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -72,7 +56,7 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -80,7 +64,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# our pango is too old, but it seems a somewhat arbitrary version was chosen.
+# This version of Gajim seems to work fine with our pango in 15.0.
+sed -i "/_MIN_PANGO_VER/s/'1.50.0'/'1.48.0'/g" gajim/gajim.py
+
+python3 -m build --wheel --no-isolation
+
+python3 -m installer --destdir "$PKG" dist/*.whl
+
mv $PKG/usr/share/man $PKG/usr/man
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/network/gajim/gajim.info b/network/gajim/gajim.info
index e03140b052..49c97e2fcd 100644
--- a/network/gajim/gajim.info
+++ b/network/gajim/gajim.info
@@ -1,10 +1,10 @@
PRGNAM="gajim"
-VERSION="1.3.3"
+VERSION="1.5.4"
HOMEPAGE="https://gajim.org/"
-DOWNLOAD="https://gajim.org/downloads/1.3/gajim-1.3.3.tar.gz"
-MD5SUM="2fa77eadb4323aed392664664c706fb2"
+DOWNLOAD="https://gajim.org/downloads/1.5/gajim-1.5.4.tar.gz"
+MD5SUM="64affe8a670a34fca67808ca1cb5b664"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pyOpenSSL python-nbxmpp python3-pycrypto python3-keyring css-parser"
-MAINTAINER="Ruben Schuller"
-EMAIL="sb@rbn.im"
+REQUIRES="python3-build python3-wheel python-nbxmpp cryptography css-parser python3-keyring gtksourceview4 gsound python-qrcode python-axolotl python-gnupg gst-python"
+MAINTAINER="Andrew Clemons"
+EMAIL="andrew.clemons@gmail.com"