summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Tim Dickson <dickson.tim@googlemail.com>2023-06-17 09:25:31 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-06-17 09:45:17 +0700
commitb34f0d7bab6f2c285c5c7d51d16072782d201890 (patch)
treeb05ad4ae8cd0492764e97a458b6e0110e609de42
parent388a776764da128e5b6ffed08886cb8fb825a1c6 (diff)
downloadslackbuilds-b34f0d7bab6f2c285c5c7d51d16072782d201890.tar.gz
slackbuilds-b34f0d7bab6f2c285c5c7d51d16072782d201890.tar.xz
python/thonny: Updated for version 4.1.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/thonny/doinst.sh6
-rw-r--r--python/thonny/thonny.SlackBuild13
-rw-r--r--python/thonny/thonny.info6
3 files changed, 17 insertions, 8 deletions
diff --git a/python/thonny/doinst.sh b/python/thonny/doinst.sh
index 5fb28930db..65c7e2eeb9 100644
--- a/python/thonny/doinst.sh
+++ b/python/thonny/doinst.sh
@@ -1,3 +1,9 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/python/thonny/thonny.SlackBuild b/python/thonny/thonny.SlackBuild
index 91312f2373..d0302163aa 100644
--- a/python/thonny/thonny.SlackBuild
+++ b/python/thonny/thonny.SlackBuild
@@ -27,13 +27,14 @@
#4.0.0 23 Aug 2022. version bump
#4.0.1 14 Sep 2022. version bump
#4.0.2 20 Jan 2023. version bump
-#4.1.0 7 Jul 2023. version bump
+#4.1.0 7 Jun 2023. version bump
+#4.1.1 16 Jun 2023. version bump
#note. get download link from https://pypi.org/project/thonny/#files
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=thonny
-VERSION=${VERSION:-4.1.0}
+VERSION=${VERSION:-4.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -78,9 +79,11 @@ find -L . \
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/share/applications
cp -a packaging/linux/org.thonny.Thonny.desktop $PKG/usr/share/applications/$PRGNAM.desktop
-mkdir -p $PKG/usr/share/pixmaps
-cp -a packaging/icons/$PRGNAM-*.png $PKG/usr/share/pixmaps/
-cp -a packaging/icons/$PRGNAM-128x128.png $PKG/usr/share/pixmaps/$PRGNAM.png
+mkdir -p $PKG/usr/share/icons/hicolor/{16x16,22x22,32x32,48x48,64x64,128x128,192x192,256x256}/apps
+for i in `ls packaging/icons/$PRGNAM-*x*.png`; do
+ IDIR=`echo $i|awk -F"-" '{print $2}'|awk -F"." '{print $1}'`
+ cp -a $i $PKG/usr/share/icons/hicolor/$IDIR/apps/$PRGNAM.png
+done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
for i in CREDITS.rst README.rst CHANGELOG.rst LICENSE.txt; do
cp $i $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/thonny/thonny.info b/python/thonny/thonny.info
index 7db52bf44d..1f69278dc7 100644
--- a/python/thonny/thonny.info
+++ b/python/thonny/thonny.info
@@ -1,8 +1,8 @@
PRGNAM="thonny"
-VERSION="4.1.0"
+VERSION="4.1.1"
HOMEPAGE="http://thonny.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/b4/c1/fff54391ea3dd8844802127fb9f8f66459b718685047e3e8b7ea36345285/thonny-4.1.0.tar.gz"
-MD5SUM="c0e472bacca4b9fa32e3888bfe7a59a4"
+DOWNLOAD="https://files.pythonhosted.org/packages/69/a8/7b71c9f1e153b21e10413f7771ac530b1a81bc25a031093068c57342d05c/thonny-4.1.1.tar.gz"
+MD5SUM="a8c244773910c46fcfcc1b21a8d57395"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-jedi python3-pylint pyserial mypy asttokens send2trash"