summaryrefslogtreecommitdiffstats
path: root/deps (follow)
Commit message (Collapse)AuthorAgeFilesLines
* Deps: updated dbus and qca-qt5 Eric Hameleers2020-07-303-4/+5
|
* Remove packages that moved into Slackware proper Eric Hameleers2020-07-3025-2150/+0
| | | | | | | The espeak-ng, hack-font-ttf, noto-cjk-font-ttf, noto-font-ttf and pcaudiolib packages are now part of Slackware. The flite package has been decommissioned - we will not be using it and will rely on espeak-ng only.
* deps/mlt needed a recompilation against Qt 5.15 to fix broken kdenlive Eric Hameleers2020-07-302-1/+54
|
* Deps: add pipewire as a new dependency for krfb and xdg-desktop-portal-kde Eric Hameleers2020-07-304-0/+179
|
* Deps/elogind: do not modify rc.local Eric Hameleers2020-06-171-10/+11
| | | | | Instead rely on Slackware's rc.M to start either rc.consolekit or else the rc.elogind script. Patch to rc.M is queued-up by Pat.
* Deps/elogind: build the man pages Eric Hameleers2020-06-171-1/+1
|
* Deps/xorg-server: refresh the build script Eric Hameleers2020-06-175-12/+414
| | | | | | | Sync with the Slackware version. Used in an attempt to troubleshoot the VT switch behaviour in runlevel 3 with elogind installed... turned out that /usr/bin/startx needed a different patch, replacing a systemd check with an elogind check.
* Deps/grantlee-qt4 SlackBuild polished for an overdue rebuild Eric Hameleers2020-06-171-8/+18
| | | | | | | Its SlackBuild did not yet follow the current script template, and the Qt4 based 'grantlee' package in Slackware itself was rebuilt in 2018 as part of the 'mass rebuild'; However I forgot to do the same for the 'grantlee-qt4' version in 'ktown'.
* Add exiv2 to the 'alldeps' and 'updates' build scripts Eric Hameleers2020-06-172-0/+2
|
* deps/elogind: add a 'start' argument to the rc script Eric Hameleers2020-06-171-1/+1
|
* deps/util-linux: get rid of compressed patches in the git repo Eric Hameleers2020-06-1717-9/+6737
|
* Deps to rebuild, so let's polish the SlackBuild scripts too Eric Hameleers2020-06-163-32/+48
|
* Deps/libsass: do not ship .la files Eric Hameleers2020-06-091-0/+3
|
* Proposed changes for a migration from ConsoleKit2 to elogind Eric Hameleers2020-06-0844-93/+1807
| | | | Using elogind will enable a fully working Wayland session for KDE Plasma5.
* Change remaining PRGNAM -> PKGNAM variables Eric Hameleers2020-05-267-22/+22
|
* deps/speech-dispatcher: rebuilt for proper installation of .info files Eric Hameleers2020-05-261-0/+3
|
* Deps/cryfs: rebuilt due to new boost libraries Eric Hameleers2020-05-261-2/+2
|
* Deps: add libqalculate Eric Hameleers2020-05-265-0/+150
| | | | Adds interactive graph plotting to krunner
* Deps: remove sources whose packages are now part of Slackware Eric Hameleers2020-05-2614-710/+0
|
* speech-dispatcher: install info files to the correct location Eric Hameleers2020-05-131-2/+18
|
* Update the deps for the next release of ktown Eric Hameleers2020-04-2615-37/+353
|
* Deps: removed packages that were added to Slackware distro today Eric Hameleers2020-03-2026-1673/+0
| | | | Moved to Slackware: PyQt, PyQt5, QScintilla, gpgme, sip.
* deps/qca-qt5: updated Eric Hameleers2020-03-203-2042/+5
|
* Deps: removed packages that were added to Slackware distro today Eric Hameleers2020-02-1724-981/+1
| | | | Moved to Slackware: brotli, hyphen, socat, qt5-webkit, woff2.
* Deps: added socat as a dependency for kwallet-pam Eric Hameleers2020-02-155-0/+162
|
* Remove deps that are now part of Slackware Eric Hameleers2020-02-1557-2901/+187
| | | | | | OpenAL got added to Slackware as 'openal-soft'; SDL_sound is now part of the Slackware 'sdl' package; libxkbcommon and qt5 were added to Slackware in the 'L' series.
* Deps: remove cracklib which is now in Slackware itself Eric Hameleers2020-02-135-265/+0
|
* DEPS: updated qt5 Eric Hameleers2020-01-223-1/+90
| | | | | Patches applied that address two vulnerabilities: CVE-2020-0569 and CVE-2020-0570
* DEPS: update to noto-cjk-font-ttf Eric Hameleers2020-01-224-25/+243
| | | | | Also fixed file permission of the .ttc file which prevented it from being found at all. Added a Serif .ttc file as well.
* Recompilations caused by the update to Python 3.8 in -current Eric Hameleers2020-01-0110-11/+11
|
* Deps: update QScintilla to match the version in Slackware Eric Hameleers2019-12-232-2/+2
|
* Deps: updates (lensfun, mlt, sip) and addition (md4c) Eric Hameleers2019-12-2211-13/+158
|
* Deps: remove qt-gstreamer which was only used by KDE Telepathy Eric Hameleers2019-11-2810-344/+0
|
* Deps: remove dependencies that are now included in slackware Eric Hameleers2019-11-2411-477/+0
|
* Deps: remove qt5-speech and telepathy from meta SlackBuild scripts Eric Hameleers2019-11-242-4/+0
| | | | | | - a separate qt5-speech has been removed because it's already contained in the big qt5 package - telepathy was removed completely
* Deps: update/recompile QScintilla and dvdauthor Eric Hameleers2019-11-123-6/+85
|
* Remove package files added by accident Eric Hameleers2019-11-126-93/+0
|
* Deps: updates for qt5 and PyQt5 Eric Hameleers2019-11-114-24/+9
|
* Deps: add exiv2 and LibRaw updates to the official packages Eric Hameleers2019-11-1111-0/+453
| | | | | | | | Newer exiv2 is required to compile the latest Digikam 6.4.0. Pat threw LibRaw in the mix for good measure. Then he added the shared libraries of the official Slackware versions of these packages to aaa_elflibs so that no breakage to official packages will occur when you upgrade to their updated ktown versions.
* Deps: remove qt5-speech Eric Hameleers2019-11-114-154/+0
| | | | ...because this is already all contained in the big qt5 package...
* Deps: rebuilt qt5, qt5-webkit and upgraded sip Eric Hameleers2019-10-196-8/+153
| | | | | The qt5 and qt5-webkit packages needed to be rebuilt against the new icu4c. The sip package was upgraded to the version which is also used in Slackware.
* Update the deps - cracklib, phonon and phonon-vlc Eric Hameleers2019-10-137-107/+101
|
* Remove telepathy dependencies and stop building KDE Telepathy Eric Hameleers2019-10-1371-2981/+0
|
* Deps: add phonon support for kdelibs and Qt4 based applications Eric Hameleers2019-09-159-7/+316
| | | | | | | | | | Used the last versions of phonon and phonon-gstreamer that still had Qt4 support and renamed the packages to 'phonon-qt4' and 'phonon-qt4-gstreamer' so as not to make them clash with the Qt5 based phonon packages. Note that at leasr one backend is required to produce sound at all, so I chose the gstreamer based backend because gstreamer is part of Slackware and VLC is not.
* Deps: updated for the upcoming release Eric Hameleers2019-09-1422-160/+165
| | | | | | | | | The qt5 and qt5-speech packages have been updated to 5.13.1, PyQt5 was updated to 5.13.0. There's a new official polkit-qt5-1 version too: 0.113.0. The cryfs package was updated to 0.10.2. Tthe phonon layer is now Qt5-only: phonon 4.11.0, phonon-gstreamer 4.10.0, phonon-vlc 0.11.0.
* Deps/telepathy: updates Eric Hameleers2019-09-145-43/+75
| | | | New versions of libsignon-glib and telepathy-accounts-signon.
* Packages rebuilt/upgraded due to newer ffmpeg/libevent in -current Eric Hameleers2019-08-0617-55/+71
| | | | | | | | | | | | | | | | Deps: - rebuilt qt5 (for the new libevent). - rebuilt OpenAL and mlt (for the new ffmpeg). - upgraded opencv, qrencode, qtav, sip and QScintilla. - removed PyQT (since this now properly landed in -current) Frameworks: - rebuilt prison (for the new qrencode) and kfilemetadata5 (new ffmpeg). Plasma: - rebuilt ksysguard (for the new libevent). Applications: - rebuilt ffmpegthumbs and k3b (for the new ffmpeg). Applications-extra: - upgraded digikam and krita.
* Deps: tell xorg-server to use /dev/shm as shared-memory directory Eric Hameleers2019-07-111-0/+1
|
* Deps: polishing some of the slack-desc files Eric Hameleers2019-07-113-4/+4
|
* Deps: updates to opencv, frei0r-plugins and mlt Eric Hameleers2019-07-117-21/+72
|