summaryrefslogtreecommitdiffstats
path: root/deps/grantlee/grantlee.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'deps/grantlee/grantlee.SlackBuild')
-rwxr-xr-xdeps/grantlee/grantlee.SlackBuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/deps/grantlee/grantlee.SlackBuild b/deps/grantlee/grantlee.SlackBuild
index a9e437e..e4afb09 100755
--- a/deps/grantlee/grantlee.SlackBuild
+++ b/deps/grantlee/grantlee.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2015, 2016, 2017 Eric Hameleers, Eindhoven, NL
+# Copyright 2015, 2016, 2017, 2020 Eric Hameleers, Eindhoven, NL
# Copyright 2015 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
@@ -25,10 +25,10 @@
# Used to be called 'grantlee-qt5'
PKGNAM=grantlee
SRCNAM=grantlee
-VERSION=${VERSION:-5.1.0}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-5.2.0}
+BUILD=${BUILD:-1}
-NUMJOBS=${NUMJOBS:--j7}
+NUMJOBS=${NUMJOBS:-$(nproc)}
# Automatically determine the architecture we're building on:
MARCH=$( uname -m )
@@ -79,10 +79,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-## Don't make it clash with grantlee 0.x:
-#sed -i CMakeLists.txt \
-# -e 's|INCLUDE_INSTALL_DIR include|INCLUDE_INSTALL_DIR include/grantlee-qt5|'
-
mkdir -p build
cd build
QTDIR=/usr/lib${LIBDIRSUFFIX}/qt5 \
@@ -102,7 +98,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
-cp -a AUTHORS CHANGELOG COPYING* GOALS README \
+cp -a AUTHORS CHANGELOG COPYING* README* \
$PKG/usr/doc/$PKGNAM-$VERSION
mkdir -p $PKG/install