summaryrefslogtreecommitdiffstats
path: root/testing/source/vtown/input-methods/marisa/marisa.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'testing/source/vtown/input-methods/marisa/marisa.SlackBuild')
-rwxr-xr-xtesting/source/vtown/input-methods/marisa/marisa.SlackBuild151
1 files changed, 0 insertions, 151 deletions
diff --git a/testing/source/vtown/input-methods/marisa/marisa.SlackBuild b/testing/source/vtown/input-methods/marisa/marisa.SlackBuild
deleted file mode 100755
index 071802646..000000000
--- a/testing/source/vtown/input-methods/marisa/marisa.SlackBuild
+++ /dev/null
@@ -1,151 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for marisa
-
-# Copyright 2016 Heinz Wiesinger, Amsterdam, The Netherlands
-# Copyright 2016, 2020 Patrick J. Volkerding, Sebeka, MN, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PKGNAM=marisa
-VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d- | rev)}
-BUILD=${BUILD:-1_vtown_1}
-
-NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
-
-# Automatically determine the architecture we're building on:
-MARCH=$( uname -m )
-if [ -z "$ARCH" ]; then
- case "$MARCH" in
- i?86) export ARCH=i586 ;;
- armv7hl) export ARCH=$MARCH ;;
- arm*) export ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) export ARCH=$MARCH ;;
- esac
-fi
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "s390" ]; then
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "armv7hl" ]; then
- SLKCFLAGS="-O2 -march=armv7-a -mfpu=vfpv3-d16"
- LIBDIRSUFFIX=""
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
- exit 0
-fi
-
-TMP=${TMP:-/tmp}
-PKG=$TMP/package-marisa
-
-rm -rf $PKG
-mkdir -p $TMP $PKG
-cd $TMP
-rm -rf marisa-$VERSION
-tar xvf $CWD/marisa-$VERSION.tar.?z || exit 1
-cd marisa-$VERSION || exit 1
-
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \+
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --disable-static \
- --build=$ARCH-slackware-linux
-
-make $NUMJOBS || make || exit 1
-make install DESTDIR=$PKG || exit 1
-
-cd bindings/perl
- perl Makefile.PL \
- INC="-I$TMP/marisa-$VERSION/lib" \
- LIBS="-L$TMP/marisa-$VERSION/lib/.libs" \
- PREFIX=/usr \
- INSTALLDIRS=vendor
-
- make $NUMJOBS || make || exit
- make test || exit 1
- make install DESTDIR=$PKG || exit 1
-cd -
-
-cd bindings/python
- python setup.py build_ext \
- --include-dirs="$TMP/marisa-$VERSION/lib" \
- --library-dirs="$TMP/marisa-$VERSION/lib/.libs" || exit 1
- python setup.py install \
- --root=$PKG || exit 1
-cd -
-
-cd bindings/ruby
- ruby extconf.rb \
- --with-opt-include="$TMP/marisa-$VERSION/lib" \
- --with-opt-lib="$TMP/marisa-$VERSION/lib/.libs" \
- --vendor
- make $NUMJOBS || make || exit 1
- make install DESTDIR=$PKG || exit 1
-cd -
-
-# Don't ship .la files:
-rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
-
-# Remove perllocal.pod and other special files that don't need to be installed,
-# as they will overwrite what's already on the system.
-find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
-
-# Remove empty directories
-find $PKG -depth -type d -empty -delete || true
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
-cp -a AUTHORS ChangeLog COPYING INSTALL NEWS README \
- $PKG/usr/doc/$PKGNAM-$VERSION
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz