summaryrefslogtreecommitdiffstats
path: root/source/y/nethack/nethack.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/y/nethack/nethack.SlackBuild')
-rwxr-xr-xsource/y/nethack/nethack.SlackBuild155
1 files changed, 155 insertions, 0 deletions
diff --git a/source/y/nethack/nethack.SlackBuild b/source/y/nethack/nethack.SlackBuild
new file mode 100755
index 000000000..7171170df
--- /dev/null
+++ b/source/y/nethack/nethack.SlackBuild
@@ -0,0 +1,155 @@
+#!/bin/bash
+
+# Copyright 2020 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PKGNAM=nethack
+VERSION=3.6.6
+SRCVER=366
+BUILD=${BUILD:-1}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$(uname -m)" in
+ i?86) ARCH=i586 ;;
+ arm*) readelf /usr/bin/file -A | egrep -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$(uname -m) ;;
+ esac
+ export ARCH
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
+ exit 0
+fi
+
+# Multi threaded builds do not work.
+#NUMJOBS=${NUMJOBS:-" -j $(expr $(nproc) + 1) "}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "s390" ]; then
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "armv7hl" ]; then
+ SLKCFLAGS="-O3 -march=armv7-a -mfpu=vfpv3-d16"
+ LIBDIRSUFFIX=""
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PKGNAM
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+
+cd $TMP
+rm -rf NetHack-NetHack-${VERSION}_Released
+tar xvf $CWD/nethack-${SRCVER}-src.tar.?z || exit 1
+cd NetHack-NetHack-${VERSION}_Released || exit 1
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \+
+
+# Prepare sources:
+sed -e 's|^/\* \(#define LINUX\) \*/|\1|' \
+ -e 's|^/\* \(#define TIMED_DELAY\) \*/|\1|' -i include/unixconf.h
+
+# Set default directories and install to use setgid games:
+sed -e '/^HACKDIR/ s|/games/lib/\$(GAME)dir|/var/lib/nethack/|' \
+ -e '/^SHELLDIR/ s|/games|/usr/games|' \
+ -e '/^VARDIRPERM/ s|0755|0775|' \
+ -e '/^VARFILEPERM/ s|0600|0664|' \
+ -e '/^GAMEPERM/ s|0755|02755|' \
+ -e 's|\(DSYSCF_FILE=\)\\"[^"]*\\"|\1\\"/var/lib/nethack/sysconf\\"|' \
+ -e 's|\(DHACKDIR=\)\\"[^"]*\\"|\1\\"/var/lib/nethack/\\"|' -i sys/unix/hints/linux
+
+sed -e 's|^#GAMEUID.*|GAMEUID = root|' \
+ -e 's|^#GAMEGRP.*|GAMEGRP = games|' \
+ -e '/^FILEPERM\s*=/ s|0644|0664|' \
+ -e '/^DIRPERM\s*=/ s|0755|0775|' -i sys/unix/Makefile.top
+
+sed -e "/^MANDIR\s*=/s|/usr/man/man6|$PKG/usr/man/man6|" -i sys/unix/Makefile.doc
+
+# Create a few directories:
+mkdir -p $PKG/usr/man/man6
+mkdir -p $PKG/usr/doc/nethack-$VERSION
+mkdir -p $PKG/var/lib
+
+# Prepare to build:
+( cd sys/unix ; sh setup.sh hints/linux )
+
+# Build and install:
+make -j1 install manpages PREFIX=$PKG
+
+# Fix some paths:
+sed -e "s|HACKDIR=$PKG/|HACKDIR=/|" \
+ -e 's|HACK=$HACKDIR|HACK=/usr/share/games/nethack|' \
+ -i $PKG/usr/games/nethack
+mkdir -p $PKG/usr/share/games/nethack
+mv $PKG/var/lib/nethack/{nethack,recover} $PKG/usr/share/games/nethack
+
+# Fix perms:
+chown -R root:games $PKG/var/lib/nethack
+chown root:games $PKG/usr/share/games/nethack/{nethack,recover}
+chmod 2755 $PKG/usr/share/games/nethack/{nethack,recover}
+
+# Add some documentation:
+mkdir -p $PKG/usr/doc/nethack-$VERSION
+cp -a \
+ Porting README* \
+ dat/license \
+ doc/Guidebook.txt \
+$PKG/usr/doc/nethack-$VERSION
+
+# Strip binaries:
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+# Compress manual pages:
+find $PKG/usr/man -type f -exec gzip -9 {} \+
+for i in $( find $PKG/usr/man -type l ) ; do
+ ln -s $( readlink $i ).gz $i.gz
+ rm $i
+done
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz